Solved

TypeName property of ObjectDataSource 'ObjectDataSource1' could not be found on GoDaddy hosting account

Posted on 2009-04-13
4
1,934 Views
Last Modified: 2012-05-06
I receive the below message on my GoDaddy hosted account.  My application works perfectly on my local pc and all else works except this one connection.  This objectDataSource1 is calling an .xsd/.xss under app_code.  The type specified in the TypeName property of ObjectDataSource 'ObjectDataSource1' could not be found.
Partial Code:

<asp:GridView ID="GridView1" 

    runat="server" 

    AllowPaging="True" 

    AllowSorting="True"

    AutoGenerateColumns="False" 

    DataSourceID="ObjectDataSource1" 

    Style="z-index: 100;left: 128px; position: absolute; top: 155px" 

    Width="850px" BackColor="White" CellPadding="4" 

    ForeColor="Black" GridLines="Vertical" PageSize="40">

         <Columns>
 

   <asp:ObjectDataSource ID="ObjectDataSource1" runat="server" OldValuesParameterFormatString="original_{0}"

        SelectMethod="GetRideRequests" TypeName="ViewRidesTableAdapters.v_RequestRideTableAdapter">

    </asp:ObjectDataSource>

Open in new window

0
Comment
Question by:ppeterso
  • 2
4 Comments
 
LVL 3

Expert Comment

by:OmerFarukZ
ID: 24135488
      <Columns> tag is missing?

try this:

<asp:GridView ID="GridView1"
    runat="server"
    AllowPaging="True"
    AllowSorting="True"
    AutoGenerateColumns="False"
    DataSourceID="ObjectDataSource1"
    Style="z-index: 100;left: 128px; position: absolute; top: 155px"
    Width="850px" BackColor="White" CellPadding="4"
    ForeColor="Black" GridLines="Vertical" PageSize="40">
</asp:GridView>


 
   <asp:ObjectDataSource ID="ObjectDataSource1" runat="server" OldValuesParameterFormatString="original_{0}"
        SelectMethod="GetRideRequests" TypeName="ViewRidesTableAdapters.v_RequestRideTableAdapter">
    </asp:ObjectDataSource>
 
0
 
LVL 29

Accepted Solution

by:
David H.H.Lee earned 500 total points
ID: 24135522
Hi ppeterso,
It could be configuration issue. Have you set the folder as application in IIS?
Check this similiar asked thread:
http://www.tek-tips.com/viewthread.cfm?qid=1227255&page=1

If the proposed not resolve the issue, try to contact GoDaddy's support for further clarifications.
Hope it helps.
0
 

Author Comment

by:ppeterso
ID: 24139374
I will test this out and get back to you if it resolves the issue.  Thank you for the quick response.
0
 

Author Closing Comment

by:ppeterso
ID: 31569770
This worked!  Thank you, thank you.  I had to move my aspx forms up one level to a higher directory and then set that as an application in IIS settings.  
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

User art_snob (http://www.experts-exchange.com/M_6114203.html) encountered strange behavior of Android Web browser on his Mobile Web site. It took a while to find the true cause. It happens so, that the Android Web browser (at least up to OS ver. 2.…
Problem Hi all,    While many today have fast Internet connection, there are many still who do not, or are connecting through devices with a slower connect, so light web pages and fast load times are still popular.    If your ASP.NET page …
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now