Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 497
  • Last Modified:

User cannot access "My Documents" on Server 2003

On a Server 2003 network users "My Documents" are redirected to Z:\Docs\User Name

File permissions are inherited from Z:\Docs. A user requested that they be the sole person with read access to their documents. At that point Administrators, authenticated users, creator owner and the user had access to the documents.

On trying to remove "Authenticated Users" I received the popup that this could not be done with inheritable permissions ticked. This was unticked and that group removed. Since then there is no access to subfolders, even when "authenticated users" are added and inheritable permissions are reinstated.

The effective permissions for that user show that they should have access but access is denied to all subfolders (even with inheritence enabled).

How can I get Administrators and that user access to the files again?
0
localhost_offline
Asked:
localhost_offline
  • 2
  • 2
1 Solution
 
ryan80Commented:
When you removed the inheritance, did you copy over the settings, or remove them entirely?  Do the folders underneath have inheritance?  have you given the users full control?  Unless you are missing something, it sounds like it should be working.  And you said you checked the effective permissions for the sudfolders and files? and it looks correct?

Here are some things you can try if things are really hosed up:

Remove ALL security setting on this folder then add desired permissions one by one.

Back the folder.

Solutions 1:
Remove all Groups and/or user in security tab
Uncheck "inherit for parent the permission entries that apply to child"
      Click remove when prompted
Check "Replace permission entries on all child objects……"
Click ok. And ok again to exit out of properties.

Go to security tab again in properties. Assign new rights.
Go to Owner tab in advanced assign new permissions


Solution 2:
If you have read permission on the files. Copy all file to an another partition formatted as ntfs or fat16/32.
Delete to original and  you should have full rights to the new copy.

0
 
localhost_offlineAuthor Commented:
At this stage I cannot copy the files - access denied. i can change ownership, that's all.

If I remove all groups will I still be able to apply permissions?
0
 
ryan80Commented:
If you make yourself the owner, you should be able to apply permissions.  But since the permissions seem to be acting funny, test it with an individual file or folder first.
0
 
localhost_offlineAuthor Commented:
Here's what I think happened. I ticked deny all for authenticated users, this seems to have propagated throughout.

The only way around was to give ownership to Administrators, and then set full permissions on each file / subfolder and appears to be working ok.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now