Solved

Remove Internet Explorer security warning on terminal servers (Citrix)

Posted on 2009-04-14
7
1,495 Views
Last Modified: 2012-05-06
Hi all!

I have a problem.
When users are searching for a telephone number or a user in Trio Present on a Citrix Desktop server a message appears in Internet Explorer:
"When you send information to the internet, it might be possible for others to see that information. do you want to continue?"

I found the registry setting that disable this message:
HCLM\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\INTERNET SETTINGS\ZONES\3 and the key is 1601

Values:
0 = do not prompt
1 = Prompt with checkbox checked
101 = Prompt with checkbox unchecked

I made a script:
SET WSHShell = CreateObject("WScript.Shell")

'Removes security warning in Internet Explorer

WshShell.RegWrite "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3\1601","00000000","REG_DWORD"

I have tried this script and it works, it changes the registry so the message do not appear.

I tried to link this script into the GPO for Terminal Servers (User Configuration-Windows Settings-Scripts-Logon), but when a user logs on the registry isn`t changed.
If I try to connect to a Citrix Desktop server via RDP the registry is changed, but not via Citrix. (This is because I use my admin user, not my ordinary user)

This only happens when a user connects to a Citrix desktop server.
If`I try to check the box "don`t show this message again" the message still shows up the next time I log in via Citrix to that Desktop server.

Does anyone have a clue or a solution I would be very pleased.
My customer wants this message to disappear.
0
Comment
Question by:Lazyeyes
  • 5
  • 2
7 Comments
 
LVL 18

Expert Comment

by:chuckyh
ID: 24137340
That key you are setting is in HKLM, try setting the one in HKCU instead. Or you can turn on loop back processing for GPO.
0
 
LVL 1

Author Comment

by:Lazyeyes
ID: 24137695
My script points to HKCU, so I already tried that.

WshShell.RegWrite "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3\1601","00000000","REG_DWORD"

Also tried to point the script to HKLM, that works but HKCU still shows wrong value even if I have enabled loopback.
Something is blocking users to edit registry settings, but I have no problems changing registry settings via ICA connection.

The settings getting "restored" each time I login the second time.

0
 
LVL 18

Expert Comment

by:chuckyh
ID: 24138207
Is the GPO applied to the citrix servers or the users? Can you run policy wizard to see which settings actually gets applied?
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 1

Author Comment

by:Lazyeyes
ID: 24146040
The GPO is applied to the Citrix servers OU. The settings gets applied (tried with an msgbox in the script). I think the problem is that the logon script is running after the script in the GPO
0
 
LVL 1

Author Comment

by:Lazyeyes
ID: 24146106
If I log on to the desktop server the value in registry is wrong, but if I do a gpupdate the value change in registry. Gotta be the logon script that mess things up. The strange part is that the changes isn`t saved to the registry when I log off.
0
 
LVL 1

Accepted Solution

by:
Lazyeyes earned 0 total points
ID: 24156137
I found the policy that messed up the registry setting.
User Configuration- Internet Explorer Maintenance- Security/ Security Zones and Content Ratings- Security Zones and Privacy-Internet- "Submit nonecrypted form data"

Anyway, I put the registry settings into the logonscript, seems to work now.
0
 
LVL 1

Author Comment

by:Lazyeyes
ID: 24178632
Found it out myself
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

After several days of searching and hunting for limited documentation, I wanted to share this guide to hopefully save someone the hassle of trying to figure this out on their own. I have tested this on Xendesktop 7.1 and PS 4.5 running simultaneous…
Citrix XenDesktop 7.6 Citrix Policies Graphics
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now