Solved

SBS 2008 Autodiscover

Posted on 2009-04-14
6
527 Views
Last Modified: 2012-05-06
Hi.  Have a new SBS 2008 server which is all working nicely except that when I setup an external Outlook 2007 client, autodiscover sets everything up fine but gets the authentication wrong in the connection settings - ie Basic not NTLM.  Have been trawling the web for info but cant see the wood for the trees now...
0
Comment
Question by:donmeado
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 4

Expert Comment

by:dud386
ID: 24138111
So do you want to change the authentication on the client or server?
To change the authentication on the client:

1. In Outlook > click Tools > Account Settings
2. Click the Change button
3. Click the More Settings button
4. Click the Connections tab
5. At the bottom, click the Exchange Proxy Settings button
6. Under Proxy Authentication Settings, use the drop down to change authentication.
0
 
LVL 1

Author Comment

by:donmeado
ID: 24138148
Hi

Server.

What I need is for the Autodiscover service to set this automatically to NTLM rather than have to go in there manually.  If I manually change it to NTLM all works fine.

Cheers
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24138255

Basic Authentication is the default which Outlook will use. What result do you get if you run a get-OutlookAnywhere|fl at Exchange Management Shell? (Post the result here).

-Matt
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 1

Author Comment

by:donmeado
ID: 24138459
Have removed identity of server etc (replaced with -)

I can see it's showing basic.  So will Autodiscover automaticically use that value if I change to NTLM.  Is there a reason I should leave it as basic?  The RPC not found error is presumably because RPC is in SBS Web Applications rather than Default Website (which SBS did itself, not me (I hope)).

[PS] C:\Windows\System32>get-OutlookAnywhere|fl
WARNING: IIS://-/W3SVC/1/ROOT/Rpc was not found. Please
make sure you have typed it correctly.


ServerName                 : -
SSLOffloading              : False
ExternalHostname           : -
ClientAuthenticationMethod : Basic
IISAuthenticationMethods   : {Basic, Ntlm}
MetabasePath               : IIS://-/W3SVC/1/ROOT/Rpc
Path                       :
Server                     : -
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Rpc (Default Web Site)
DistinguishedName          : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=
                             -,CN=Servers,CN=Exchange Administrative Group
                              (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=-
                             -,CN=Microsoft Exchange,CN=Services,CN=Confi
                             guration,DC=-,DC=local
Identity                   : -\Rpc (Default Web Site)
Guid                       : 038fe47b-5a9f-4b75-9f72-169534e36cd3
ObjectCategory             : -/Configuration/Schema/ms-Exch-Rpc-
                             Http-Virtual-Directory
ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
                             Directory}
WhenChanged                : 09/04/2009 17:56:54
WhenCreated                : 09/04/2009 17:56:54
OriginatingServer          : -
IsValid                    : True
0
 
LVL 58

Accepted Solution

by:
tigermatt earned 500 total points
ID: 24138582

I've had my issues with this on SBS. Firstly, you'll need to patch with this hotfix: http://support.microsoft.com/kb/954034.

Once that's patched, I'd then run set-OutlookAnywhere -Identity "<value in the 'Identity' section of the get-OutlookAnywhere output>" -ClientAuthenticationMethod basic -IISAuthenticationMethods basic

Then, launch the TS Gateway Manager console from Administrative Tools > Terminal Services. Doing that will reset the TS Gateway configuration, and should get the two to co-exist.

-Matt
0
 
LVL 1

Author Closing Comment

by:donmeado
ID: 31569875
Thanks tigermatt, that got me to the right settings to finish the job. Cheers.
0

Featured Post

How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question