Solved

Can't access a secondary drive on a network.

Posted on 2009-04-14
22
357 Views
Last Modified: 2012-05-06
OK, maybe I didn't explain the problem in a clear enough manner last time, so let me start all over again...

The two main machines involved are:

Machine A:  Sony laptop running Windows Vista.  1 hard drive
Machine B:  Desktop running Windows XP Pro SP3. 2 hard drives.

We are trying to get Machine A to access both hard drives in Machine B.  We have shared both hard drives in Machine B.  Machine A has full access to the C drive in Machine B(the main drive).  No problem.  Then we shared drive D in Machine B.  Machine A can see it, but not access it.  We used the same sharing proceedures as the C drive, but are still not able to have full access to the D drive in Machine B.  We are getting an error message that says we don't have the proper permission to access the D drive in Machine B.  Simple file sharing is activated and we can still only see the D drive in Machine B...not access it.
Accessing the C Drive in Machine B is still happening, but we can still only see the D Drive and not access it.
Since our error message says that we don't have the proper permission to access the D Drive in Machine B, we gave the "Guest" administrator permissions in the Users on Machine B...but still we cannot access the D drive in Machine B.  It still says we don't have the proper permission to acces it.
How do we give permission to access the D Drive in Machine B?  
0
Comment
Question by:NCSAV
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
  • 5
  • +1
22 Comments
 
LVL 3

Accepted Solution

by:
mikey1h earned 500 total points
ID: 24139982
On machine B     open my computer, right  click Drive D, and properties.    under sharing, check permissions and make sure that woever you are assigning rights to, and/or everyone is listed and has full control.   if not there, click the add button and put them in.

then under security, do the same
0
 
LVL 10

Expert Comment

by:Vince Glisson
ID: 24140020
Right click on the D drive on machine B,go to properties, under the security tab look for the user account from machine A that you want to have access to drive D on machine B.
If its not there you need to add it.
What does your network look like, windows domain - small office network, etc...
mesavince
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24140187
Is the drive formatted NTFS ?

0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24140203
On Machine B,

CONVERT D: /FS:NTFS
0
 

Author Comment

by:NCSAV
ID: 24153637
OK, I have tried what you all have suggested with no luck at all.  The drive we're tyring to access is formatted NTFS and the network is a home network.  We still cannot access the D drive on the B machine.  

Any other ideas??
0
 
LVL 3

Expert Comment

by:mikey1h
ID: 24153650
try to map the drive , but use the ip address of the shared folder....  when you map it,      format the location as   \\ipaddress\sharename

0
 
LVL 10

Expert Comment

by:Vince Glisson
ID: 24154540
What is the share name, does it end with a $ sign?
When you add permissions for the D: drive, are you adding the account that is on Machine A.
Machine A\user
0
 

Author Comment

by:NCSAV
ID: 24205525
mikey1h,

It won't map.  It says that I don't have the permission.

0
 

Author Comment

by:NCSAV
ID: 24205584
MesaVince,

Nope, no "$" after the drive letter.  Already checked for that.  Now, where are you adding the permissions?  Are you going to "Manage"?  Are you going to "My Computer" --> "Sharing"?  If so, I saw no place to add a specific user.

One thing to note...When I share the "C" Drive on Machine B, Windows automatically sets the folder settings.  It does not do that for the "D" Drive.  
0
 
LVL 3

Expert Comment

by:mikey1h
ID: 24205770
On my computer, right click the drive >sharing and security
There should be a button there for permissions.    also don't forget to check the security tab and make sure the appropriate users are allowed there as well
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24205798
Sounds like you have windows "simple file sharing" turned on....

You can turn it off and "take ownership" of the entire drive and it's contents.

Open a folder...click "Tools>Folder Options, choose the "Veiw" tab.... and the last option in the underlying list is "Use Simple File sharing"...  uncheck that....

Now right click the D: from "my computer"..... look for the "security" tab... click  "advanced" button....and choose the "Owner" tab....   choose the current account as the new owner, check the bottom box to apply to all sub folders/files... click ok, click apply...   wait ....

Close the property page and re-open it.... you should have the ability to both browse the drive and set new ntfs security on it.
0
 

Author Comment

by:NCSAV
ID: 24375653
OK...got the solution.

I aplologize for not writing sooner, but all the solutions above did nothing.  I want to thank you for trying, but there was no solution which worked.

I finally had to call Microsoft and pay money for the answer, which I will now share with you.

To get full access, you have to open "My Computer" on the Vista machine and go to the hard drive in question.  Right click on the hard drive and go to "Sharing".  Once at "Sharing", you click the "Security" tab which will show the permissions.  You then delete all the permissions and add "Everyone" with full administrative access.  Restart the machine and you're up and running.
0
 
LVL 3

Expert Comment

by:mikey1h
ID: 24376049
Author stated that this was due to adding EVERYONE to the securities.     In the first post (mine) for this question, I instructed him to make sure all users AND e3veryone had full control;
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24376160
I also object...
mikey1h was right on the money....
0
 

Author Comment

by:NCSAV
ID: 24385456
All,
Allow me to present the difference between the solution Microsoft gave me and your solution.

Mikey1h gave the following solution...
"...In the first post (mine) for this question, I instructed him to make sure all users AND e3veryone had full control;"

What I posted was very different. It included what Mikey1h suggested, but his suggestion did not work until...and let me quote here..."You then delete all the permissions...".

Just simply adding "Everyone" to the permissions doesn't work...you have to blow out everything else and then add "Everyone".

0
 
LVL 3

Expert Comment

by:mikey1h
ID: 24385522
not so.....    we have different user accounts set up here for various permissions  and EVERYONE set as read only, and they all work together.    in order for a user account to override the everyone settings, the account would have to be set to deny a cerain permission
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24385673
I agree with mikey still,

Whether or not you "blow everything out".... if the everyone group was added to share permissions as well as the security tab with full control...as was stated, it's essentially the same exact solution Microsoft walked you through...

As long as there were no DENY permissions overriding it on the security tab...which would have been pretty obvious just looking at the list, then it would work as expected.

I'm assuming you didn't look at the security tab as mikey1h instructed in the first post.... but when you talked with microsoft they had the advantage of walking you through it step by step over the phone with the same exact solution.

Don't be stingy with the points man.... keep in mind that all of us experts do this for free.
0
 
LVL 10

Expert Comment

by:Vince Glisson
ID: 24390264
messavince votes for #3 post id = 24139982
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 24390463
3 !
0
 
LVL 3

Expert Comment

by:mikey1h
ID: 24391519
3
0

Featured Post

Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question