Solved

Internal Postmaster NDRs

Posted on 2009-04-14
9
2,506 Views
Last Modified: 2012-05-06
I have no issues with the external postmaster NDRs, but I wanted to know if anyone knew why the internal FROM comes back as "MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@domain.com".

Is there something that needs to be configured for it to show "Postmaster" to my internal users?

Thanks.
0
Comment
Question by:ovationit
  • 4
  • 3
  • 2
9 Comments
 
LVL 65

Expert Comment

by:Mestha
ID: 24140257
Have you set a postmaster@ email address on the system?

Simon.
0
 

Author Comment

by:ovationit
ID: 24140286
Yes, I have a mailbox with the smtp address for postmaster@domain.com.  Initially, it's just a user mailbox that I will change over to a shared mailbox once I know the internal postmaster is responding correctly.
0
 
LVL 4

Expert Comment

by:dud386
ID: 24140388
Check this out, I used it the other day to change the NDRs: http://technet.microsoft.com/en-us/library/bb400930.aspx

Particular emphasis on the Get-OrganizationConfig and Set-OrganizationConfig cmdlets.

Get will show you that mailbox that it's sending from. Set will help you change it.
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:ovationit
ID: 24141609
So I ran the Get-OrganizationConfig cmdlet and have the following (I excluded everything not relavent):

MicrosoftExchangeRecipientEmailAddresses            : {smtp:MicrosoftExchange32
                                                      9e71ec88ae4615bbc36ab6ce4
                                                      1109e@<domain>, smtp:M
                                                      icrosoftExchange329e71ec8
                                                      8ae4615bbc36ab6ce41109e@<
                                                      domain>, SMTP:Mi
                                                      crosoftExchange329e71ec88
                                                      ae4615bbc36ab6ce41109e@<d
                                                      omain>}
MicrosoftExchangeRecipientReplyRecipient            : domain/Users/Postmas
                                                      ter
MicrosoftExchangeRecipientPrimarySmtpAddress        : MicrosoftExchange329e71ec
                                                      88ae4615bbc36ab6ce41109e@
                                                      <domain>
MicrosoftExchangeRecipientEmailAddressPolicyEnabled : True

I attempted both Set-OrganizationConfig -MicrosoftExchangeRecipientEmailAddresses postmaster@domain and Set-OrganizationConfig -MicrosoftExchangeRecipientEmailAddresses "Postmaster".  Neither accepted the command.  The first attempt indicated that the smtp address I entered was already being used.  This was a result of having to build a new mailbox with the smtp address automatically configured.  I thought that by doing this, I wouldn't get the MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@<domain> this is showing in the FROM field of an internal NDR.  Am I on the right track?
0
 
LVL 4

Accepted Solution

by:
dud386 earned 250 total points
ID: 24142409
You're on the right track. You will have to disable the Email Policy and add a new address to change the from:

Set-OrganizationConfig -MicrosoftExchangeRecipientEmailAddressPolicyEnabled $False

Then you can assign the email address you want:

Set-OrganizationConfig -MicrosoftExchangeRecipientEmailAddresses email@domain.com

Now all this does is add an alias to the MicrosoftExchange32                                                      9e71ec88ae4615bbc36ab6ce41109e account. So you're not going to be able to use Postmaster. Just make up something, I used the company name and then postmaster, so it was: CompanyPostmaster@domain.com
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24143797
Just in case anyone is interested, I think the reason you are seeing this address is because of this change in Rollup 7.

http://support.microsoft.com/default.aspx?kbid=969690

Simon.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24146172
The only way to fix this is to either
a. Remove rollup 7
b. Wait for the next rollup which has a fix.
c. Call Microsoft and ask for the interim hotfix which resolves the issue.

Simon.
0
 

Author Closing Comment

by:ovationit
ID: 31570003
dud386, this worked like a charm.  Thanks for your help.  And BTW, I had recently updated Exchange 2007 to rollup 7.
0
 

Author Comment

by:ovationit
ID: 24147631
Mestha, thanks for your help, too.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video discusses moving either the default database or any database to a new volume.

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question