Solved

Cisco ASA5510 DMZ

Posted on 2009-04-14
9
923 Views
Last Modified: 2012-06-21
I have an ASA5510.  I need to configure port #2 as a DMZ port.  I want to route ALL traffic, ALL services, ALL ports (including ping) that come in on a particular IP 12.100.99.72 to go to this ASA port and my ip phone system.  The IP phone system has a 10.10.10.221 IP address.

Tried following the cisco directions, found them quite lacking.

Anybody have detailed directions for dummies on how to do this?

Thanks in advance...
0
Comment
Question by:bnhcomputing
  • 6
  • 3
9 Comments
 
LVL 5

Expert Comment

by:andrewis
ID: 24140506
you will need to create a static NAT entry with an ACL allowing this traffic in.

example
static (dmz,outside) 12.100.99.72 10.10.10.221 netmask 255.255.255.255 <- this is the one to one NAT
access-list <acl_name> permit ip any host 12.100.99.72 <- this is the ACL allowing all services to IP 12.100.99.72

You more than likely already have an outside rule set so take a look in your config for the access-group command and add that ACL to your already configured list

access-group <acl_name> in interface outside <-- look for this command to see what ACL is tied to your outside interface.


0
 

Author Comment

by:bnhcomputing
ID: 24140903
Thank you for the suggestion.  That is what I think I did, but I still do not get a response from tying to ping or telnet to my outside IP address which I'd rather not publish.

Is there anywhare to find step-by-step instructions?
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24141250
if you post a scrubbed config I should be able to tell you whats up.

0
 

Author Comment

by:bnhcomputing
ID: 24141269
Please forgive my stupidity, but
I telnet in, and enable, and then show run or something like that, right?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:bnhcomputing
ID: 24141364
I think this is what you are looking for
ASA5510# show run

: Saved

:

ASA Version 8.0(4)

!

hostname ASA5510

domain-name mydomain.com

enable password xxwwzz encrypted

passwd xxyyzz encrypted

names

name 10.100.2.0 Illinois description Illinois Office

name 10.100.1.3 Inside-SBS-Server

name 122.148.198.150 Outside-MSExchange

name 122.148.198.149 Outside-PhoneSystem

name 10.10.10.0 Software-VPN-Clients

name 10.100.10.253 Inside-PhoneSystem

dns-guard

!

interface Ethernet0/0

 nameif Outside

 security-level 0

 ip address 122.148.198.147 255.255.255.248

!

interface Ethernet0/1

 nameif Inside

 security-level 100

 ip address 10.100.1.5 255.255.255.0

!

interface Ethernet0/2

 nameif PhoneSystem

 security-level 0

 ip address 10.100.10.254 255.255.255.0

!

interface Ethernet0/3

 shutdown

 no nameif

 no security-level

 no ip address

!

interface Management0/0

 nameif management

 security-level 100

 ip address 192.168.1.1 255.255.255.0

 management-only

!

boot system disk0:/asa804-k8.bin

ftp mode passive

clock timezone CST -6

clock summer-time CDT recurring

dns server-group DefaultDNS

 domain-name mydomain.com

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 www

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 smtp

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 995

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 https

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 444

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 4125

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq

 ldap

access-list Outside_access_in extended permit ip any host Outside-PhoneSystem

access-list Outside_access_in extended permit tcp any host Outside-PhoneSystem

access-list Outside_access_in extended permit udp any host Outside-PhoneSystem

access-list Outside_access_in extended permit udp any host Outside-PhoneSystem e

q www

access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 Il

linois 255.255.255.0

access-list Inside_nat0_outbound extended permit ip any Software-VPN-Clients 255

.255.255.0

access-list Split_Tunnel_List standard permit 10.100.1.0 255.255.255.0

access-list Outside_1_cryptomap extended permit ip 10.100.1.0 255.255.255.0 Ill

inois 255.255.255.0

access-list PhoneSystem_access_in extended permit ip any any

access-list PhoneSystem_access_in extended permit ip host Outside-PhoneSystem ho

st Inside-PhoneSystem

access-list PhoneSystem_access_in extended permit tcp host Outside-PhoneSystem h

ost Inside-PhoneSystem eq www

access-list PhoneSystem_access_in extended permit tcp host Outside-PhoneSystem h

ost Inside-PhoneSystem eq https

access-list PhoneSystem_access_in extended permit ip host Inside-PhoneSystem any
 

pager lines 24

logging enable

logging asdm informational

mtu Outside 1500

mtu Inside 1500

mtu PhoneSystem 1500

mtu management 1500

ip local pool VPN-Pool 10.10.10.1-10.10.10.255 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

asdm history enable

arp timeout 14400

global (Outside) 10 interface

nat (Inside) 0 access-list Inside_nat0_outbound

nat (Inside) 10 0.0.0.0 0.0.0.0

static (Inside,Outside) Outside-MSExchange Inside-SBS-Server netmask 255.255.255

.255

static (Inside,PhoneSystem) 10.100.1.0 10.100.1.0 netmask 255.255.255.0

static (PhoneSystem,Inside) Outside-PhoneSystem Inside-PhoneSystem netmask 255.2

55.255.255

static (PhoneSystem,Outside) Outside-PhoneSystem Inside-PhoneSystem netmask 255.

255.255.255

static (PhoneSystem,Inside) Inside-PhoneSystem Outside-PhoneSystem netmask 255.2

55.255.255

access-group Outside_access_in in interface Outside

access-group PhoneSystem_access_in in interface PhoneSystem

route Outside 0.0.0.0 0.0.0.0 122.148.198.146 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 management

http 10.100.1.0 255.255.255.0 Inside

http 26.40.114.24 255.255.255.255 Outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128

-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256

-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association life

time seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association life

time kilobytes 4608000

crypto map Outside_map 1 match address Outside_1_cryptomap

crypto map Outside_map 1 set pfs

crypto map Outside_map 1 set peer 169.99.136.249

crypto map Outside_map 1 set transform-set ESP-3DES-SHA

crypto map Outside_map 1 set security-association lifetime seconds 28800

crypto map Outside_map 1 set security-association lifetime kilobytes 4608000

crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map Outside_map interface Outside

crypto map Inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map Inside_map interface Inside

crypto isakmp enable Outside

crypto isakmp enable Inside

crypto isakmp policy 10

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp nat-traversal 30

telnet 10.100.1.0 255.255.255.0 Inside

telnet timeout 5

ssh 26.40.114.24 255.255.255.255 Outside

ssh timeout 60

console timeout 0

management-access Inside

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics host

threat-detection statistics port

threat-detection statistics protocol

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

ntp server Inside-SBS-Server source Inside prefer

group-policy GroupPolicy2 internal

group-policy GroupPolicy2 attributes

 vpn-filter none

 vpn-tunnel-protocol IPSec

group-policy Wysocki-VPN-Client internal

group-policy Wysocki-VPN-Client attributes

 dns-server value 10.100.1.3 66.170.2.177

 vpn-tunnel-protocol IPSec

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value Split_Tunnel_List

username admin password UpSGCNJD1nBLFmwQ encrypted privilege 15

username kathy password QP6B7KR8z6zODExc encrypted privilege 0

username kathy attributes

 vpn-group-policy Wysocki-VPN-Client

username hubert password yeI7IXaQndhunp5y encrypted privilege 15

username hubert attributes

 vpn-group-policy Wysocki-VPN-Client

username rmmsolutions password 2XIysAdHiN4xxCEw encrypted privilege 15

tunnel-group Wysocki-VPN-Client type remote-access

tunnel-group Wysocki-VPN-Client general-attributes

 address-pool VPN-Pool

 default-group-policy Wysocki-VPN-Client

tunnel-group Wysocki-VPN-Client ipsec-attributes

 pre-shared-key *

tunnel-group 169.99.136.249 type ipsec-l2l

tunnel-group 169.99.136.249 general-attributes

 default-group-policy GroupPolicy2

tunnel-group 169.99.136.249 ipsec-attributes

 pre-shared-key *

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns migrated_dns_map_1

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns migrated_dns_map_1

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:ecc166da8c94bed3cef46501e6ff4a43

: end

ASA5510#

Open in new window

0
 
LVL 5

Expert Comment

by:andrewis
ID: 24141656

Your config looks OK

try adding the following command and try again

conf t
same-security-traffic permit inter-interface

Both your outside interface and phonesystem interface have the same security level so this command will allow traffic to pass between them


0
 

Author Comment

by:bnhcomputing
ID: 24142054

Still no luck, cannot ping the phone device.
0
 

Author Comment

by:bnhcomputing
ID: 24186186

I now have some of it working.  The outside trafic coming in seems to be OK, but inside going out seems to be blocked.

Isn't there some SIMPLE way to say allow EVERYTHING from outside ip address 122.148.198.149  to port 2 inside address 10.100.10.253  and allow EVERYTHING from port 2, inside address 10.100.10.253  out to outside address 122.148.198.149  and allow ALL services?
ASA5510# show run

: Saved

:

ASA Version 8.0(4)

!

hostname ASA5510

domain-name mydomain.com

enable password xxxyyyzzz encrypted

passwd zzzyyyxxx encrypted

names

name 10.100.2.0 Illinois description Illinois Office

name 10.100.1.3 Inside-SBS-Server

name 122.148.198.150 Outside-MSExchange

name 122.148.198.149 Outside-PhoneSystem

name 10.10.10.0 Software-VPN-Clients

name 10.100.10.253 Inside-PhoneSystem

dns-guard

!

interface Ethernet0/0

 nameif Outside

 security-level 0

 ip address 122.148.198.147 255.255.255.248

!

interface Ethernet0/1

 nameif Inside

 security-level 100

 ip address 10.100.1.5 255.255.255.0

!

interface Ethernet0/2

 nameif PhoneSystem

 security-level 0

 ip address 10.100.10.254 255.255.255.0

!

interface Ethernet0/3

 shutdown

 no nameif

 no security-level

 no ip address

!

interface Management0/0

 nameif management

 security-level 100

 ip address 192.168.1.1 255.255.255.0

 management-only

!

boot system disk0:/asa804-k8.bin

ftp mode passive

clock timezone CST -6

clock summer-time CDT recurring

dns server-group DefaultDNS

 domain-name mydomain.com

same-security-traffic permit inter-interface

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq www

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq smtp

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq 995

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq https

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq 444

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq 4125

access-list Outside_access_in extended permit tcp any host Outside-MSExchange eq ldap

access-list Outside_access_in extended permit ip any host Outside-PhoneSystem

access-list Outside_access_in extended permit tcp any host Outside-PhoneSystem

access-list Outside_access_in extended permit udp any host Outside-PhoneSystem

access-list Outside_access_in extended permit udp any host Outside-PhoneSystem eq www

access-list Inside_nat0_outbound extended permit ip 10.100.1.0 255.255.255.0 Illinois 255.255.255.0

access-list Inside_nat0_outbound extended permit ip any Software-VPN-Clients 255.255.255.0

access-list Split_Tunnel_List standard permit 10.100.1.0 255.255.255.0

access-list Outside_1_cryptomap extended permit ip 10.100.1.0 255.255.255.0 Illinois 255.255.255.0

access-list PhoneSystem_access_in extended permit ip any any

access-list PhoneSystem_access_in extended permit ip host Outside-PhoneSystem host Inside-PhoneSystem

access-list PhoneSystem_access_in extended permit tcp host Outside-PhoneSystem host Inside-PhoneSystem eq www

access-list PhoneSystem_access_in extended permit tcp host Outside-PhoneSystem host Inside-PhoneSystem eq https

access-list PhoneSystem_access_in extended permit ip host Inside-PhoneSystem any

pager lines 24

logging enable

logging asdm informational

mtu Outside 1500

mtu Inside 1500

mtu PhoneSystem 1500

mtu management 1500

ip local pool VPN-Pool 10.10.10.1-10.10.10.255 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

asdm history enable

arp timeout 14400

global (Outside) 10 interface

nat (Inside) 0 access-list Inside_nat0_outbound

nat (Inside) 10 0.0.0.0 0.0.0.0

static (Inside,Outside) Outside-MSExchange Inside-SBS-Server netmask 255.255.255.255

static (Inside,PhoneSystem) 10.100.1.0 10.100.1.0 netmask 255.255.255.0

static (PhoneSystem,Inside) Outside-PhoneSystem Inside-PhoneSystem netmask 255.255.255.255

static (PhoneSystem,Outside) Outside-PhoneSystem Inside-PhoneSystem netmask 255.255.255.255

static (PhoneSystem,Inside) Inside-PhoneSystem Outside-PhoneSystem netmask 255.255.255.255

access-group Outside_access_in in interface Outside

access-group PhoneSystem_access_in in interface PhoneSystem

route Outside 0.0.0.0 0.0.0.0 122.148.198.146 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

http server enable

http 26.40.114.24 255.255.255.255 Outside

http 10.100.1.0 255.255.255.0 Inside

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000

crypto map Outside_map 1 match address Outside_1_cryptomap

crypto map Outside_map 1 set pfs

crypto map Outside_map 1 set peer 169.99.136.249

crypto map Outside_map 1 set transform-set ESP-3DES-SHA

crypto map Outside_map 1 set security-association lifetime seconds 28800

crypto map Outside_map 1 set security-association lifetime kilobytes 4608000

crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map Outside_map interface Outside

crypto map Inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map Inside_map interface Inside

crypto isakmp enable Outside

crypto isakmp enable Inside

crypto isakmp policy 10

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp nat-traversal 30

telnet 10.100.1.0 255.255.255.0 Inside

telnet timeout 5

ssh 26.40.114.24 255.255.255.255 Outside

ssh timeout 60

console timeout 0

management-access Inside

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics host

threat-detection statistics port

threat-detection statistics protocol

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

ntp server Inside-SBS-Server source Inside prefer

group-policy GroupPolicy2 internal

group-policy GroupPolicy2 attributes

 vpn-filter none

 vpn-tunnel-protocol IPSec

group-policy Wysocki-VPN-Client internal

group-policy Wysocki-VPN-Client attributes

 dns-server value 10.100.1.3 66.170.2.177

 vpn-tunnel-protocol IPSec

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value Split_Tunnel_List

username admin password UpSGCNJD1nBLFmwQ encrypted privilege 15

username kathy password QP6B7KR8z6zODExc encrypted privilege 0

username kathy attributes

 vpn-group-policy Wysocki-VPN-Client

username hubert password yeI7IXaQndhunp5y encrypted privilege 15

username hubert attributes

 vpn-group-policy Wysocki-VPN-Client

username rmmsolutions password 2XIysAdHiN4xxCEw encrypted privilege 15

tunnel-group Wysocki-VPN-Client type remote-access

tunnel-group Wysocki-VPN-Client general-attributes

 address-pool VPN-Pool

 default-group-policy Wysocki-VPN-Client

tunnel-group Wysocki-VPN-Client ipsec-attributes

 pre-shared-key *

tunnel-group 169.99.136.249 type ipsec-l2l

tunnel-group 169.99.136.249 general-attributes

 default-group-policy GroupPolicy2

tunnel-group 169.99.136.249 ipsec-attributes

 pre-shared-key *

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns migrated_dns_map_1

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns migrated_dns_map_1

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:59933bb33c94b773b9bdfc4c55a9fad8

: end

ASA5510#

ASA5510#

Open in new window

0
 

Accepted Solution

by:
bnhcomputing earned 0 total points
ID: 24878696
Never sis get this to work.  Brought in two "Cisco Certified" consultants and they couldn't get it working either.  Ended up using a SWITCH BEFORE the firewall as it does not appear the firewall can be configured correctly.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now