Solved

Implementing Exchange 2007 SCR Questions

Posted on 2009-04-14
10
929 Views
Last Modified: 2012-05-06
I am about to implement SCR and have a coupple of questions.  I dont understand how or what will happen when we do backups on the source server, when that takes place, the log files are truncated and writen to the EDB file for each coresponding storage group... so what if any effect does that have onthe way SCR copies the logs tot he target?
I have brought up a target server all patched and ready to go, by default there si already a "first storage group" I have moved it to a location that mimics the source server. But if I implement SCR for the that storage group will it over write the existing database ? What do I need to do to make sure that the default database on teh target is wiped before the replication copy begins to build? same for the log files on that target server as well?  what do I do with t hem? if anything???
More questions to come Im sure, but Im assigning 500 points to this as I wouldlike to get GOOD answers that will help me make the next step which is implement SCR for my 2 exchange servers.
thanks in advance!
0
Comment
Question by:CCNPwanabe
  • 8
  • 2
10 Comments
 

Author Comment

by:CCNPwanabe
ID: 24143426
OK I have some trouble...
I started SCR succesfully for 2 storage groups .. those didint exixt on the Target server.  Per some instructions I read I renamed the default storage group folder to SG1-old and created a new folder for the Edb file. I did the same for the folder for the log files as well.
What happened looks like the transaction logs copied over to the target but as it is trying to play them intothe the data base folder to create the edb file is it is registering a ton of errors in the application event log that say (1) the .edb file can not be found, and (2)an attempt to open the device (sid) failled, access denied.
Thoughts???
my guess is i shouldnt have renamed and created a new folder for the edb file....
How do I fix this?
BTW, the other two storage groups are fine and working well with SCR
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24143778
If you remember that SCR target can be a live server, then you will not go far wrong.
You do not touch the existing databases on the target server, because if it was live they would continue to operate correctly.
The only thing you have to watch for is that the databases and storage group are not named the same on both servers.

Otherwise it is a matter of implementing the identical directory structure on both servers.

Simon.
0
 

Author Comment

by:CCNPwanabe
ID: 24148686
Came in to the office today and noticed that there is a new problem, when I do a get-storageGroupCopyStatus on the source server, it takes about 3 minutes to return a result, and the 3 storage groups show a status of "service down"
when I attemot to either Resume_storagegroupcopy OR Update-storagegroupcopy from the tagrget exchange server I get a message that it can not find the the named storage group in AD, and when I run it on the Source server I get an error that says "the windows cluster service encountered an error durring functiohn IsNodeClustered
Help!!!(please)
0
 

Author Comment

by:CCNPwanabe
ID: 24150858
On another note, when I run a test-replication health onhthe source server, i get a reply that the server doesnt have local continuous replication enabled...
but when I run on the other server (target) it passes all but the connection to the SGcopySuspended on first storage group. saying that the replication is suspended.
I try to run a update storagegroup and it it says that the storage group can not be found ont he domain controler
this happens for all storage groups that were replicating fine yesterday.
0
 

Author Comment

by:CCNPwanabe
ID: 24151358
OK Sorry this is hard to follow, but new update...

I ran "disable-storageGroupCopy" for all three storage groups, deleted all the assosciated files and the re-ran "Enable_storageGroupCopy" for all three storage groups...
each time I ran the command, it gave me no errors, as though it was not a problem.

Im Looking at the source exchange server and the hard drive is writein to both the log files drive array as well as the EDB files array, meaning it is doing something...

I look in the directories for the edb files and the log files and they are being populated once again  for the second and third SG's, but  The problem is the First storage group is not doing anything, not a single log file, nor EDB has been created.

errors are piling up in the application event log on the target server to the effect of the name of the server (source server) can not be found for all storage groups... yet the files are there...
example:
Log file action LogCopy failed for storage group nnnnnn\Second Storage Group. Reason: The network name cannot be found.
.....and.....
The directory '\\GRF-LW-EX\20065f67-441d-4702-b399-8fe3132276d6$' required by the Microsoft Exchange Replication Service for GRF-LW-EX\Second Storage Group could not be accessed. Check the network connectivity and name resolution. Error: 67.
.....and.......
The directory \\GRF-LW-EX\20065f67-441d-4702-b399-8fe3132276d6$ required by the Microsoft Exchange Replication Service for GRF-LW-EX\Second Storage Group does not exist. Check the file system and its permissions

thoughts on this....


All the logs and Databases have been write for the second and third storage groups, but in the "Get-Replicationstatus"cmmdlt, it still says that all the sotrage groups replication is disabled????


So Frustrated!!!!!!!!!!

0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:CCNPwanabe
ID: 24153020
Microsoft.Exchange.Cluster.ReplayService (3712) Log Verifier e00 33947656: An attempt to open the device name "\\GRF-LW-EX\b7696efe-ba61-49ef-b78d-57345e94d94b$" containing "\\GRF-LW-EX\b7696efe-ba61-49ef-b78d-57345e94d94b$\" failed with system error 5 (0x00000005): "Access is denied. ".  The operation will fail with error -1032 (0xfffffbf8).

Still getting this for the first message storage group....
No errors for the other storage groups, but get-replicationstatus shows ALL message stores are disabled....
If I  could make the a 100000000000000000000000000000 point question I would....
0
 

Author Comment

by:CCNPwanabe
ID: 24153397
Now on my second storage group I am getting this error in the application log of the target:
Log file action LogCopy failed for storage group GRF-LW-EX\Second Storage Group. Reason: CreateFile(\\GRF-LW-EX\20065f67-441d-4702-b399-8fe3132276d6$\E0200005134.log) = 2
I also have a healthy status all the storage group copies

[PS] C:\Windows\System32>get-storagegroupcopystatus "grf-lw-ex\first storage group" -standbymachine grf-lw-ex2 |fl summary*,Copy*
SummaryCopyStatus : Healthy
CopyQueueLength   : 0
[PS] C:\Windows\System32>get-storagegroupcopystatus "grf-lw-ex\third storage group" -standbymachine grf-lw-ex2 |fl summary*,Copy*
SummaryCopyStatus : Healthy
CopyQueueLength   : 0
[PS] C:\Windows\System32>get-storagegroupcopystatus "grf-lw-ex\users storage group" -standbymachine grf-lw-ex2 |fl summary*,Copy*
SummaryCopyStatus : Healthy
CopyQueueLength   : 0
____________________________________
But when I run a regular Get-storagegroupcopystatus I get something very different (see below)

Name                      SummaryCopyStatus       CopyQueueLength         ReplayQueueLength      LastInspectedLogTime
----                      -----------------       ---------------         -----------------      --------------------
First Storage Group       Disabled                0                       0
Public Storage Group      Disabled                0                       0
Second Storage Group      Disabled                0                       0
Third Storage Group       Disabled                0                       0
Users Storage Group       Disabled                0                       0


How is that posible....
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24158402
I have no idea what you have done with the setup. I have completely lost track.
The only thing I can suggest is to remove all of the SCR configuration and start again.

Simon.
0
 

Author Comment

by:CCNPwanabe
ID: 24158559
No Problem, reading my posts  is probably more frustration  than I am feeling, But I think I fixed it last night... So far so good.
Please try to answer the question below my explanation of what I did to fix it...
thanks....

Resolution:
After reading a bit aboutthe errors that i was getting with resolution in AD, I found that it may sometimes be needed to remove and then re-add the exchange server to the Domain exchange servers group in AD and then restart the system attendant on that machine...
that fixed the resolution issues.
I suspended the  storage group copies to all storage groups and ended up re-seeding them.
So far so good, no problems, and no more errors.
BUT (Question)
still if I run a "Get-StorageGroupCopyStatus"
the result is still the same as above. (comes back with disabled for all storage groups)
Name                      SummaryCopyStatus       CopyQueueLength         ReplayQueueLength      --              -----------------               ---------------             -----------------      --------------------
First Storage Group       Disabled                            0                       0
Public Storage Group      Disabled                           0                       0
Second Storage Group      Disabled                        0                       0
Third Storage Group       Disabled                           0                       0
Users Storage Group       Disabled                0                       0
_____________________________________________________________________________
But if I ask for a bit more detail and do a :
"get-storagegroupcopystatus "grf-lw-ex\first storage group" -standbymachine grf-lw-ex2 |fl summary*,Copy*
it comes back with a healthy status...

What is the difference... and is there a way of "refreshing" that in fo for the previous cmdlet?
0
 

Accepted Solution

by:
CCNPwanabe earned 0 total points
ID: 24158791
Ok I just figured out what I was doing wrong
(hard when you have to teach yourself about the new powershell for exchange cmdlts)
the Correct syntax should have been:
get-storagegroupcopystatus -standbymachine "the name of the standybymachine"
that gives the real results...

This post is finished, all is well!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now