SQL2005 Ugrade Advisor will not Run

I have SQL2000 SP4 running on a single server and I would like to upgrade to SQL2005.

I have installed the SQL 2005 Upgrade Advisor on the server. It quits when it tries to analyze the SQL DB and says it cannot connect to the database.

It appears all the SQL Services are running, I have reinstalled the App., restarted the server but I cannot get the tool to run.
comm1cccAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Chris LuttrellConnect With a Mentor Senior Database ArchitectCommented:
Does it happen to be a named instance instead of the default?  I have seen some discussion like this one at SQLServerCentral, http://www.sqlservercentral.com/Forums/Topic525884-146-1.aspx, which points to this one on msdn.blogs, http://www.sqlservercentral.com/Forums/Topic525884-146-1.aspx. The latter specifically had a comment that it was an "Absolutely useful post. Solved my porblem of connecting to SQL server 2000 through upgrade advisor."  It looks like named instances can cause a problem possibly because of the switch to SQL Server Browser in 2005.  Some possible solutions/work-arounds are to use the IP address or pretend it is the default instance and supply MSSQLSERVER as the instance name.
If this is not the answer, maybe give some more details of your setup and specific error messages and someone can key in on the problem.
0
 
Anthony PerkinsCommented:
Or perhaps you have not enabled remote access on the SQL Server 2005 box.
0
 
comm1cccAuthor Commented:
I am running the App. locally so I don't think Remote Access is going to come into play but yes Remote Access is enabled and I have tried it from another machine with the same results

It is running on the default instance (MSSQLSERVER). I can go thru all of the steps in the wizard and as soon as the tool runs it cannot connect to the DB
0
All Courses

From novice to tech pro — start learning today.