DotNetNuke returns homepage, but replaces URL with IP address. How do I fix this?

I am responsible for supporting a web site that just went live. The site works well except for the fact that the URL is replaced by the IP address when the page displays. How do I fix this?

I have little to no experience yet with DotNetNuke or web development.

I'm rating this as a 500 because I can find no information whatsoever about this elsewhere and there are no obvious (to me) settings.

Thanks!
gnhopsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bradl3yCommented:
It might be as simple as changing the hostname in IIS:
See this link for instructions:
http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_21638588.html

If everything is set correctly in IIS, then there must be a configuration file that DotNetNuke uses.

If you havn't tried already, they do have community forums here: http://www.dotnetnuke.com/Community/Forums/tabid/795/Default.aspx

0
paololabeCommented:
The problem could be caused by a wrong IIS configuration, as bradl3y said, or a wrong configuration of aliases of portal.
Login as HOST, go on Portals Settings, check the aliases configuration in the bottom of page.
In the aliases should be present the url of the web site, for example www.mysite.com or mysite.com

Paolo.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gnhopsonAuthor Commented:
Your solution was exactly right. I found the HTTP alias right away, then as a double-check I googled dotnetnuke http alias and found the following link which confirmed the solution. While the link wasn't a 100% match to what I did, it did give me enough information to fix the problem to fix the problem based on paololabe's recommendation.
http://aquesthosting.com/DNN4AddPortalAlias
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.