Solved

RDP Client 6.0 won't keep login credentials after reboot

Posted on 2009-04-14
18
3,896 Views
Last Modified: 2013-11-21
We have a few computers in our company (2 or 3 at the most) that will drop RDP login credentials after a full reboot.  After turning on 'Allow me to save my credentials', the computer will keep them saved until it is rebooted.  Logging out does not drop the credentials.  The computers all have SP3, and thus, the newer RDP 6.0.  Since there are only a few computers with this problem, and not much online about the issue, I'm guessing it is computer specific.  The problem is very consistent, though.  Any help would be greatly appreciated!

I also looked into uninstalling the client from the NTUninstallKB925876 folder like some suggestions I've read but that folder isn't there.
0
Comment
Question by:jesman3
  • 6
  • 3
  • 3
  • +1
18 Comments
 

Expert Comment

by:AceSpade09
ID: 24143141
Hi, I believe you need to save the RDP connection once on your Hard disk with the "Save As" option.  Preferably on the "C" drive.  Once you have saved it, then go ahead and create a shortcut on the desktop.  See once you save the connection with the proper configuration, the settings will be kept no matter how many times the PC is rebooted.  

Sincerely,

VM
0
 

Author Comment

by:jesman3
ID: 24143161
I'm saving the RDP file straight onto the desktop.  I've deleted it and tried re-creating it several times to no avail.
0
 

Author Comment

by:jesman3
ID: 24152226
Just to add some clarity, I am saving an RDP connection file (blah.rdp) onto the desktop, and checking the "Allow me to save my credentials" option.  When I connect, it prompts me to sign in with the user name and password, with a check box to remember my credentials, which I turn on.  If I disconnect and reconnect, it DOES NOT prompt me to re-enter the user name and password... it lets me right in.  However, if I reboot the computer, and try to connect, it WILL prompt me.  If I right click - Edit the icon, the "Allow me to save my credentials" option has unchecked itself, and when it prompts me to sign in, the password field is blanked out.  Since in my company this info is confidential, we can't give that out so people can remote in from home.
0
 

Expert Comment

by:AceSpade09
ID: 24152341
Ok at this point I am assuming that your client is connecting to the Terminal Server.  You need to check the User's Settings on the server to make sure it allows password saves.  It's a security measure.  

The Do not allow password to be saved policy setting applies to Terminal Services Remote Desktop Connection clients. This policy setting can be set to one of the following options:


Enabled. This option clears and disables the Save my password check box.
Disabled. This option allows passwords to be saved, but does not force users to save passwords.
Not Configured (default). If this policy is set to Not configured, any other Group Policy setting which applies is still in effect. This option does not affect other policy settings.

0
 

Expert Comment

by:AceSpade09
ID: 24152351
Also, if you don't want them to remote in from home, just use an internal IP when saving the RDP anyway.  Even if they have the credentials, they can't log in from home :)

Good Luck!
0
 

Author Comment

by:jesman3
ID: 24169782
I'm not exactly sure where the "Do not allow password to be saved policy" setting would be, but if it's on the client computer, I've searched and used gpedit.msc to set this but it hasn't changed anything.  If the setting is on the server, the fact that multiple other people use this same login account with no problem would make this a non-issue.

Per the note about using the internal IP, we have people (including one of the problem computers) that are off-site so, aside from using VPNs everywhere, which isn't really an option, we can't do that.

Back in RDP 5.1 when you could save credentials right into the RDP file, it was perfect.  With this change coming packaged in SP3, it's a nightmare.  Luckily more computers aren't plagued with this too.
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 

Author Comment

by:jesman3
ID: 24200204
No one else is having this problem?  Any insight into the new credentials store for RDP 6.0 vs the old one?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24276407
OK.... V6.0 doesnt save them hashed in the .rdp file like previous versions, it stores them in Ptoected Storage on the local client.

Few things.....

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
start>run>services.msc

Make sure that the Protected Storage service is started, and set to Automatic.....
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Disable Storage of Credentials and .NET Passwords
http://www.pctools.com/guides/registry/detail/1286/

Make sure this isnt present either....
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In the registry....

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
"DisablePwdCaching"=dword:0000001

If it is present, and set to a 1, delete it, or change the value to a 0.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

How to perform advanced clean-boot troubleshooting in Windows XP
http://support.microsoft.com/kb/316434

In MSConfig
I would disable all items under Startup, and retest.....
If it still fails, disable all non MS services....
If it still fails, disable the services, except for the Protected Storage. Then retest....

If it works after disabling a group, then start restarting services in groups, and although this will take some time, It might have to be done this way....
0
 

Author Comment

by:jesman3
ID: 24282928
Johnb6767, thanks so much for the reply.  Here's how it turned out.

The Protected Storage service was already set to run automatically.

The DisableDomainCreds registry setting was already entered and set to 0.

The DisablePwdCaching entry was not entered at all.  I later entered it and set it to 0, but I still experienced the problem.

I used MSConfig to strip the boot down to first only MS services, then only essential services (DCOM Server Process Launcher, RPC, RPC Locator) and Protected Storage.  Even then, I would still experience the problem, being every time I save credentials and reboot, the password is blanked out again.  Note that the username does stay, but the password doesn't.  I'm sorry if I wasn't clear on that earlier.

Any other thoughts?  Is there a way to uninstall and reinstall it if it came bundled with SP3?

Thanks again for the suggestions!
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24368161
I havent tried to uninstall RDP from SP3.....

Short of replacing a few files, it might be possible....

Another alternative though.... If you have stored RDP files, this might be a workaround. RDP v6 doesnt store them (the passwords) in the RDP, but from a previous thread I was in, they managed to have it work with no problems, although I couldnt confirm this.....

How rdp passwords are encrypted
http://www.remkoweijnen.nl/blog/2007/10/18/how-rdp-passwords-are-encrypted/
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 500 total points
ID: 24368170
Look at my Accepted Answer in the below thread......

http://www.experts-exchange.com/Microsoft/Applications/Q_24108573.html
0
 

Author Closing Comment

by:jesman3
ID: 31570187
Thank you Johnb6767!  I tried unregistering the file but it didn't work.  But, I was able to just replace the files with the 5.1 version from my own computer and it worked.  One catch: when Windows detects those files are deleted, it tries to put them right back.  I had to delete the originals and copy mine over very quickly after.  Windows apparently doesn't check their versions, so it's not trying to overwrite them.  I also did register the older one (regsvr32 mstscax.dll) once I copied it over, in case that makes any difference.

So, while we didn't actually fix the main problem, downgrading was a perfectly workable solution for me.  Thanks again for your help!
0
 
LVL 8

Expert Comment

by:RGRodgers
ID: 32868848
I had a similar problem with RDP and with MSN IM.  I found the solution on another site which fixed both problems for me.  It has to do with installation of the Yahoo IM as well as MSN IM, so you may or may not have the same problem.  I'd like to hear either way.
The link to the solution would be:
http://www.techsupportforum.com/microsoft-support/windows-xp-support/310281-solved-windowslivemessenger-will-not-save-login-settings-after-reboot.html
 
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now