Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cannot restore RPC over HTTP after new certificate.

Posted on 2009-04-14
13
632 Views
Last Modified: 2012-05-06
I just created a new certificate oma.company.com to get Activesync working with an IPhone, now that is working but our remote laptops have lost RPC over HTTP. I Updated the new certificate on the remote machines, changed the domain name for the server address in the Outlook Exchange client setup.
I have read and implemented most of the relevant Petri papers but still have this error in the Microsoft Textexchangeconnectivity. A couple of other posts have dealt with this error but none of them seems to list a usuable error.
Attempting to ping RPC Endpoint 6001 (Exchange Information Store) on server sierra.quicksilver.local
  Failed to ping Endpoint
 Additional Details
  An RPC Error was thrown by the RPC Runtime. Error 1130 1130
 
0
Comment
Question by:pmacafee
  • 9
  • 2
  • 2
13 Comments
 
LVL 4

Expert Comment

by:dud386
ID: 24144710
Are you using RPCping to get those results? You might try restarting the Exchange System Attendant service and trying to connect again.
0
 

Author Comment

by:pmacafee
ID: 24144798
Is that a service found in the Administrative Tools?
0
 

Author Comment

by:pmacafee
ID: 24144802
Is that a service found in the Administrative Tools?
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 

Author Comment

by:pmacafee
ID: 24144838
Oh  BTW, what is RPCPing?
0
 

Author Comment

by:pmacafee
ID: 24144866
Cannot find the Exchange System Attendant in Ssrvices.
I always restart the IIS Admin Service after each Server Management change.
0
 
LVL 4

Accepted Solution

by:
dud386 earned 125 total points
ID: 24144868
It's a service under the local services. Start > Run > type: services.msc > click OK

Restart MS Exchange System Attendant

RPCping is a utility you can use to test RPC connections all the way to the mailbox server. More info here: http://support.microsoft.com/kb/831051
0
 

Author Comment

by:pmacafee
ID: 24145042
Did the restart.  No joy. Downloaded the 2003 Server RK to get the ping utility.
Will get to the office In the AM to run tests.  Bye for now.
0
 

Author Comment

by:pmacafee
ID: 24145043
Did the restart.  No joy. Downloaded the 2003 Server RK to get the ping utility.
Will get to the office In the AM to run tests.  Bye for now.
0
 
LVL 9

Expert Comment

by:Raghuv
ID: 24145645
Also to confirm if the configuration of RPC virtual directory is fine, try and raise https://oma.company.com/rc/rpcproxy.dll on the computer which has Outlook with RPC over HTTP config and ensure you get a blank page as a result....Also ensure you do not receive any certificate warnings...

Also when you ran the test on TestExchangeConnectivity, it will also give an option to help you to resolve the issue. Can you confirm what does the link suggests you....?
0
 

Author Comment

by:pmacafee
ID: 24148816
Raghuv;
I ran the dll test on 2 machines that have the certificate that I installed to get Activesync running.

When I navigate to the dll address suggested, I get a warning screen that asks for a certificate and a window displays no certificate. When I cancel out, I get a login for oma.company.com\me. When I log in I get a blank screen.
0
 
LVL 9

Assisted Solution

by:Raghuv
Raghuv earned 125 total points
ID: 24149175

To fix the issue i.e ""When I navigate to the dll address suggested, I get a warning screen that asks for a certificate and a window displays no certificate"" -> Open IIS manager (Assuming you have Windows 2003) -> locate RPC -> Right click and choose properties -> select Directory security tab -> Click on the bottom most edit button -> Under Client Certificates -> choose ignore.

For Windows 2008 -> Locate RPC in IIS manager -> Open SSL settings -> Under Client Certificates -> choose ignore.

Incase you still recieve a blank certificate window, then you will have follow the above procedure for the Default Web Site as well (Instead of RPC)
0
 

Author Comment

by:pmacafee
ID: 24149723
Ok, set ignore on rpc and rpc with certificate.
Not sure how to use the RPCping utility though.
0
 

Author Comment

by:pmacafee
ID: 24150101
That did it, connected, thanks Raghuv and dud386
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question