It it possible to install asterisk 1.4 with h323plus

Hello,

I am trying to install asterisk 1.4 with h323plus.

1. Do I need to install open323 as well in order to compile asterisk 1.4?
2. If not can you please point out why i am getting such error?

thanks in advancer
/include -DPTRACING -I/usr/src/asterisk/h323plus/include -M ast_h323.cxx >> *.dep
ast_h323.cxx:42:17: error: lid.h: No such file or directory
make[2]: *** Deleting file `*.dep'
g++ -DNDEBUG -I../../include -include ../../include/asterisk/autoconfig.h -fPIC  -D_REENTRANT -fno-exceptions  -Wall  -fPIC -DPIC -DNDEBUG -I/usr/src/asterisk/ptlib_v2_0_1/include -DPTRACING -I/usr/src/asterisk/h323plus/include -Os  -pipe -felide-constructors -Wreorder  -c ast_h323.cxx -o ast_h323.o
ast_h323.cxx:42:17: error: lid.h: No such file or directory
ast_h323.cxx: In destructor virtual MyProcess::~MyProcess():
ast_h323.cxx:201: error: timerChangePipe was not declared in this scope
ast_h323.cxx: In member function virtual H323Channel* MyH323Connection::CreateRealTimeLogicalChannel(const H323Capability&, H323Channel::Directions, unsigned int, const H245_H2250LogicalChannelParameters*, RTP_QOS*):
ast_h323.cxx:1820: error: cannot allocate an object of abstract type MyH323_ExternalRTPChannel
ast_h323.h:127: note:   because the following virtual functions are pure within MyH323_ExternalRTPChannel:
/usr/src/asterisk/h323plus/include/channels.h:640: note:        virtual BOOL H323_RealTimeChannel::OnSendingAltPDU(H245_ArrayOf_GenericInformation&) const
/usr/src/asterisk/h323plus/include/channels.h:653: note:        virtual void H323_RealTimeChannel::OnSendOpenAckAlt(H245_ArrayOf_GenericInformation&) const
/usr/src/asterisk/h323plus/include/channels.h:670: note:        virtual BOOL H323_RealTimeChannel::OnReceivedAltPDU(const H245_ArrayOf_GenericInformation&)
/usr/src/asterisk/h323plus/include/channels.h:686: note:        virtual BOOL H323_RealTimeChannel::OnReceivedAckAltPDU(const H245_ArrayOf_GenericInformation&)
make[2]: *** [ast_h323.o] Error 1
make[2]: Leaving directory `/usr/src/asterisk/asterisk-1.4.24.1/channels/h323'
make[1]: *** [h323/libchanh323.a] Error 2
make[1]: Leaving directory `/usr/src/asterisk/asterisk-1.4.24.1/channels'
make: *** [channels] Error 2

Open in new window

dizel247Asked:
Who is Participating?
 
dizel247Author Commented:
To answer my own question. Asterisk has released verison 1.4.5 that is working with h323plus

0
 
Kamran ArshadIT AssociateCommented:
Hi,

Please read the below installation howto;

http://www.n3ncy.com/UNIX/Debian/Asterisk-1.6x.htm
0
 
dizel247Author Commented:
uetian1707 thanks for your reply. But I was actually looking to install Asterisk 1.4 with h323plus.

I able to install 1.4 with openh323 and able to install 1.6 with h323plus. I am having problems in installing 1.4 with h323plus

Please suggest if its even possible or it was only made for 1.6?

Regards,

Roman
0
 
dizel247Author Commented:
To answer my own question. Asterisk has released verison 1.4.5 that is working with h323plus

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.