Solved

How do I change DSL settings on a cisco 800a

Posted on 2009-04-14
14
899 Views
Last Modified: 2012-05-06
Hi,
I have a customer who has a cisco 800a and has changed ISP so needs to have the username and password on the ADSL port changing. I am not familiar with the cisco kit but I am with normal DSL routers. I have got a blue cisco cable. I think I have the passwords but this will only be checked when i arrive on site. How do I save a current config to a pc in case things go wrong, display the settings I need and then change them and commit them to flash memory pls
0
Comment
Question by:Grover247
  • 7
  • 7
14 Comments
 
LVL 7

Expert Comment

by:hau_it
ID: 24145374
Welcome to the cisco world

The blue cable is call rollover and you plug it in the serial port of you pc and in the console port of the router
After that you open hyperterminal or if you have vista download tera term PRO (easy and free)
select 9600 bits per second, Data bits 1, parity none, Stop bits 1, flow control none
When you click enter you will the Press return to get started.
Press enter and maybe you will be asked for password. Type the password and you will be in the user exec prompt. Then type enable and you will be at the privileged exec mode. Again you may be asked for a password,
Type show run and hit enter. This is the configuration of your router. Copy this config to a notepad and change whatever you need.
Then paste it back to the router

Dimitris
0
 

Author Comment

by:Grover247
ID: 24145424
Thank you Dimitris, this is very helpful.
I have these notes also for changing the pap or chap settings....do they look okay to you



!--- Here are the commands to configure authentication
!--- with with your ISP. This example uses the "CHAP"
!--- method.
!--- Commands for using the "PAP" method are included at
!--- the end of this box
!
 ppp authentication chap callin
 ppp chap hostname <username>
 ppp chap password <password>
!
 
 
!--- Tells the router to NAT all traffic that passes
!--- through it:
!--- 1) From the inside to the outside,
!--- 2) And whose IP address is in the 192.168.1.0 network
!---    as given in access list 1
!--- 3) Giving it an outside "public" address that is the
!---    same as interface Dialer1 gets from the PPPoE
!---    connection
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
access-list 1 permit 192.168.1 0.0.0.255
 
o        If your ISP tells you that you need to do the PAP, and not the CHAP, type of authentication then you'll have to replace the lines:

 
ppp authentication chap callin
ppp chap hostname <username>
ppp chap password <password>
with only these two:

ppp authentication pap callin
ppp pap sent-username <username> password <password>
 
0
 
LVL 7

Expert Comment

by:hau_it
ID: 24145474
you can use both pap and chap
If your provider supports only PAP then you just type ppp pap sent-username <username> password <password>
The ppp authentication pap is not needed

About the NAT if your internal network is 192.168.1.0 then it is correct.
Just remember to put the command ip nat inside in your internal interface and ip nat outside at the dialer interface

Dimitris
0
 

Author Comment

by:Grover247
ID: 24145513
Thats great.
One or two last things please
1. How do i commit the changes to the router once i am happy that they work please?

2. If I manage to mess it all up before I commit the changes then I presume you can still just reboot the router and it will come back with the old config?


Grover247
0
 
LVL 7

Expert Comment

by:hau_it
ID: 24145533
before you commit the changes try to see if they work. If they dont you can simply restart the router without saying yes to saving prompt and your changes will be lost.
After you are sure that everything is working, while in privilege mode (router#) type wr and press enter.

Dimitris
0
 

Author Comment

by:Grover247
ID: 24145638
Dimitris,
You are a fine person for helping me so quickly.
Have a great day today and I will post a reply later to tell you how it all went
Once this is posted i will award you the points.
All the best

Iain

Ps What country/county are you in? I am always curious who helps who from what country as sometimes time zones are against people yet they stay up late or get up early to assist others in need which is great.

I am in the UK in the county of Oxfordshire
0
 
LVL 7

Expert Comment

by:hau_it
ID: 24145652
Hi Iain,

I hope that you will be fine with no problem.

I am from Greece Athens so we have 2 hours difference
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:Grover247
ID: 24145795
I just had another thought about this.
I will need to change the fixed ip address of the wan interface if I am changing the ISP connection info
Can you help me with this also pls?

I saw this on the web




Current Configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
!
hostname ciscorouter
!
ip subnet-zero
no ip domain-lookup
!
bridge irb
 
!--- Configure the home / SOHO network interface's IP address
!--- The "ip nat" statement tells your router that this
!--- interface:
!--- 1) uses NAT
!--- 2) is the inside "private" interface
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
 encapsulation aal5snap
 !
 bundle-enable
 dsl operating-mode auto
 bridge-group 1
!
!--- Cisco prefers to run the PPPoE client on a virtual
!--- "BVI" interface
!--- This is tied to the real ATM DSL interface with the
!--- "bridge-group" command above.
!--- (The BVI number always matches the bridge-group number)
 
!--- The "ip nat" statement tells your router that
!--- this interface:
!--- 1) uses NAT
!--- 2) is the outside "public" interface
!
interface BVI1
 ip address 97.158.253.25 255.255.255.248
 ip nat outside
 
!--- Tells the router to NAT all traffic that passes
!--- through it:
!--- 1) From the inside to the outside,
!--- 2) And whose IP address is in the 192.168.1.0 network
!---    as given in access list 1
!--- 3) Must get an outside "public" address that is the
!--- same as interface BVI1
!
ip nat inside source list 1 interface BVI1 overload
 
!--- This statement performs the static address
!--- translation for the Web server. With this statement,
!--- users trying to reach 97.158.253.26 port 80 (www) will be
!--- automatically redirected to 192.168.1.100 port 80
!--- (www), which in this case is the Web server.
!---
!
ip nat inside source static tcp 192.168.1.100 80 97.158.253.26 80 extendable
!--- Set your default gateway as provided by your ISP
!
ip classless
ip route 0.0.0.0 0.0.0.0 97.158.253.30
!
access-list 1 permit 192.168.1.0 0.0.0.255
 
bridge 1 protocol ieee
bridge 1 route ip
!
end
0
 
LVL 7

Expert Comment

by:hau_it
ID: 24145828
could you post the running config of your router?
0
 

Author Comment

by:Grover247
ID: 24145930
no, I'm not at the client site
0
 
LVL 7

Expert Comment

by:hau_it
ID: 24145952
ok in our previous conversation you mention that you have a dialer interface and not a BVI.
In order to use a new IP address you have to type in the dialer interface the following

ip address negotiated (if it is dynamic)
ip address x.x.x.x (if it is a static IP)
0
 

Author Comment

by:Grover247
ID: 24146032
ok so it would be for example ip address 96.201.32.62 once i am at the interface

and to get to the dialer interface I type.....?
0
 
LVL 7

Accepted Solution

by:
hau_it earned 500 total points
ID: 24146038
router>enable
router#conf t
router(config-router)#int dialer 0
router(config-if)# ip address ......
0
 

Author Comment

by:Grover247
ID: 24151154
It all worked very smoothly. Customer is happy, DSL connection is up, Linksys ip phones and all pc's are working well. Thank you very much indeed for all your detailed and kind help.
I am about to close and award you the points Dimitris.
Stay Cool
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now