how do you prevent firefox from caching javascript?

Is there a way to prevent firefox from caching anything uning s browser setting and not changing the webpage?

A user is accessing my ssl sharepoint site and is complaing about slowness.  It works well for me and I think it might be a caching issue.  I have several users so I don't know what kind of browse they use.  I want to do some testing on my end first and dont' want to change the sites code.  I just want to prevent the javascript from being cached.
jackjohnson44Asked:
Who is Participating?
 
torimarConnect With a Mentor Commented:
Well, "about:config" is the usual way of deep-tweaking Firefox.
The rest was research in the Mozilla knowledgebase and on some mailing lists.

Hope it helped you.
0
 
torimarCommented:
There is no javascript specific setting, but you can prevent your browser from caching HTTP/HTTPS pages.
In the address bar, type:
about:config

In the filter bar, type "cache", then search for "network.http.use-cache" and set it to "false". Here you can also disable caching completely by setting "browser.cache.disk.enable" to 'false'.

Another way would be server-side, by setting your server to send no-cache headers for .js files. I only know about .htaccess methods for Apache though, not for IIS:
http://www.askapache.com/htaccess/using-http-headers-with-htaccess.html#prevent-caching-with-htaccess
0
 
jackjohnson44Author Commented:
thanks, how did you know that?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.