?
Solved

Cisco Router Telnet Access

Posted on 2009-04-15
10
Medium Priority
?
726 Views
Last Modified: 2012-05-06
hi,

i have a Cisco 3845 router.  i have configured for telnet access and set a password.  i can get in just fine.  the issue is it's not prompting me for to put in "en" and prompt for password.  once i telnet in, i just type en, config t, and away i go.

i need this to prompt, i have done it before, i just can't remember the command.

thanks.
0
Comment
Question by:Vjz1
  • 4
  • 2
  • 2
  • +1
10 Comments
 
LVL 20

Expert Comment

by:RPPreacher
ID: 24148040
R1>enable
R1#configure terminal
R1(config)#enable password cisco
R1(config)#enable secret router
0
 
LVL 5

Expert Comment

by:ionut_mir
ID: 24148045
Try:

Router(config)#enable secret <your password>
0
 

Author Comment

by:Vjz1
ID: 24148125
yeah i tried that:

#enable secret password

but no go.  is there something else?

when i'm on the console, it does what i want, i type en and it asked me for the password again.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
LVL 20

Expert Comment

by:RPPreacher
ID: 24148202
config term first
0
 
LVL 10

Expert Comment

by:TakedaT
ID: 24148216
could you show us what you have at the bottom of your configuration for the vty lines?
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 24148218
Did you do both of these?

R1(config)#enable password cisco
R1(config)#enable secret router

just follow those lines exactly.
0
 

Author Comment

by:Vjz1
ID: 24148311
line con 0
exec-timeout 0 0
password 7 jfioewhafidhso
logging synchronous
login

line aux 0
password 7 jfdosjafiodsa
login

line vty 0 4
access-class 23 in
privilege level 15
password 7 jfdoksajfod
login

line vty 5 15
access-class 23 in
privilege level 15
password 7 fdsoafjdos
login

line vty 16 1052
password 7 jfdosajfods
login


thanks in advance
0
 
LVL 20

Accepted Solution

by:
RPPreacher earned 1000 total points
ID: 24148433
delete the 'privilege level 15'
0
 
LVL 10

Assisted Solution

by:TakedaT
TakedaT earned 1000 total points
ID: 24148436
I believe that the "privilege level 15" on your vty lines gives the telnet sessions full access, bypassing the need for the "enable secret" lines.  If you remove those lines from your vty lines, and add the lines that RPPreacher stated, does this help?
0
 
LVL 5

Expert Comment

by:ionut_mir
ID: 24148526
Try again to add the commands:

Router#config t
Router(config)#enable secret <password> priv 15

What error do you get? Post it,if you can.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

600 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question