Solved

how to build GNU Classpath and JamVM

Posted on 2009-04-15
8
1,223 Views
Last Modified: 2013-12-05

I'm trying to build GNU Classpath 0.98 and JamVM 1.5.2. Following the JamVM readme, I did 'configure; make; make install' on the jamVM, and it worked.

However, I need a java compiler (ecj) which is in .jar format itself. I can't run it without a working JVM (which I'm currently building).

I use slax and it doesn't provide a binary package for ecj. What should I do?
0
Comment
Question by:MicheleMarcon
  • 4
  • 4
8 Comments
 
LVL 86

Expert Comment

by:CEHJ
ID: 24148302
>>I use slax and it doesn't provide a binary package for ecj. What should I do?

I didn't know slax used packages - thought it was tarballs. You could get a deb or rpm and unpack it maybe?
0
 
LVL 13

Author Comment

by:MicheleMarcon
ID: 24148430
Unfortunately, it's not so easy. ecj depends on, basically, a JRE, GTK, Cairo and a lot of stuff. Downloading and unpacking everything will most probably lead to system corruption.
0
 
LVL 86

Accepted Solution

by:
CEHJ earned 500 total points
ID: 24148516
No, i realise you could get dependency problems, but i don't think it should depend on any windowing environment. These are the deps on my system:
goose@hpbrio:/tmp$ debfoster -d ecj-bootstrap
Package ecj-bootstrap depends on:
  ecj-bootstrap-gcj fastjar gcc-4.1-base gcj-4.1-base gij-4.1 java-common
  java-gcj-compat libasound2 libc6 libgcc1 libgcj-bc libgcj-common libgcj7-0
  libgcj7-jar tzdata zlib1g

Open in new window

0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 13

Author Comment

by:MicheleMarcon
ID: 24157394
I've tryed unpacking rpm and deb for a lot of distribution. I managed to run gij but gij didn't run ecj.

So no luck with deb and rpm.

I even found the .tgz files for jamvm and gnu classpath. But even then, they don't work! There was a symlink wrong, I adjusted it but still don't work...

0
 
LVL 86

Expert Comment

by:CEHJ
ID: 24157623
What is the script meant to do that you got? What *did* it do?
0
 
LVL 13

Author Comment

by:MicheleMarcon
ID: 24165175
Sorry, I don't understand. Which "script" are you talking about? I've taken a few routes for my solution:

a) I used JDK for building classpath. JDK can't find VMStackTrace classes (classpath classes)
b) I run ecj.jar with script ecj-bootstrap and other, still using JDK. Didn't work.
c) I downloaded the source of gcj, only to find that I need to rebuild gcc (can't do that, too long to explain)
d) I downloaded and installed debs and rpms of gcj, ecj. I managed to run gij which in turn should run ecj-bootstrap. I only get "Aborted" as output.
e) I downloaded binaries classpath-0.98-1.pkg.tar.gz and jamvm-1.5.1.tgz. Guess what? They still didn't work. I tryed to link this classpath with my own built jamvm but still didn't work.

Switching to other JVM won't help, as the problem is building classpath. I think I'll try to download the oldest classpath available, and hope that it builds with JDK. If it works, I'll use it to build newer classpaths...

Other suggestion?
0
 
LVL 13

Author Comment

by:MicheleMarcon
ID: 24165434
Found it! Look at this forum thread:

http://sourceforge.net/forum/message.php?msg_id=7193290
0
 
LVL 86

Expert Comment

by:CEHJ
ID: 24166139
>>Which "script" are you talking about?

I meant 'script ecj-bootstrap' actually. Glad you got it fixed ;-)

0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux boot cd to do hardware report on PC? 3 57
sql import cannot be resolved jsp 3 45
Bot application - advice 3 38
Java Eclipse Loop 3 20
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Introduction This article is the first of three articles that explain why and how the Experts Exchange QA Team does test automation for our web site. This article explains our test automation goals. Then rationale is given for the tools we use to a…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question