Solved

BITS and WSUS 3.1

Posted on 2009-04-15
5
703 Views
Last Modified: 2012-05-06
Have never been able to get bits to work in background mode with WSUS 3 or 2 for that matter, only when I force it into foreground mode does it start to download. This has never been an issue with most of our servers becuase of adequate bandwidth but I am now trying to set one up with a 512 k internet link and foreground mode just grabs all the available bandwidth

Our usual setup is Server 2003 and in a small site this server will also be running ISA 2004/6
0
Comment
Question by:sictuser
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 10

Expert Comment

by:sublifer
ID: 24149344
You may want to check your BITS settings and customize them to fit your environment better.

From your PDC, run: gpedit.msc to open your Group Policy editor

Bits settings can be found under:  Computer Config. > Admin. Templates > Network > Background Intellige...

You can limit the bandwidth during certain times and tell it to use all or another specified amount of bandwidth when no during those times.  You can also adjust the timeout (in days) for transfer jobs to be considered abandoned.
0
 

Author Comment

by:sictuser
ID: 24155567
Thanks Sublifer

I already have the group policy set. The problem is the updates will not start to download until bits is forced into foreground mode. Once in foreground mode the group policy has no effect. It seems the only way round this for me is to build the server on a site with good bandwidth, force bits into foreground mode, dowwnload updates, re site the server and set it to check for updates after 5pm. This should allow adequate time for any new updates to download via the 512k link
0
 

Accepted Solution

by:
sictuser earned 0 total points
ID: 24158106
Solved it! well it's working at the moment!!

The server is running ISA server which then forwards requests to a central linux proxy. I turned off the ISA and redirected WSUS straight to the upstream proxy, bits started working in background mode and obeyed the group ploicy settings. Left WSUS using the upstream proxy and turned the ISA services back on and bits continues to work. Would ideally like to get WSUS to use the local ISA but this will do as a workaround for now
0
 
LVL 10

Expert Comment

by:sublifer
ID: 24160614
Glad you've gotten it working.  BITS is really a great idea but it would be nicer if they had better management of it.
0
 

Author Comment

by:sictuser
ID: 24166872
I agree, it is difficult to manage
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We were having a lot of "Heartbeat Alerts" in our SCOM environment, now "Heartbeat" in a SCOM environment for those of you who might not be familiar with SCOM is a packet of data sent from the agent to the management server on a regular basis, basic…
Experts-Exchange users below are the steps you can follow to upgrade your Lync server to latest CU's or cumulative updates. Note: Perform it during non-production hours.   Step 1: Backup your lync and SQL server database. Follow below article: h…
Viewers will learn the different options available in the Backstage view in Excel 2013.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question