Solved

Menubar dropdown itmes don't show

Posted on 2009-04-15
8
634 Views
Last Modified: 2013-12-26
Hi there

I have a problem with a menu bar. I have an entry with the following stucture

File
--> TEST
        -> SUBTEST1
        -> SUBTEST2

In the menu bar, Subtest1 and 2 show up correct (see picture 1). However, if I click on the "Test" symbol on the toolbar, Sub1 and 2 won't show up (see picture 2)

The propertys in the toolbar tab of TEST are:

ToolbarItemText=TEST
ToolbarItemName=addwatch!
ToolbarItemDownName=AddWatch5!
ToolbarItemVisible=TRUE
ToolbarItemDown=FALSE
ToolbarAnimation=FALSE
ToolbarItemSpace=0
ToolbarItemOrder=0
ToolbarItemBarIndex=1
Columns=2
DopDown=TRUE
ObjectType=MenuCascade

Thank you for your help!

Thomas
test1.JPG
test2.JPG
0
Comment
Question by:mistermusic
  • 4
  • 4
8 Comments
 
LVL 14

Expert Comment

by:sandeep_patel
Comment Utility
Check the ToolbarItemVisible property for SUBTEST1 AND 2.
0
 

Author Comment

by:mistermusic
Comment Utility
Hi

The ToolbarItemVisible proberty is checked (TRUE)....
0
 
LVL 14

Expert Comment

by:sandeep_patel
Comment Utility
you need to click on little down arrow near to that icon. otherwise export your menu object and attach here.
0
 

Author Comment

by:mistermusic
Comment Utility
I would like to export and attach but since that toolbar has an ancestor and it is proberty of the company I work for it is not possible...

Any more suggestions? I am about to give it up :-(
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 14

Expert Comment

by:sandeep_patel
Comment Utility
you can try to create a fresh dummy menu without any ancestor. For the parent (i.e Test) above properties looks fine. For child (i.e subtest1 and subtest2) ToolbarItemVisible=TRUE, DopDown=FALSE,ObjectType=Menu! should work.

I checked with pb10.5 and that works pretty fine. Don't know if there is any issue with PB11.5

Regards,
Sandeep
0
 

Author Comment

by:mistermusic
Comment Utility
Hi

I created a dummy menu - same problem. I attached the exported menue to this answer.

Thank you very much!
test.txt
0
 
LVL 14

Expert Comment

by:sandeep_patel
Comment Utility
I just updated ToolbarItemName property for both subtest1 and 2 and it is working. Attaching updated menu here.


test.txt
0
 

Accepted Solution

by:
mistermusic earned 0 total points
Comment Utility
Hi

Thank you for your help!! I found the bug - it was because the menu was inherited and somehow my changes were ignored.

Thomas
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

In our object-oriented world the class is a minimal unit, a brick for constructing our applications. It is an abstraction and we know well how to use it. In well-designed software we are not usually interested in knowing how objects look in memory. …
Programmer's Notepad is, one of the best free text editing tools available, simply because the developers appear to have second-guessed every weird problem or issue a programmer is likely to run into. One of these problems is selecting and deleti…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now