• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 275
  • Last Modified:

Copy a directory and permission over the network

I need to find a way to allow users to copy a directory and the AD security into a new directory. The users will need to do this from their workstation to the mapped network drive. (2003 Servers)

I have a customer directory "g:\Customer-Projects\

and a template, under the template there are several levels of directories that need to be copied (there may be files in some of the directories but not all).

Customer Template
-Project
--Accounting
---Credits Memos
---AR
--Engineering
---design
---ATP
---Documents
---Hardware
---CAD Drawing
--Purchasing
---Bib Sheets
--Proposals
---RFQ
---Customer Requirements
--Sales
--Security


xcopy /S /I /E /O /A /T "G:\Customer-Project\Customer Template\*" "G:\Customer-Project\New"

I have tried XCOPY and this works as long as I run it as an administrator, however If I run it from the workstation I am told the following

access denied
Unable to create directory - g:\customer-project\new\project

It accreated the project directory but nothing below that level.

I have check to verify that I have permissions in that and all lower level directories and I get the same thing.

When I run the same xcopy compand on local to local or server to local I have no issues. It is only when I atempt to place the copied files onto the server.

My goal is to have a program that the user can click on and do this for either a new customer or a new project in an existing customer.
0
steele2j
Asked:
steele2j
  • 3
  • 2
1 Solution
 
AkhaterCommented:
what are the permissions of the "G:\Customer-Project\New" ?

moreover make sure that you SHARED permissions is "everyone full control" by default it is "everyone read"
0
 
steele2jAuthor Commented:
I have set the Shared permissions to full control and now get the following"

C:\Documents and Settings\jsteele>xcopy /S /I /E /O /A /T "\\secure-server-2\files\Customer-Project\Customer Template\*" "\\secure-server-2\files\Customer-Project\Raytheon Systems"
File creation error - This security ID may not be assigned as the owner of this object.

Unable to create directory - \\secure-server-2\files\Customer-Project\Raytheon Systems\Project


I get the same message even if I have taken ownership of the files and ensure I have Shared and Security  permissions to set to full control.
0
 
AkhaterCommented:
can you give robocopy a go ?

robocopy /SEC to preserve permissions
0
 
AkhaterCommented:
also my best guess is that removing the /o from your xcopy will make it work
0
 
steele2jAuthor Commented:
This exnded up being the issue after all. I tested it on anouther server with a clean share and it worked. The share permissions passed down caused the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now