Virtual Audio

On server 2008, on a virtual machine the audio is not working, how to configure?
slicgAsked:
Who is Participating?
 
Vince GlissonOwnerCommented:
On w2k8 audio is not enabled by default you have to enable it.
control panel->Sound
 
0
 
Darius GhassemCommented:
Are you running Hyper-V? Make sure you go into the settings to check to make sure your setting are configured correctly. If you are RDP into the VM make sure you enable on the RDP client.
0
 
Vince GlissonOwnerCommented:
If the virtual machine is also w2k8 then you would need to enable it also as it would also default to disabled
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
slicgAuthor Commented:
I apologize, I should be more clear.  I am running 2008 MS Server and have a virtual machine configured.  I have enabled audio on both.  The audio device I am using is a logitech usb "audio hub".  Works great on host machine but the drivers do not install on the guest OS.  The audio radio button shows at the bottom of the screen but it says the drivers were not installed.  This particular hub does not come with a cd with drivers it is plug and play.  Thank you for responding.  
0
 
Vince GlissonOwnerCommented:
Guest VM's do not support sound, i thought they did, this article explains it and has a work around.
I did more research and found this article, i learned something on this one..
http://windowsitpro.com/article/articleid/99566/guest-vm-audio-support-under-hyper-v.html
 
0
 
Darius GhassemCommented:
That is why I asked if you were running Hyper-V good post MesaVince that is the exact one I was going to throw up. A way to get around this is to RDP into the VM.
0
 
slicgAuthor Commented:
I have tried the rdp solution before posting this question, does not work.  Any other suggestions.  Thanks!  Any info on USB devices?
0
 
Darius GhassemCommented:
That has worked for me everytime. Go to the RDP-TCP properties then enable there as well. USB isn't support in 2008 Hyper-v.

http://blogs.technet.com/mattmcspirit/archive/2008/02/29/hyper-v-and-usb.aspx
0
 
Vince GlissonOwnerCommented:
no usb support as of yet, in future you'll be able to capture a usb port as you do a cd/dvd drive...
Thanks for compliment dariusg...
 
0
 
slicgAuthor Commented:
If this is working for you, let me expound.  We use HP DL380 G5's servers for workstations, do in need to install a sound card since usb devices are not recogonized? then through rdp the sound will push? darius, thanks for the links they are leading me to more info. My current speakers is a logitech audio usb hub.   How can I get audio to work, I will ditch the usb speakers and go anothe route?  please be specific.
0
 
Darius GhassemCommented:
Get some speakers that have the green port to plug into the sound card.
0
 
slicgAuthor Commented:
any recommendations on sound cards for servers?
0
 
Darius GhassemCommented:
Just any Sound max card PCI. Have you went into the server's RDP-TCP properties?
0
 
Vince GlissonOwnerCommented:
That server has 4 pci-e slots 3 full and one low profile.
sound card from SIG (they have a nice low profile one) or from Creative should do the trick.
0
 
slicgAuthor Commented:
Thanks for leading me into a direction for a solution.
0
 
Darius GhassemCommented:
What was the solution for you? Why a "B" grade?
0
 
slicgAuthor Commented:
darius, you gave me no solution that works at this time, you provided me more links to do more research.  i need specific direction on how to solve the issue.  i thank you and appreciate you for your responses.
0
 
Darius GhassemCommented:
Did you go to the RDP-TCP properties on the terminal server?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.