• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2258
  • Last Modified:

Cannot ping computer in a workgroup home network - times out

I am finally stumped on this networking issue so am hoping someone here can help me.

I have 3 WinXp computers in a home network on a common workgroup.  I'll call them Computer A,B,C.  Computer A is acting as my always on file server and is wireless.  B and C are wired.  All the computers were able to connect to Computer A until about a week ago, at which point Computer C could not connect to shared folders on Computer A.  I'm not sure what happened other than I did mess with my IP settings to try to get a Linksys gaming adapter to work (and have RMAd). Not sure if that's related.

Anywho, I have valued this as many points as possible because I am technically versed and have tried many things already, which are below.

I made all my IPs static to start with to make troubleshooting eaiser. I first narrowed the problem down to the fact that C cannot ping A.  However, B can ping C and C can ping B.  Strangely, B can ping A as well.  Only C cannot ping A.  
I then noticed when clicking Microsoft Windows Network iin Windows Explorer, it would hang for about a minute, eventually show my workgroup (named "GROUP").  When I clicked "GROUP", it would also hang, eventually producing an error that "GROUP is not accessible...The list of servers for this workgroup is not currently available"

After much research, I tried turning Computer Browser service off on B, and C, but leaving it on A only.  That had no effect.  

I then tried reseting the TCP/IP stack to installation defaults on computer C by typing "netsh int ip reset reset.log" in a command prompt. I also reset WINSOCK entries to installation defaults by typing "netsh winsock reset catalog".  After a reboot, the hanging stopped and I could click my "GROUP" workgroup and see A, and B from C, but A was still not pingable.

I installed Network Magic Pro on A, B, and C to see if anything interesting would show.  On computer A, I did notice that it supposedly saw C, but the IP was wrong in Network Magic.  How could that be?  So I tried the resetting trick above that I did but now on A, rebooted and then the correct IP was displayed.  Still could not ping A <-> C.  

I tried Winsock Fix at http://www.snapfiles.com/get/winsockxpfix.html
No luck with that either, could still see computers in the workgroup but could not ping.

Lastly, I tried changing the workgroup on A first to "MYGROUP", rebooted.  I then changed it to "MYGROUP" on C and rebooted.  Now, the hanging issue is occuring again when clicking on "My Network Places".  Computer Browser turned on all of them again as well.

I'm really am stumped, thinking of trying LMHOST files instead, but I shouldn't have to.  Simple File Sharing and Workgroups has always worked for me.  What's really irksome is that B and C can share folders and ping fine.  And B can share folders and ping with A.  But A and C cannot.  I have AVG 8 and Malware Bytes on all 3 computers, only XP Firewall is on and an exception for File Sharing is on.

Any ideas?
0
Ordendelfai
Asked:
Ordendelfai
  • 5
  • 4
  • 3
  • +2
2 Solutions
 
CCI_ITCommented:
Try these 2 things to start.
 
1) turn off windows firewall
2) make sure the Subnet mask is the same on all computers since you entered them statically.
See if A can ping anything.
0
 
OrdendelfaiAuthor Commented:
Yep, tried turning windows firewall off on both computers.  Subnet is 255.255.255.0 on both.  Computer B is also on same subnet, and can ping A and C with windows firewall on or off on either computer.
0
 
OrdendelfaiAuthor Commented:
Just following up, still unresolved if anyone has any other ideas.
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
_Commented:
Just a thought:
if CompC was the one you tried the Gaming NIC in, it might have set something (or tried to) in the router.
Firewall, QoS, filtering, forwarding, Vlan... something.

Have you tried shuting A, B, C, down and resetting the router?
0
 
OrdendelfaiAuthor Commented:
Coral, the router being the problem is an interesting thought.  Before I tried doing a hard reset of the router, I unboxed the gaming adapter and plugged it into Computer C ethernet port.  It's a WGA600N Linksys Gaming Adapter.  It works sporadically but drops constantly hence I'm sending it back.

When I used the WGA600N to access internet and plugged into Computer C, Computer C can now ping Computer A and access shared folders.  So there's a big clue, just not sure what it means yet or where the issue is.  I might try the router hard reset and see what happens.
0
 
CCI_ITCommented:
if they are all on the same subnet, it should even be touching the router.
0
 
CCI_ITCommented:
unless you mean a linksys router/switch compbination.
 
(or netgear etc.)
0
 
giorgosy78Commented:
Just a small thought

If u can connect A and C directly with a cross over cat 5 cable will show if the problem is with your router.

0
 
_Commented:
>> When I used the WGA600N to access internet and plugged into Computer C...

ooooooh... my head...
any way you can tell if the Linksys was WiFi'ing to Computer A directly or through the router?

>> I did notice that it supposedly saw C, but the IP was wrong in Network Magic.  How could that be?  

Sounds like you had 2 routers going at the same time, not a bad thing in itself, but it likes to do strange things with IP addys, and add wifi security settings, and it can get interesting.
0
 
ChiefITCommented:
Make sure netbios over TCP/Ip is enabled on your C computer, not netbios over DHCP.
0
 
OrdendelfaiAuthor Commented:
Coral47: The linksys is wifi'ing through the router for sure - I assigned it an IP in the range the router handles and forced it to connect to my access point.  Logging into the router confirms the Linksys is being handled by the router (a D-Link router btw).  Only one router is installed with a DSL modem.

ChiefIT: Netbois over TCP/IP is the one enabled.

I found something that worked, though I can't explain why.  When I had first installed the WGA600N device , I gave it a fixed IP of 192.168.0.101.  After hooking up the device again to C and seeing that C could ping A again, I had a thought to change the IP of C to 192.168.0.101. I removed the WGA600N, change the IP on C, rebooted C and A and the router, and disabled Computer Browser again on C.  Now C can ping A and share files no problem.  I'm scared to change it back to something else and break it to understand why this worked.  Strangest problem I've ever come across on a home network.  Anyone want to take a stab at what happened here?

0
 
_Commented:
>>  Anyone want to take a stab at what happened here?

Nope.  If it's working, don't even breathe hard.     ; )
Just be sure to write down that config info, or at least the steps that fixed it.

Some things I would look at:
- Lease Times used by the different devices.
- Static and DHCP addy ranges
- if the different "hosts" assigns addys from top-to-bottom or bottom-to-top.
0
 
ChiefITCommented:
Yes,

Netbios is not a routeable protocol. It will not go through nat, over a vpn tunnel or across a firewall easily. It will also not go over a vlan on different subnets. by removing the nat router and directly connecting to it through a the same subnet, you took out that equation. I have helped many people overcome this.

Unlike NSLookup, Ping is a multiple communications protocol troubleshooting utility. If you ping by IP address, you are performing an arp ping, if you ping by netbios name you are troubleshooting netbios, if you ping by fully qualified domain name you are troubleshooting DNS. Ping can also be used to troubleshoot your netbios name resolution, and mtu (maximum transferable units).

I have no doubt you couldn't get your netbios ping or file and print sharing to work because you were between subnets, over a firewall or somethint that wouldn't allow netbios broadcasts to propogate from one computer to another.

Like I said, if you want your router in there again, we can fix this. Adding an LMHOST record between your small workgroup OR enabling a WINS server will do just fine. Also a port query between the computers will allow you to see if the ports are blocked between each computer.

The ports used for file and printer sharing as well as a netbios ping are:

WINS and Netbios broadcasts:
WINS/Netbios ports 137 UDP/TCP
Netbios datagram port 138 UDP
Netbios datagram port 139 UDP

Simultaneously Windows will use SMB or netbios over SMB to share files and printers. those ports are:
SMB port 445 UDP and TCP
as well as Netbios datagram port 139 UDP.

As stated above, netbios is not routeable without a WINS connection or all computers having an LMhost record. If you wish for more information, google search "domain master browser chiefit" or just ask.

0
 
OrdendelfaiAuthor Commented:
Alright everyone, I still didn't figure out a final solution to this.  I do agree that the issue probably resided in the D-Link router.  This whole issue reminded me how much I dislike wireless, so I just hard wired my pc's to Cat6 for gigabit transfer speeds.  I also installed a windows server which I had been wanting to do for some time anyways to eliminate the d-link router.  I still have the wireless, but only for guest wifi.

I am splitting this one as I do think ChiefIT gave the most detailed response of how to fix this, and Coral pointed me to the router in the first place.

0
 
ChiefITCommented:
To fix this, you need a WINS connection or to configure a LMHOST file  between the two subnet's domain master browsers. This explains how to get netbios broadcasts routeable. It's called the WINS/WAN configuration of the master browser service.

http://www.microsoft.com/resources/documentation/windowsnt/4/server/reskit/en-us/net/chptr3.mspx?mfr=true
0
 
_Commented:
Thank you much.   : )
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now