• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 982
  • Last Modified:

USB Drive recognized but is inaccessible

I have a FreeAgent Go drive I am trying to get to work on a Windows XP computer with SP3 installed.  This is the second drive i have tried.  The first was 1TB Western Digital.  Windows would recognize that a drive was plugged in but would not recognize the device.

With the Seagate Go 320GB it recognizes it.  Installs the driver and the Device shows up under Hard Drives in device manager.  When i try to populate the volume I get the Device Unknown and Status unreadable.  

It does not show up in Disk Manger , or in Windows Explorer/My computer.

I have tried different ports/remove and reinstall etc..  Any ideas?
Thanks in advance.
0
Blade42
Asked:
Blade42
  • 9
  • 8
  • 2
1 Solution
 
HuntedBountyCommented:
If its a new drive, i think its only meant for vista (check on the packet on what OS its compatible with)

If you have a vista pc or a friend who has a vista pc, try and see if the drive works on vista, if it does then its a compatible problem with XP, and if it doesnt work, there must be something wrong with the drive.

0
 
Blade42Author Commented:
The compatibility according to the site says XP/Vista.  
0
 
Blade42Author Commented:
Also the drive works on another XP system.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
HuntedBountyCommented:
Then the problem has to be with your pc.

"The first was 1TB Western Digital.  Windows would recognize that a drive was plugged in but would not recognize the device."

For that usb drive, did you get a cd with it or something, because apparently your system doesnt have the drivers to run it.

Search the site for the drivers of that usb drive and install them.

0
 
nobusbiljart fanCommented:
here some things to try :

Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

http://support.microsoft.com/kb/925196

OR :
Remove all USB drivers with:     https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usb.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbport.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbprint.inf
0
 
Blade42Author Commented:
I tired each of those suggestions and now the device is installing as unknown device rather than even recognizing it as a Free Agent Go.  
0
 
nobusbiljart fanCommented:
try updating the chipset driver then
0
 
Blade42Author Commented:
Is there a good way to tell which chipset drivers to install?
0
 
nobusbiljart fanCommented:
normally you look what mobo you have, or pc model.
you find the drivers on their site
you can seeit in device manager -for many it is reflected in the  video ada^pter
you can also run siw for identifying devices
0
 
nobusbiljart fanCommented:
or if you post your model - i'll look it up
0
 
Blade42Author Commented:
I apologize for the delay.  It is a Dell Optiplex.  I have updated the BIOS and applied the Chipset Drivers taht Dell recommends to the computer.  Still no go.  I have moved the USB drive to another computer and confirmed that it works fine.  
0
 
nobusbiljart fanCommented:
you can test if the usb hardware is still ok by running from a live Knoppix cd, it supports usb :
ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V6.0.1CD-2009-02-08-EN.iso

you can also  run this from the run box (you can copy the command) :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
or :start>run>services.msc
look for Removable Storage Service. Is it set to Auto, and if not started, click the Start link in the top left...
In c:\windowsc:\windows\inf.  look for usbstor.inf -  If not found, copy from another PC. If you find it, right click it and select Install
See if it rebuilds the USB support...  normally located at c:\windows\system32\drivers
0
 
Blade42Author Commented:
I will try the Knoppix CD.  I know that USB support still works for the most part as I have a keyboard/mouse and a printer connected.  I have moved them around to different ports and am still able to use them.
0
 
nobusbiljart fanCommented:
i hope this helps, but i'v' seen cases where they did a fresh install to get it going again...
0
 
Blade42Author Commented:
I have been unable to test this solution as of yet.  I apologize for the long delay.  I beleive the answer is going to be resinstalling Windows as every other USB device I connect to any port will work except for disk drives.
0
 
nobusbiljart fanCommented:
then it seems that the usb is ok, but you have a problem with the drivers
these are the last things to try i'v found :
5-The registry keys reside in the registry (click start, run, regedit) under the following keys:
 HKEY_LOCAL_MACHINESYSTEM\CurrentControlSet\Enum

 Under the headings USB, and USBSTOR. Right click "USB", click "permissions" click the "Allow Full Control" checkbox, and OK. Once you have completed this, right click the "USB" key, and click delete. Do the same for the "USBSTOR" key, delete both.
 Restart the PC, . After this has completed, plug your USB Jumpdrive back in, and it should recognize.

If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. A Windows repair install should correct this.

Hkey_local_Machine_System_CurrentControlSet>Services>USBSTOR
Select USBSTOR & on the right side change the value of 'Start' to '3'

--------------------------------------------
In the Registry Editor, browse to "HKLM\System\Setup" and check the following REG_DWORD entries:

-AuditInProgress
-FactoryPreinstallInProgress
-SetupType
-SystemSetupInProgress

If any one of those doesn't exist, nevermind. For those which exist, make sure they are set to '0'.
0
 
Blade42Author Commented:
Thank You.  I will try those this weekend.
0
 
Blade42Author Commented:
Thanks for all the help on this!
0
 
nobusbiljart fanCommented:
no problem, you're welcome !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 9
  • 8
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now