?
Solved

Exchange 2003 Outlook Web Access not working for at least one user

Posted on 2009-04-16
5
Medium Priority
?
777 Views
Last Modified: 2012-05-06
Hello all,

We are having a strange problem. Outlook Web Access is working for most users. So far we only know of one user who has told us that it is not working for them. There may be others who have not tried, or have not reported it to us.

When anyone goes to https://public-fqdn/Exchange/ (We are using SSL with a valid publicly signed certificate) they do not get the Outlook Web Access Welcome Screen, but rather a generic login box appears.

For most users, they can then enter their password and it takes them through to the correct OWA screen. For this one user, he then sees the blue vertical divider between what should be the two frames (folder list on the left and viewer on the right), but both are showing 404 errors. We have tried him on a couple of different machines, with IE, Firefox and Chrome. On his PC he can log into OWA as another user and it displays fine, so it does not appear to be his PC, also as mentioned he has tried on a couple of machines.

This user has an iPhone which connects using Active Sync, this is working correctly.

We have tried recreating the default folders as described: http://support.microsoft.com/?id=883380

We have checked the NTFS permissions on the folders to check that they were not the problem, but they appear to be correct.

Any ideas?

Jerry
0
Comment
Question by:Luxtech
  • 2
  • 2
5 Comments
 
LVL 8

Accepted Solution

by:
epohl earned 2000 total points
ID: 24156816
Can you check the IIS logs on the OWA server to get the sepcific errors when that user account trys to login? You will want to use forms based authentication if the want the webpage login rather than the login pop up box.


http://www.petri.co.il/configuring_forms_based_authentication_in_exchange_2003.htm
0
 

Expert Comment

by:vanblijd
ID: 24156822
Try moving his mailbox to another server/store.
0
 
LVL 1

Author Comment

by:Luxtech
ID: 24183559
Sorry for the delay in replying, been busy!

@vanblijd: Unfortunately we do not have another Exchange server to move his account to.

@epohl: I enabled the forms based authentication as described in the Petri article. This has solved that first problem, however it stopped iPhones worjking! I have resolved that with the instructions here: http://support.microsoft.com/?kbid=817379

As for the errors, the only entries in the log are shown in the code snippet (I have removed identifying information) :)

Any advice gratefully received. Unfortunately the one person who is having this issue is one of the top people! :)

Thanks,

Jerry

2009-04-20 11:11:10 W3SVC1 <server-ipaddress> POST /exchweb/bin/auth/owaauth.dll - 443 - <client-ipaddress> Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 302 0 0
2009-04-20 11:11:10 W3SVC1 <server-ipaddress> GET /Exchange - 443 <username> <client-ipaddress> Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 302 0 0
2009-04-20 11:11:10 W3SVC1 <server-ipaddress> GET /Exchange/ - 443 <username> <client-ipaddress> Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 200 0 0
2009-04-20 11:11:10 W3SVC1 <server-ipaddress> GET /Exchange/<username>/ Cmd=navbar 443 <username> <client-ipaddress> Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 404 0 0
2009-04-20 11:11:11 W3SVC1 <server-ipaddress> GET /Exchange/<username>/Inbox/ Cmd=contents 443 <username> <client-ipaddress> Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 404 0 0

Open in new window

0
 
LVL 1

Author Comment

by:Luxtech
ID: 24183793
OK, this is confusing now...

I have noticed that actually the username in the error logs was not the correct username. It was actually username+companyname (Plus symbol in between). This is one of the user's email addresses (not the primary) he uses for registering on several websites etc. For some reason OWA was using this and looking for Exchange/username+company/Inbox which of course does not exist.

I removed this email address, disabled and re-enabled the account's OWA access and this now works. I have added this email address back in, and all still working.

Not sure what happened here, but seems to working.

Am awarding points to epohl as solved the authentication issue, and pointed in right direction for the 404 error.

Thanks,

Jerry
0
 
LVL 8

Expert Comment

by:epohl
ID: 24183797
Are there any kind of extended characters in the username other than alpahnumeric ? Is the users default smtp address the same email domain as users that can logon successfully?
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
This article will help to fix the below errors for MS Exchange Server 2016 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses
Course of the Month14 days, 19 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question