• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 874
  • Last Modified:

PC will not boot if USB drive is attached

Hi Experts,

I have 2 systems based on Asus M5GZ-MX motherboards.
Both systems have the latest BIOS version.

I recently acquired 2 Lacie 1 TB USB drives, both are formatted as a single NTFS partition.
These drives are used for backups and are not bootable.
I want to be able to leave one USB drive attached to each PC for automatic backups.

My problem is that neither of these PCs will boot if a Lacie 1 TB USB drive is attached.
The boot sequence does not progress past the BIOS splash screen.
If I press DEL during boot, an early message says:

1 USB device detected (I don't have any other USB devices)

The last message I see on the screen is:

Auto-detecting USB Mass Storage Devices.
Device #01

It doesn't go any further than that.

These drives work fine if plugged in after the PC boots.

I have other USB drives, e.g. Maxtor that can be connected while these PCs boot.

Regards,
Leigh
0
LeighWardle
Asked:
LeighWardle
  • 13
  • 7
  • 4
  • +1
1 Solution
 
andeporterCommented:
Change the boot order in the BIOS. Make sure it checks the HDD for a boot sector before the removable media :)
0
 
blaazeCommented:
its very simple
just ignore those usb harddrives while booting
to fix it first goto ur bios setup and then remove those usb drives from the boot list
keep only the system's hdd on the list
then u can get the system working smoothly!!
0
 
LeighWardleAuthor Commented:
Sorry, I forgot to mention that the BIOS Boot Sequence allows only 3 boot devices.  I have the boot sequence set to Floppy, CD/DVD Drive then Primary HD.  
There is no mention of any USB devices in the Boot Sequence.
Am I missing something?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
blaazeCommented:
can u plz tell us what u want
do u want that usb drive to be booted up while booting or u wont need it
0
 
LeighWardleAuthor Commented:
I said in my question: "These drives are used for backups and are not bootable.".
I just want to leave them connected all the time.
And I want my PCs to boot without me having to disconnect them.
0
 
LeighWardleAuthor Commented:
Let me clarify my last comment:  I said in my question: "These drives are used for backups and are not bootable.".
I just want to leave them connected all the time.
And I want my PCs to boot from the Internal drive without me having to disconnect the USB drive.
0
 
blaazeCommented:
can u send me a snapshot of the bios boot priority , so that i can tell u what to do

send me at blaazetech@gmail.com
0
 
LeighWardleAuthor Commented:
blaaze, here is the snapshot of the bios boot priority.
0003.JPG
0
 
blaazeCommented:
its ok but plz send one with full screen , i need all details on the screen
0
 
LeighWardleAuthor Commented:
blaaze, there is no other technical information on the bios boot priority screen.
The only other information is stuff about how to edit the boot priority, how to exit etc.
0
 
LeighWardleAuthor Commented:
The make and model of the USB drives is a factor here.

1TB LACIE HARD DISKs are Model 301304A - Design by Neil Poulton - USB2.0, 7200RPM.

What needs to be explained is why the PCs will happily boot with a Maxtor USB drive (also single NTFS partition, not bootable) connected?
0
 
blaazeCommented:
ok here is the second run
if u dont want ur floppy then just do one thing

set the boot device priority as follows

1st boot device>3m-pioneer dvd-rw
2nd boot device>pm-wdc wd1600jb hdd( i think this is the internal hdd)
3rd boot device > ur new usb drive

and in parent menu dont forget to enable boot usb devices while booting
0
 
LeighWardleAuthor Commented:
Hi Experts,

It is about midnight here in Melbourne, Australia.
Time for sleep.

Will be online again in 8 hours...
0
 
LeighWardleAuthor Commented:
blaaze said:
ok here is the second run
if u dont want ur floppy then just do one thingset the boot device priority as follows1st boot device>3m-pioneer dvd-rw2nd boot device>pm-wdc wd1600jb hdd( i think this is the internal hdd)3rd boot device > ur new usb driveand in parent menu dont forget to enable boot usb devices while booting

I have prior experience with getting USB devices to boot with this BIOS.
But with the Lacie drives we have "Catch 22" because:
  • we can't get into the BIOS settings if the Lacie drive is connected
  • the BIOS will only let me include a USB drive in the boot sequence if it is connected during boot (it is not recognized if it gets connected while editing the BIOS settings
0
 
LeighWardleAuthor Commented:
It's goodnight for me...
0
 
blaazeCommented:
i think this is ur model of 1tb hdd
LaCie d2 SAFE Hard Drive

now plz check that it is connected to usb port and not to the firewire port
0
 
LeighWardleAuthor Commented:
Here's the spec on the Lacie drive: http://www.lacie.com/download/datasheet/hddesignbyneilpoulton_en.pdf

The drive doesn't have a firewire port.

Let me emphasize that the Lacie drive works fine if I connect it after the BIOS boot sequence.
0
 
asmodeusnzCommented:
Many New computers, including Servers, promote USB drives to be the primary boot device whether you have that enabled or not. In doing so, especially since your USB drives are non-bootable and used for backups only this will cause the system to halt, which is exactly what is happening in your case.
So the short answer is NO, it seems your PC is promoting your USB device to be primary boot device so you cant leave the external USB drive connected.
0
 
LeighWardleAuthor Commented:
asmodeusnz said:
Many New computers, including Servers, promote USB drives to be theprimary boot device whether you have that enabled or not. In doing so,especially since your USB drives are non-bootable and used for backupsonly this will cause the system to halt, which is exactly what ishappening in your case.So the short answer is NO, it seems your PCis promoting your USB device to be primary boot device so you cantleave the external USB drive connected.Many New computers, including Servers, promote USB drives to be the primary boot device whether you have that enabled or not. In doing so, especially since your USB drives are non-bootable and used for backups only this will cause the system to halt, which is exactly what is happening in your case.So the short answer is NO, it seems your PC is promoting your USB device to be primary boot device so you cant leave the external USB drive connected.
I am still puzzled as to why the PCs will happily boot with a Maxtor USB drive (also single NTFS partition, not bootable) connected?
0
 
blaazeCommented:
i think i got ur answer , it is because ur model of the hdd is having a power switch on it, as it needs seperate power, the system cannot recognize it at boot time, all u have to do is, set the boot device priority as i mentioned above and then keep ur hdd connected to the usb port but not switched on(OFF)
after booting up u can just switch on it(ON) to get it working

as simple as that, but it was eating everyone's brain
0
 
LeighWardleAuthor Commented:
blaaze said:

i think i got ur answer , it is because ur model of the hdd is having a power switch on it, as it needs seperate power, the system cannot recognize it at boot time, all u have to do is, set the boot device priority as i mentioned above and then keep ur hdd connected to the usb port but not switched on(OFF)after booting up u can just switch on it(ON) to get it workingas simple as that, but it was eating everyone's brain.

I already know that I can boot with the Lacie drive disconnected or switched off.
That's not a practical solution because the PC is a Server and I am 10 miles away from it.
Occasionally Windows update forces a reboot and there is no technical person there to manipulate the switch on the Lacie drive.

When I use a Maxtor USB drive there is no boot problem.
0
 
asmodeusnzCommented:
Hi Leigh,

Only Some USB Devices get promoted to primary boot devices. They dont all do it.
It depends on the BIOS and the USB device.
Obviously your Lacie drive is getting promoted and your Maxtor is not.

Why dont you just use the Maxtor since that works fine?
0
 
LeighWardleAuthor Commented:
Hi all,

Sorry it's been a few days since I have had time to look at this issue.

asmodeusnz: I don't believe any of my USB Devices are getting promoted to primary boot devices.  If they were, wouldn't I see some message like "No boot device found", as none of these drives have a partition set to Active.  
The Maxtor was only used for testing, it's only 160 GB, I need 1 TB.

I have also tested a WD Essentials 1 TB drive - the behavious is the same as the Lacie 1 TB drives.

Last of all, I have tested a system that uses an Asus M5GZ-MX/1333 motherboard - this is a newer board than the Asus M5GZ-MX motherboard that has the boot problem.  This board works OK with all the USB drives.

I really want to close this Question now - the only relatively simple and inexpensive solution that seems to be available is to replace the Asus M5GZ-MX motherboards by M5GZ-MX/1333 motherboards.

Regards,
Leigh

0
 
asmodeusnzCommented:
asmodeusnz: I don't believe any of my USB Devices are getting promoted to primary boot devices.  If they were, wouldn't I see some message like "No boot device found", as none of these drives have a partition set to Active.  

You wont see any error message, you'll just get a blank screen after BIOS Posting
0
 
asmodeusnzCommented:
The comments I've made have answered your question correctly

When your Lacie drivers are plugged in, your PC is halting on boot, with a blank screen after you get usb device detected.

As I said, some drives will not get promoted to BOOT, others will

Sometimes the correct answer is just NO, you cant do it with those Lacie drives.
You've even proven that yourself in testing....


0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 13
  • 7
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now