Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2570
  • Last Modified:

External mail flow to public folders not working with #5.2.0 smtp;550 5.2.0 STOREDRV.Deliver MapiExceptionNotFound error

The issue: External emails sent to public folders bounce with the following error:

Your message did not reach some or all of the intended recipients.

      Subject:      fgfgfgfg
      Sent:      16/04/2009 09:50

The following recipient(s) could not be reached:

      test@company.com on 16/04/2009 09:50
            The message reached the recipient's e-mail system, but delivery was refused.  Attempt to resend the message.  If it still fails, contact your system administrator.
            <company.local #5.2.0 smtp;550 5.2.0 STOREDRV.Deliver: The Microsoft Exchange Information Store service reported an error. The following information should help identify the cause of this error: "MapiExceptionNotFound:16.18969:99000000, 17.27161:000000005C000000000000000000000000000000, 255.23226:666F3A20, 255.27962:44000000, 255.17082:BFF9FFFF, 0.25697:94000000, 4.21921:BFF9FFFF, 255.27962:FA000000, 255.1494:02400080, 255.26426:96000000, 4.9206:BFF9FFFF, 4.7974:BFF9FFFF, 255.1750:0F010480, 0.26849:0F010480, 255.21817:BFF9FFFF".>

We are in a mixed 2003/2007 Exchange environment as I am in the process of moving to 2007.

Our Exchange setup:
2003 Standard SP2 x64 all Ex2007 servers
2003 Standard SP2 x86 all Ex2003 servers

1 Ex2007 CAS/Hub Transport Server 'Ex2007-1'
2 Ex2003 BE Servers; 1 server has 99% of mailboxes. 'Ex2003-1' and 'Ex2003-2'
2 Ex2007 Mailbox servers; configured with a handful of mailboxes, not yet live. 'Ex2007-2' and 'Ex2007-3'

As expected emails come in to Ex2007-1 and are relayed either by smtp to the Ex2003 BE servers or by the new 'store driver' to ex2007 servers. Public folder emails however when submitted to Ex2007-1 bounce with the above error. If I telnet to port 25 to Ex2003-1 or Ex2003-2 they deliver ok.

It is as if Ex2007-1 can find the proxy address (else the bounce would be different) but cannot ascertain what server has that proxy address. The categoriser appears to be working ok and the adsi entries under CN=Test,CN=Microsoft Exchange System Objects,DC=jobsgopublic,DC=local,dc2 [DC2.company.local] appears to be fine.

Public folders on Ex2007-2 work fine so long as so I do not try to add a replica onto one of the Ex2003 BE servers. Doing so causes the email to queue in the Local Delivery queue on the Ex2003 BE server and for only the 'TRANSFER STOREDRIVER' line to be logged and not the 'DELIVER STOREDRIVER' line indicating successful delivery.  - When creating a replica onto a Ex2003 server Ex2007-1 does become aware of this as it starts to relay emails to it but they just sit in its Local Delivery queue as stated as the public folder is never created.

New public folders created also do not work as well as mail disabling and re-enabling them.

Creating replicas of the public folders on an Ex2007 server does not resolve the issue as public folder replication does not occur, it would appear that this is part of the problem.

Public folder Folder content, hierarchy etc. email apepar to be working fine.

What could have caused the problem: I have been testing SCR and consequently have been creating and deleting public folder databases on Ex2007-2. As there were never any replicas of any public folders from the Ex2003 servers on this database I cannot see how this could have caused any issues but it is probably not a coincidence.

This problem is very similar to the issue mentioned here:http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23795293.html?sfQueryTermInfo=1+10+mapiexceptionnotfound    but I have ruled out duplicate proxyaddresses / smtp addresses.

I have checked http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23163517.html?sfQueryTermInfo=1+10+mapiexceptionnotfound 
All the servers are in the relevant groups within the  'Microsoft Exchange Security Groups' OU and 'Exchange Servers' group inherits the relevant permissions.

All help greatly appreciated.
0
BenyG
Asked:
BenyG
3 Solutions
 
consultkhanCommented:
on the mail enabled public folders you must have "create permissions" given to anonymous group.this is a known issue.
could you verify this please ?
thanks,
consultkhan
0
 
BenyGAuthor Commented:
Anonymous and Default both have Author role permissions, which incudes 'Create items.'

I have had the issue are you stating before, and even wrote a page on it: http://www.rogerrabbit.net/wiki/Bounce_5.2.1_when_emailing_a_public_folder_(Exchange)
0
 
consultkhanCommented:
Ok.Could you enable diagnostic logging on the public folder in question,send an email to that folder,capture log and post it here ?

Its getting interesting.
thanks,
consultkhan
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
MiDanielCommented:
I had a similar problem with an Mail-Enabled Public Folder. This is a permissions problem on the Public Folder. Please make sure that the Public Folder in question has Anonymous permissions assigned as Author. This allows external email from an "Anonymous" source to "Create an Item" in the public folder. If this permission is not assigned you will received the 550 5.20 STOREDRV error message as well as Event ID: 8010 error message in the Event Viewer on an Exchange 2007 Server or a Small Business 2008 Server.

You can assign this permission using the Exchange Power Shell or by accessing the Public Folders via Outlook with an user account that has Public Folder Administrative Permissions or is the Folder Owner. In either case, assign Anonymous the Author permissions.

You can verify that this is working by monitoring the Messaging Queue on Exchange Server 2007. The queue should show messages with a "Retry" status. These are the messages that were rejected by the Public Folder. When you click on the message you can read the message header information. After the permissions have been updated for Anonymous, you can monitor the public folder and verify that the messages that were in the queue with a retry status are being delivered.

0
 
BenyGAuthor Commented:
MiDaniel: Already tried, see above.

Thanks to consultkhan and MiDaniel, for some strange reason this problem appeared to fix itself after a few weeks. It is now all working OK. Presumerably I did another config for something else in inadvertently fixed this issue.
0
 
JimmyDailyCommented:
For Anyone banging their heads against the wall and googling this with no results.
I got this error after an Exchange 2k3 and 2010 migration.
The exchange 2003 uninstall failed (as they always do) and left exchange in a sorry state.

I had corrupted messages in the folder before the migration and had to do some trickey to get replication working, im guessing this broke the mailbox
Anyway,my first public folder issue was cause by a dodgy container in adsi check this link
http://blogs.dirteam.com/blogs/davestork/archive/2010/03/16/mail-enabled-public-folder-recipient-not-found.aspx

You will then run into the issue described above, nothing I could do resolved the issue.
Easiest way to fix it.

jump into EMS, Disable the mailbox for the public folder.
using outlook, move all the messages to a "backup" box
Write down user permissions.
Delete the mailbox
Create a new mailbox
Mail enable and test mailbox.
Move old mail back

Ugly I know, but it works.

Note you might run into issues moving the messages out "all at once" if you do. move messages in smaller sections (it will throw a permissions error of all things)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now