PowerEdge 1800 SATA Cerc 6 squeals with high-pitch tone during format

Posted on 2009-04-16
Last Modified: 2013-12-15
I have a PE1800 (Cerc 6) that I bought with 3 * SATA 750GB disks but recently upgraded to 1TB * 6 SATA disks.
The card cannot make a >2TB array, so there are  two arrays: Cerc Arr012 and Cerc Arr345, each made of 3 * 1TB disks in RAID 5 for a total of 1.9 TB per array.

I installed and configured this server as an R-Snapshot backup server, but during initial testing, I realized that I only had 2TB of space to use for backups because LVM could only go up to 2TB in a volume. I needed to repartition, so I backed up the system using rsync and am trying to reinstall RHEL5.

At first, I tried to put the LVM-usable disk space from Arr012 and Arr345 into the same Volume Group so that I could have one big /srv partition for backups:
Arr012: sda1-/boot + sda2-swap + sda3-LogVol00
Arr345: sdb1-LogVol00
LogVol00 = swap + /(root) + /var + /tmp + /srv
However, when Disk Druid got to the formatting stage, a continuous high-pitched beep or whine or alarm sound emanated from the case. It just kept going for about 10 minutes while I was Googling the issue. Finally, I shut the machine down and started the installation over again.

I then tried this:
Arr012: sda1-/boot + sda2-LogVol00
Arr345: sdb1-LogVol01
LogVol00 = swap + /(boot) + /var + /tmp + /srv
LogVol01 = /srv2

I divided it up like the above and then set it to format. It did not squeal like the first try, but it does squeal for a little and then go quiet as it formats. And the format is taking forever. I went home after 20:00, and it was still formatting /srv2. I cannot tell whether it is stalled or not, but I would liek to know why the high-toned squeal.

Should I worry about this sound?
Can I rely on this server in this condition?
Should I give up on this machine?
Question by:shinmaikeru
    LVL 18

    Assisted Solution

    The high-pitched beep may be due to a read error that made the drive enters in a too long error recovery process which forced the CERC card to disconnect it...and beep !

    More details below...

    Large SATA drives are suffering of TWO major features:

    1/ TLER (or CCTL) are missing feature on Desktop editions
    Desktop drive editions delay their answer when a read error occurs to retry and retry the read ... too long for the hw raid card not to consider the drive is dead/not responding anymore (it's back at reboot time...but it still has some unreadable sectors somewhere waiting for you !)

    2/ "Unrecoverable bit read error per bits read" ratio is too high for large drives
    Most of the Desktop edition have a 1 per 10 exp 15 ratio (sometimes 1 per 10 exp 14 for the worst SATA Desktop drives).
    This means, you have a 0.8% probability to get an unrecoverable read error per 1TB read (8% for those drives with a 1 per 10 exp 14 ratio)

    NB: Some SAS drives reach a 1 per 10 exp 16 "Nonrecoverable Read Errors per Bits Read" ratio for their 2,5" models
    ==> This is an "Enterprise" usage of course

    -No RAID 5 with SATA drives while they keep having such a high failure rate !
    -Doing RAID 6 with 4 drives is way slower than RAID 10 and cost the same
    -Doing RAID 6 with 5-6 drives is not a bad idea if you align the partition and try to use array block size equals to your client io block size

    Accepted Solution

    Thank you for the information. Just to clarify, these are enterprise-grade drives that I carefully chose and ordered directly from a Seagate dealer, and they are 3.5", but I appreciate the extra information. In researching this, I also learned that the SATA Cerc 1.5/6 sold in the  Dell PE1800 has a terrible reputation.

    However, the problem turned out to be a failed drive in the second array, Arr345. Number 4 was bad. I was formatting for a new installation when it happened, so there was no RAID monitoring software working. When I rebooted, I entered the RAID configuration utility and it clearly said that HDD04 was bad.

    I am now working on getting it replaced and buying a spare. My initial plan was to have a hot spare, but the 2TB limit that necessitates making two R5 arrays prevents me from using the hot spare, so I will have to have a backup sitting in the server room.

    Thank you again.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Join & Write a Comment

    Suggested Solutions

    Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
    Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now