Right click print option missing on PDF documents

Posted on 2009-04-16
Last Modified: 2012-05-06
I have at least two machines which users do not have either Power or admin rights to. When the users open up a folder containing PDF documents which they have full rights to, they are unable to right click and select print as the option is not their this is the same for file print.

The administration has this functionality on both machines, and so do the users on other documents apart from PDF's. I have tried a reinstall of Adobe Reader 9.1 to no avail.

Any suggestions would be greatly appreciated.
Question by:Radar888
    LVL 66

    Expert Comment

    Thats going to be controlled by Shell32.dll

    If you make them an admin, it doesnt change the behaviour, right? It shouldnt.....

    Start>run>regsvr32 shell32.dll

    Or, replace it with one from another machine. Delete it from c:\windows\system32\dllcache first, and then rename it in teh System32 directory, and then replace it.

    Author Comment

    Hi Johnb6767,

    Thanks for taking the time to have a look at this problem.

    You did guess right adding the user to the admin group has no bearings on this problem. Furthermore i tried you suggested fixes but to no avail, copying the shel32.DLL from another machine where the user has this functionality still had no effect. This problem only exists with PDF documents, and is only relevant when using adobe reader as other an installation of another PDF program (nuance) corrects the problem.
    LVL 66

    Expert Comment

    And nuance is installed AFTER the adobe is found not to work right, or before?

    Author Comment

    AFTER of course
    LVL 66

    Accepted Solution

    Maybe another shell extension causing the problem.....

    ShellExView - Shell Extension Manager For Windows

    Sort by the MFGR column, and try disabling all NON MS extensions, and see if teh problem is resolved. If it is, then you have the proces of elimination to play with....

    If not, start disabling in larger chunks...... Then keep retrying....

    Expert Comment

    I found a solution for this as well - I know it's a little late to the game but I hope this helps anyone else that looks for a resolution to this issue.

    Open Regedit
    Navigate to [HKEY_CLASSES_ROOT\.pdf]
    Rename/Delete the above entry to ".pdfold"
    Your right-click context menu for "Print" when selecting a .PDF file should be restored. (A reboot should not be necessary)
    Once you have verified this you can delete the renamed ".pdfold" if you haven't already.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    Visual xHarbour 1 52
    Software for Checking updates on Different Forums. 5 45
    Driver Problem 12 51
    HP PC Hardware Diagnostics UEFI 11 46
    A high-level exploration of how our ever-increasing access to information has changed the way we do our jobs.
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    This video demonstrates basic masking and how to edit the mask to reveal the desired image.
    In this fifth video of the Xpdf series, we discuss and demonstrate the PDFdetach utility, which is able to list and, more importantly, extract attachments that are embedded in PDF files. It does this via a command line interface, making it suitable …

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now