Active directory Problem after seizing FSMO roles

After a 2003 dc server died and was unrecoverable in a 3dc server domain .
i used ntdsutil to seize the roles held by the now dead serverwhich all seams to work ok.
however i now have a problem logging on or joining the domain as it seams i have a ad/dns error

if i run netdom query fsmo it fails to find or connect to my domain
netdom pdc finds the server i siezed this role for
netdom dc again fails to find the domain

However bother server replicate to each other if i create a new AD user object and or DNS A record

in ad sites and services this server appear to hold all of the siezed roles

exchange currently fails to start as it cannot locate the DC for this domain #

any ideas would be welcome

Karl

kfreeth911Asked:
Who is Participating?
 
kfreeth911Author Commented:
ok last post on this

I tried to run dcpromo to remove the DC and the TS server form the domain , 1st time saying it was not the last server in the domain and second time it was
both failed with unable to contact domain conrtroller for this domain
so i had to run a dcpromo /forceremoval on both server , after doinga  manualy removal of exchange 20003 ( PST files exported), this worka dn now i have created a new .local domain and bother server are now DC in teh new domain and no DNS or AD problems

Again thanks fo hte help posted to this question


Karl
0
 
zelron22Commented:
Are the machines having problems (including your Exchange server) pointing to the dead server for DNS?  Have you cleaned up DNS to remove records for that server, and used NTDSUTIL to remove the metadata for the dead server?

http://support.microsoft.com/kb/216498
0
 
kfreeth911Author Commented:

yes tried this and below is what i get

select operation target: select domain
No current site
Domain - DC=dunwoodtravel,DC=co,DC=uk
No current server
No current Naming Context
select operation target:
select operation target:
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
kfreeth911Author Commented:
If i list servers in site
i get no active server in site

********************************************************************

server connections: connect to server dunwooddc1
Binding to dunwooddc1 ...
Connected to dunwooddc1 using credentials of locally
server connections: q
metadata cleanup: select operation target
select operation target: list domains
Found 1 domain(s)
0 - DC=dunwoodtravel,DC=co,DC=uk
select operation target: 0
Error 80070057 parsing input - illegal syntax?
select operation target: select operation target 0
Error 80070057 parsing input - illegal syntax?
select operation target: select operation target
Error 80070057 parsing input - illegal syntax?
select operation target: select operation target
Error 80070057 parsing input - illegal syntax?
select operation target: q
metadata cleanup: select operation target
select operation target: list domains
Found 1 domain(s)
0 - DC=dunwoodtravel,DC=co,DC=uk
select operation target: select domain number 0
Error 80070057 parsing input - illegal syntax?
select operation target: select domain number
Error 80070057 parsing input - illegal syntax?
select operation target: select domain 0
No current site
Domain - DC=dunwoodtravel,DC=co,DC=uk
No current server
No current Naming Context
select operation target:
select operation target: list servers in site
No active site list
********************************************************************************
0
 
anhnt184Commented:
Did you change DNS in Network Connections to New DNS server?
And when you type connect to server dunwooddc1, please include domain name.
0
 
zelron22Commented:
It looks like you didn't select a site.  Was there a problem selecting a site?
0
 
zelron22Commented:
After you start NTDSUTIL, go to metadata cleanup, connections, connect to server, etc.

You list domains
Select a domain number
List sites
select a site number
List servers in SIte
Select server number
then quit
then remove selected server
0
 
kfreeth911Author Commented:
ok there are only 2 server listed ( operations ones ) the dead server is no longer listed in the site

see below
but still i haev the error when trying to joing the domain
My DNS server are set to the ip of the active servers .....



select operation target: list servers in site
Found 2 server(s)
0 - CN=DUNWOODDC1,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuratio
n,DC=dunwoodtravel,DC=co,DC=uk
1 - CN=DUNWOODTERM,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configurati
on,DC=dunwoodtravel,DC=co,DC=uk
select operation target: select server  0
Site - CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=dunwoodtravel,DC=
co,DC=uk
Domain - DC=dunwoodtravel,DC=co,DC=uk
Server - CN=DUNWOODDC1,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configu
ration,DC=dunwoodtravel,DC=co,DC=uk
        DSA object - CN=NTDS Settings,CN=DUNWOODDC1,CN=Servers,CN=Default-First-
Site-Name,CN=Sites,CN=Configuration,DC=dunwoodtravel,DC=co,DC=uk
        DNS host name - dunwooddc1.dunwoodtravel.co.uk
        Computer object - CN=DUNWOODDC1,OU=Domain Controllers,DC=dunwoodtravel,D
C=co,DC=uk
Naming Context - CN=Configuration,DC=dunwoodtravel,DC=co,DC=uk
select operation target:?
0
 
zelron22Commented:
Any errors in the event logs on the DC's?
0
 
kfreeth911Author Commented:
event id 1126
Unable to est a connection with GC server
1355 the specif domain does  not exist or could not be contacted

also have a fre error that is DNS related unablet o reslove domain name

group policy prcessing aborted with unable to cind ot domain error
0
 
zelron22Commented:
Check in AD Sites and Services.  Expand the Default Site.  Expand one (or both) of your servers.  Get the NTDS properties and check the box to make your servers global catalog servers.
0
 
kfreeth911Author Commented:
Hi i have manually moved the operation master to the other server the usual way and it was successful
then i made the dunwood dc the GC server as it now no longer holds the fmso roles

Exchange system attendant has now started along with the information store
i am able to logon to the terminal server .....

tehn a reboot to bother server and i am back in teh same situation

i have a GC on teh server not holding teh master operation roles
0
 
zelron22Commented:
Make them both a GC.

When you say you reboot the other and are back in the same situation you mean to say that you can't promote the server to a domain controller?
0
 
zelron22Commented:
And give them some time to replicate the changes.  They need at least 5 minutes if they're within the same site and I believe 15 for changes to GC status.

0
 
kfreeth911Author Commented:
ok both Dcs

no i get errors when trying to run dsa.msc or site and services
naming information cannot be located
the domain does not exist or could not be contacted
0
 
kfreeth911Author Commented:
ok lets give thent eh 15 mins for replication adn i will feed back

thanks for you help on this.....
0
 
zelron22Commented:
No prob.  When you're runnindg dsa.msc are you running it on a workstation or one of the servers?

Do the servers point to themselves for DNS, and by IP not by loopback?
0
 
kfreeth911Author Commented:
yesdsa.msc  from the server itself
they point to the actual live ip address not the loopback address for DNS , 192.168.1.5 and 192.168.1.7
0
 
kfreeth911Author Commented:
Hi
ok i now have exchange running but still unablet o auth correctly tot eh ad and get error when trying to join the domain..
 DNS was successfully queried for the service location (SRV) resource record used to locate a domain controller for domain dunwoodtravel.co.uk:

The query was for the SRV record for _ldap._tcp.dc._msdcs.dunwoodtravel.co.uk

The following domain controllers were identified by the query:

dunwoodterm.dunwoodtravel.co.uk
dunwooddc1.dunwoodtravel.co.uk

Still unable to logon to the terminal server ......
?
0
 
zelron22Commented:
What errors do you get when you try to log onto the TS?  Are you logging in via RDP or to the console?  Can you review its event log, services, etc., remotely?

Is the TS 2003? Do you have a licensing server set up that's on a DC?  Perhaps it was on the now-dead DC?
0
 
kfreeth911Author Commented:
Hi
yes the TS is 2003 and the licensing server is on the active live dc
its strange as if you change the gc servers over you can logon tyo it for approx 15 mins then back to same error

it the error domain was unavailable ..
However you can logon on the console and run all teh ad services etc and dns replicated to it

i have made the decision to remove ad (30 users) and rebuild on to the same servers as i have managed to get the exchange mailboxes exported out to PST files and all the other data is in tact and operational

the ad has some strange errors and behavior i have never seen before and this method although time consuming will give me a clean and .local AD as i inherited .co.uk as the internal domain
Local client logs on using the locally cached user , can access the server resources although you are prompted for user and pwd, can even access email again usr and pwd required
this authenticates  to same server as its dns server and AD when logging to the domain

thanks for all the help posted here
0
 
zelron22Commented:
Good luck.  Sounds like a plan.  It sounds like you'll be better off for it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.