Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 547
  • Last Modified:

can't access Microsoft Network Load balanced IP from outside network?

hello I just setup load balancing on 2 of my terminal servers. everything is working on the local network. I can ping the two server's stand-alone IPs from any remote network but when I go to ping the NLB IP (192.168.1.2) it fails to respond.  Any ideas? is there somewhere I have to put in a default route for that NLB IP address on each server or something?
0
jbla9028
Asked:
jbla9028
  • 5
  • 3
  • 2
2 Solutions
 
giltjrCommented:
Do you have a NAT for the NLB IP address setup in the firewall?

Do you allow ICMP packets to/from that IP address?

A single server should only have one default route, as a default means when there are no other options use this and you can have
two defaults.
0
 
jbla9028Author Commented:
So I do not have a NAT setup in my firewall for the NLB IP. should I? the router should be wide open. it's a cisco 1720 leading into a private MPLS network. I allow all traffic to and from my remote LANs.
0
 
giltjrCommented:
Do you have a NAT for the non-NLB IP addresses on those Window's servers?  If yes, then yes you need a NAT.

If no, is the NLB IP address in the same subnet as the non-NLB IP addresses?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jbla9028Author Commented:
Yes the addresses are in the same range

Server 1 192.168.1.2


Server 2 192.168.1.8

Nlb address is 192.168.1.3

I have no problem pinging the server 1 and server 2 dedicated IPs. Why do I need a seperate nat?
0
 
oBdACommented:
You're probably running the NLB cluster in multicast mode; most routers don't publish multicast. You either need to add the arp entry to your router, or change the NLB mode to unicast (if you don't require inter-host communication).
Network Load Balancing Troubleshooting
http://technet.microsoft.com/en-us/library/cc781160.aspx#BKMK_2

Unicast NLB nodes cannot communicate over an NLB-enabled network adaptor in Windows Server 2003
http://support.microsoft.com/kb/898867

Network Load Balancing Frequently Asked Questions
http://www.microsoft.com/technet/prodtechnol/windowsserver2003/technologies/clustering/nlbfaq.mspx

Using Network Load Balancing
http://technet.microsoft.com/en-us/library/cc759562.aspx
0
 
giltjrCommented:
If you have a NAT for 192.168.1.2 and  192.168.1.8, you will  need a NAT for 192.168.1.3.

If you don't have a NAT for those, then refer to oBdA's post.
0
 
jbla9028Author Commented:
ok I think we're on the right track. It is setup in multicast.

the router is remotely managed by my ISP.
when I do an ARP -a on my workstation which is currently on the same LAN as the NLB cluster, I get a MAC address for the 192.168.1.2 ip address. is this MAC address the one that I need the ISP to statically assign in my router or do I need to assign one of the dedicated IP's mac addresses (192.168.1.3. 192.168.1.8?)
0
 
oBdACommented:
It should be the MAC address from the cluster IP address (ping it first).
If you don't require the two terminal servers talking directly to each other, it's probably easier to switch to Unicast (or if you have two NICs in each server, you can use unicast NLB on one NIC in each machine, and use the other NIC for inter-host communication).
0
 
jbla9028Author Commented:
the ISP doesn't seem like they know the command that they would need to put into their router for a static ARP entry. on a cisco router what would the command be to enter the MAC address statically in the Router's ARP tables?

0
 
jbla9028Author Commented:
Thanks. We got it. It was in multicast and the router needed a static arp entry to work.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now