Installing Flash Player 10 plugin for Firefox Linux

Posted on 2009-04-16
1 Endorsement
Last Modified: 2013-12-15
I have purchased a Alix.3C3 LX800 board.,_LX800_/_USB_/_VGA_/_audio_/_Award_BIOS

It is running iMedia Alix Linux 6.0.4 which I am lead to believe is a cut down version of Fedora.
Is this correct? I'm fairly new to Linux and don't quite grasp all the distros yet.

I am attempting to upgrade Shockwave Flash from 9 9.0 r124 to 10.0 r22 in Firefox 3.0 using this guide:

I completed these steps:
- Closed Firefox 3.0.
- Downloaded the '' file from Adobe's site.
- Created a new directory called 'plugins' in '~/.mozilla' (Directory was not there originally. I  created the directory using Thunar 0.9.0 Filemanager and chmod'd it to 777 using aterm)
-Copied the to ~/.mozilla.
- Opened Firefox > Addons > Plugins
- Disabled Shockwave Flash 9.0 r124
- Ensured Shockwave Flash  10.0 r22 was enabled
- Restarted Firefox
- Browsed to Youtube, no video display (like Flash not installed)
- Restarted OS, tried again, same result.
- Enabled Flash 9.0, disabled 10.0, tested, Works !!! (Though very jumpy and not watchable)
- Searched far and wide, got frustrated, angry, ready to give up !!!!
- Came to Expert Exchange

Can anyone shed some light as to why Firefox won't use the Flash 10 plugin?
The reason I am upgrading is because of video performance issues with Flash 9.

I have also tried using ./ script from aterm but get the error:
Error: Your glibc library is older than 2.3. Please update your library.

I am certain I am running version 2.6.X or higher as I remember seeing a folder relating to glibc called 2.6.0. I can't check as 'rpm -man' returns "command not found'. Is there another way to check as I don't think RPM is supported (RedHat only???) I am lost here....
Question by:thenos
    LVL 35

    Expert Comment

    Fedora is a derivative of Redhat, and Rpm is the packagemanager for both.
    "rpm -man" is indeed no valid command (what did you want to do, read the manual for rpm? that would be "man rpm"), try:
    rpm -qi glibc

    I have never heard of this iMedia Alix Linux before, and it certainly isn't a celebrity in the Linux world. So I'm not able to confirm that it even is Fedora based.

    I have no ready-made solution for this problem, but I can point you to a couple of inconsistencies in your report above. In several items it does not agree with the HowTo you claim to have followed.

    1."Downloaded the '' file from Adobe's site."
    I cannot find such a file for download on that website, only:
    Flash Player 10 for Linux (YUM)
    Flash Player 10 for Linux (.tar.gz)
    Flash Player 10 for Linux (.rpm)
    Flash Player 10 for Linux (.deb)

    2. The .rpm (and possibly the YUM file) should work for you if the distro really is RH/Fedora based. But if you used the .rpm file, you would know the .rpm is supported on that system.

    3. You say there was no /plugin folder. This is really strange, because there already was a plugin.

    4. "Copied the to ~/.mozilla"
    This is not the correct folder. The file needs to go to ~/.mozilla/plugins.

    5. You do not say that you CHOWN'ed the to your normal user. Did you do so?

    Maybe these inconsistencies are only inaccuracies. If not, they might help solve the issue.
    I'm afraid I shall be away for the rest of the day and not capable of answering any ensuing questions, but I'm sure other experts will step in.

    Author Comment

    Thanks for your quick reply torimar.

    Fairly new to Linux and get Windows/Linux commands all mixed up. I will attempt on Monday.

    1. I left a few steps out here which I can see might have been confusing. I downloaded Flash Player 10 for Linux (.tar.gz) unzipped and it had two files: and

    2. I will attempt this on Monday

    3. Definately wasn't there. I searched far and wide for folders with existing plugins to no avail. Once I created the plugins folder and copied into there. Firefox could see it in the addons manager. How do i upgrade the slocate database so I can use this to search?

    4. Sorry typo I copied it into the ~/.mozilla/plugins folder.

    5. I tried chowning but don't think I did it right. Is this correct? Username is literally 'x'

    (pwd = home/x)
    chown x.x .mozilla/plugins

    Author Comment

    'man rpm' gives error 'command not found'. I am not certain it is a Fedora based distro.
    Is there a way of telling what distro it is based on?

    I chown'd the file by changing the pwd of aterm to ~/.mozilla/plugins and issuing the command 'chown x' and chmod'd using 'chmod 777'. I confirmed these permissions had been applied by using the command 'ls -l'. Output = 'rwxrwxrwx 1 x root .......'
    I confirmed that user 'x' was a member of the group 'root' by issuing the command 'groups x'.

    Could anyone suggest an alternative OS that is more common and is closer to a mainstream distribution.
    It needs to be able to support the AMD Geode ALXD800 CPU and run from a 2GB CF card.

    The main reason for me wanting to upgrade to Flashplayer 10 is that 9 is very laggy and jumpy. It's unwatchable.

    Author Comment

    Found this on the iMedia Linux site:

    "iMedia Embedded Linux is library compatible with most used big linux distributions like Fedore Core, Gentoo, Suse or Mandriva making easy for the users to extend and customise their install."

    Any idea what package manager would work?
    LVL 35

    Expert Comment

    I looked through their file list ( and there is none of the known package managers available, let alone an advanced one that resolves dependencies.
    This takes no wonder if it is true what they claim to have done: reduce the size of the OS to a bare 8 (!) Mb (

    Their documentation is remarkably scarce, given the fact that it requires a lot of expertise to run such a barebone Linux. I did find the following statement:

    "Distribution package system
    To minimise space requirement but still be able to give users the possibility of easy install of packages we choose to build our own packaging system (partialy based on loki installer). Packages are self decompressing and installing each package has the possibility to have his own install script. Also each kernel module or driver have been put in a package so user can select only what he needs and keep space requirement down. If later he installs another device he can install the coresponding package. packages Most of the packages on iMedia are rebuilded from the sources to ensure minimul space requirements and reability. ..." (

    But there is no mentioning of how to use this "packaging system". Further inquiries point to a "Sysadmin" utility through which installation scripts may be used that reside on the iMedia FTP server. But that is a very restricted repository and not a package manager in the ordinary meaning of the word.
    And then I found this final verdict coming from their senior developer:

    So there will be no PM until release of the next version. And judging by the maintenance state of their forums I guess this could take a while.

    There are quite a few good Linux distros specialised in low resource systems (like Xubuntu Lite, Moblin, Vector etc), but I'd advise against trying to install them. Your hardware is so special that you would risk failing (and then having no working system at all) or at least losing all video.

    Talking about hardware: if I got this correctly, your processor is 500 Mhz? That may very well be the case of the laggy and choppy video performance (after all that's the speed computers were running at 11-12 years ago). Have you tried to play a downloaded video to see whether that will jump and lag as well? And what about non-Flash streaming video, does this play better?
    If you always get choppy video, the cause will be that either the processor or the integrated graphics adapter are too slow.

    Author Comment

    I had read that same documentation. I thought exactly the same. I thought I just didn't understand the package management bit. Thanks for your detailed insight.

    Other video I play directly from the CF card plays perfectly though not at higher resolutions i.e DIVX/AVI.

    The company that sells the board also has some other distros that have been cut down and customised for this hardware.

    I am going to attempt to install OpenBSD44 as it seems there is much more documentation and support.
    Will update post once successfully completed.

    Author Comment

    I have downloaded the version of Open BSD4.4 from
    I unzipped this file and used Physdiskwrite and PhysGUI which seemed to successfully write the image file to the CF card (I tried using both with and without the 2GB limit option).
    When I boot from the 2GB San Disk CF card I receive the following message on the screen connected via VGA:

    Using drive 0, partion 3.
    probing: pc0 com0 com1 apm pc1 mem[630K 246M a20=on]
    disk: hd0+
    > OpenBSD/I386 BOOT 3.02
    Switching console to com0

    It pauses here with the keyboard being unresponsive yet the CAPS LOCK light does turn on and off when the key is pressed.
    Any ideas on how to boot/install a GUI or what could be going wrong?
    LVL 35

    Accepted Solution

    Just assumptions, really.

    - OpenBSD:
    that sounds like a hardware compatibility issue. I've had it a lot with BSD that it simply would not boot on hardware it was actually supposed to support
    (example: FreeBSD and PC-BSD will only boot on my present desktop system when I disconnect my USB hub and unplug my USB mouse).

    - GUI 1:
    Even if there is no GUI you should definitely get a prompt.

    - GUI 2:
    Not likely that any of those OS images will include a GUI - especially not OpenBSD, since from the description the image seems to be tailored towards building a firewall or VPN appliance.
    I tested Voyage Linux (not the Yawarra image, but a Live iso from the Voyage homepage), and it boots to a prompt.

    - Image sizes:
    "A note on image sizes
    The OpenBSD and Voyage Linux images have been built on particular size Compact Flash cards. As such, if you wish to reproduce the image accurately, you should use a CF card of the same size as the image. Not doing so will leave you with inaccessible space on your CF card, or worse still, an image that doesn't boot.
    The image size and the space taken on the CF card are not the same thing. In the case of OpenBSD, the space taken when installed is around 35MB, leaving you some spare space for other files. For Voyage, the installation is a little under 64MB, leaving lots of room for additional files."

    This may acount for:
    --- possible boot failures
    --- a huge loss of space (~ 1.7 GB on a 2 GB CFC)
    --- a lot of problems when trying to install a GUI manually. I never counted the space required for installing a GUI (= X-server + window manager + dependencies), but it seems to me that this would eat up all the space left, especially when using the normal OS repositories. This holds true for OpenBSD as well as Voyage, while Voyage will certainly be easier to deal with.


    Author Comment

    I have been in contact with the manufacturer and found what was causing the OpenBSD boot problem.
    It was due to the OS being configured to switch to the console on Com0 automatically upon booting. This is due to the fact that alot of the devices they sell don't have VGA.

    This install doesn't come with the 'X' GUI. So I think I will scrap that idea.

    There are some XP drivers at,_LX800_/_USB_/_VGA_/_audio_/_Award_BIOS

    so I think I might try a cut down version of XP (TinyXP) to test with.

    I'm kinda dissapointed that I could get Linux up and running as I think the whole concept is billiant and am looking to use it more and more. I know it is due to my lack of experience and knowledge of the platform.

    I will report back if i can get XP installed
    LVL 35

    Expert Comment

    If by "platform" you mean the Alix/Geode hardware, then I agree.

    If by "platform" you mean Linux, then I disagree energically. What you have experienced wasn't 'Linux', but a non-mainstream, hardly documented, embedded OS reduced to 8 - 60 Mb of size and stripped off vital functions.

    If you wish to gain more Linux experience and knowledge without having to change anything about your partition scheme and harddrive, check out the following projects which will let you run Linux from your Windows drive and partly even like an application inside your Windows desktop:

    - Portable Ubuntu:
    - Linux4Windows:
    - Wubi:
    - coLinux:

    Those, and of course VirtualBox (, will certainly help you in expanding and deepening your knowledge.

    Author Closing Comment

    I ended up installing XP which seems to run alright.
    When I run a flash file through a browser with the flash plugin it is still very jumpy. So I really got nowhere. CPU usage hits 100% and stays there even once file is fully downloaded.
    I tried a standalone flv file player which worked much better but still yet to test it with a HD file.
    I have decided to accept this post as the answer as you were helpful, clear and friendly and it gives the most information on what I was attemting to do.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Join & Write a Comment

    I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension ( This reminded me of questions tha…
    Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now