Exchange 2007 Activesync not working (runs on on Server 2008)

An HTTP 500 response was returned from IIS7 is the error i get when testing the connectivity.

 Attempting to Resolve the host name webmail.kmiplus.org in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: 195.188.240.174

Testing TCP Port 443 on host webmail.kmiplus.org to ensure it is listening/open.
 The port was opened successfully.

Testing SSLCertificate for validity.
 The certificate passed all validation requirements.
Additional Details
 Subject: CN=webmail.kmiplus.org, OU=Domain Control Validated - RapidSSL(R), OU=See www.rapidssl.com/resources/cps (c)09, OU=GT77988718, O=webmail.kmiplus.org, C=GB, Issuer CN=Equifax Secure Global eBusiness CA-1, O=Equifax Secure Inc., C=US

Testing Http Authentication Methods for URL https://webmail.kmiplus.org/Microsoft-Server-Activesync/
 Http Authentication Methods are correct
Additional Details
 Found all expected authentication methods and no disallowed methods Methods Found: Basic realm="webmail.kmiplus.org"

Attempting an Activesync session with server
 Errors were encountered while testing the ActiveSync session
Test Steps
 Attempting to send OPTIONS command to server
 Testing the OPTIONS command failed. See Additional Details for more info
Additional Details
 An HTTP 500 response was returned from IIS7
johnsoiAsked:
Who is Participating?
 
RaghuvCommented:
Try recreating the Microsoft-Server-ActiveSync virtual directory using the Exchange Management Shell by running the below two commands,

# Remove-ActiveSyncVirtualDirectory -Identity ****** (To get the Identity, run Get-ActiveSyncVirtualDirectory & look for the parameter Identity)

# New-ActiveSyncVirtualDirectory

Now run the test again and let us know if you are still having issues.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.