• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 901
  • Last Modified:

SQL server collation mismatch

I restore a sql database and got this error
the master database has a collation of Latin1_General_CI_AS

It needs to be
Latin1_General_CPI_CI_AS

I am reinstalled the instance and have selected Latin1_General but what else do I have to do to get the CPI
0
jimcrint
Asked:
jimcrint
  • 2
  • 2
1 Solution
 
RiteshShahCommented:
collation conflict is with Master database only or will all tables under master database also?
0
 
jimcrintAuthor Commented:
i dont know enough  It says the master database.  Says that I have to reinstall the sql server with the same instance with the collation including the CP1  then restore it again

I am in the prcess of reinstalling and dont know what I have to tick to get the CP1 whatever it is
sql.jpg
0
 
RiteshShahCommented:
have a look at following steps and perform the steps rather than reinstallation.

http://geekswithblogs.net/mskoolaid/archive/2005/12/17/63413.aspx
0
 
reb73Commented:
The CP1 stands for CodePage1252 which is the default  character set and is not relevant for Windows Collations.

To set the collation to SQL_Latin1_General_CP1_CI_AS, choose SQL Collations (second option buttion) and select -
"Dictionary order, case insensitive for use with code page 1252"

0
 
jimcrintAuthor Commented:
i tried Ritesh link but  I was not able to complete the steps so I went back to another insatll and used reb27 commenst.  I have now restored the database and am back on track

Thanks for being available, I dont know what I would do without all this great support
0

Featured Post

Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now