?
Solved

ppoatm not working, urgent help required

Posted on 2009-04-17
14
Medium Priority
?
421 Views
Last Modified: 2012-06-21
given below is the config, please suggest whats wrong ... atm interface is down/down ..

Current configuration : 159 bytes
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/100
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
end

interface Dialer1
 bandwidth 1000
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password 0 xxx
 ppp multilink
end
0
Comment
Question by:nabeel92
  • 9
  • 5
14 Comments
 

Author Comment

by:nabeel92
ID: 24166732
Given below is complete router config

Router#sh running-config
Building configuration...

Current configuration : 1422 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable password xxxx
!
no aaa new-model
memory-size iomem 15
!
!
!
!
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/100
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 10.183.0.122 255.255.255.128
 ip nat inside
 ip virtual-reassembly
!
interface Dialer1
 bandwidth 1000
 ip address negotiated
 ip mtu 1440
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password 0 xxxx
 ppp multilink
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer1 overload
!
access-list 101 permit ip any any
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password xxxx
 login
!
scheduler max-task-time 5000

!
webvpn cef
end

Given below is the message i get when i run debug atm events

transmit_pak_wrapper : encap = Data
*Mar  5 04:33:20.495: atmsar_vc_tx_start(833BBFF0).
*Mar  5 04:33:20.495: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x84A41E58
*Mar  5 04:33:20.495: atmsar_transmit_pak_wrapper: deq(84A41E58). vcd: 2.atmsar_
transmit_pak_wrapper : encap = Data
Router#u all
*Mar  5 04:33:22.511: atmsar_vc_tx_start(833BBFF0).
*Mar  5 04:33:22.511: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x84A43930
*Mar  5 04:33:22.511: atmsar_transmit_pak_wrapper: deq(84A43930). vcd: 2.atmsar_
transmit_pak_wrapper : encap = Data
0
 

Author Comment

by:nabeel92
ID: 24167469
Ok, I fixed the issue ... I found out that the ISP uses the insecure PAP mechanism and not CHAP...after changing the details under dialer interface for PAP, i was able to get an I.P address and ping ... One strange and silly thing happening now is i cant telnet to the public I.P i get ? why is that ? I can ping it but cant telnet it ... i tried configuring ssh but still no response...this is how i had it set up..
username xxx privilege 15 password xxx
line vty 0 4
 login local
 transport input all

and basically thats it...i didnt thought i'd be asking such a basic question here but its just one of those days where a single thing would even take hours ....

any help would be appreciated
0
 
LVL 8

Expert Comment

by:API_NOC
ID: 24167576
Can you telnet to the private IP on the LAN? Are you trying to telnet to the Public IP from the LAN?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:nabeel92
ID: 24167730
i can telnet into the private I.P from the LAN ...
but i cant telnet to the public I.P out from the internet ....
0
 
LVL 8

Expert Comment

by:API_NOC
ID: 24167886
Your ISP maybe blocking telnet to your IP Address. Try changing your telnet port and see if that works.
http://www.cisco.com/en/US/docs/ios/12_3t/secur/command/reference/sec_i2gt.html#wp1141824
0
 

Author Comment

by:nabeel92
ID: 24168076
link u sent has too many config ...
can u tell me the command to configure telnet on another port say, 2323 instead of 23 ?

But it's strange that ISP may block that coz there are 2 routers on that site thru teh same ISP .. I can telnet into one (SHDSL) but cant telnet into the other one (which is ADSL) .. given below is exact config in case if there is anything i might be missing ..

Building configuration...

Current configuration : 5617 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxx
!
boot-start-marker
boot-end-marker
!
enable password xxx
!
no aaa new-model
memory-size iomem 15
!
!
!
!
ip cef
!
!
!
!
ip domain name xxx
!
multilink bundle-name authenticated
!
!
username admin privilege 15 password 0 xxx
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 no snmp trap link-status
 pvc 0/100
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address x.x.x.x
 ip nat inside
 ip virtual-reassembly
!
interface Dialer1
 ip address negotiated
 no ip redirects
 ip mtu 1440
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 load-interval 30
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp pap sent-username xxx password 0 xxx
 ppp ipcp dns request
 ppp ipcp route default
!
ip route x.x.x.x
!
!
access-list 101 permit ip any any
!
!
!
!
control-plane
!
banner login ^CC
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege le
vel of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password cisco
 login local
 transport input all
!
scheduler max-task-time 5000

!
webvpn cef
end
0
 
LVL 8

Expert Comment

by:API_NOC
ID: 24170149
ADSL is a different service and maybe going thru a different DSLAM try the following commands

config t
line vty 3 4
rotary 23


this will allow you to telnet in on port 3023
0
 

Author Comment

by:nabeel92
ID: 24179120
that didnt help ... It is so weird .. Ive even restarted this router ... I can telnet to the inside interface but not the dialer .. .there is no ACL on the dialer ... ISP's would usually block the ping requests which makes sense but not telnet or ssh ? i know it must be smthg abt the dialer interface for this one ?

interface Dialer1
 bandwidth 1000
 ip address negotiated
 no ip redirects
 ip mtu 1440
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 load-interval 30
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp pap sent-username username@internetprovider.dom password 0 mypassword
 ppp ipcp dns request
 ppp ipcp route default
end
0
 

Author Comment

by:nabeel92
ID: 24190430
any idea guys ? Ive contacted the ISP and they say they dont block anything from their end ...
0
 

Author Comment

by:nabeel92
ID: 24193434
Ok, i guess this maybe relevant to what am trying to do ... as u can see the dialer interface has the config "ppp ipcp route default" and it shows a default route of 60.234.8.18 whereas my I.P is 60.234.161.90 ... Now, shouldn't the default route belong to the same subnet ? and maybe thats why it doesnt recognize telnet or any other tcp connection ... I give command "ip http serve" on router and if i try to open a connection on port 80, it doesnt open that ... so basically, other than ping its not allowing anything from outside to its public I.P
0
 
LVL 8

Expert Comment

by:API_NOC
ID: 24193650
Try changing this:

interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/100
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 
To this:

interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/100
  encapsulation aal5mux ppp Dialer1
  dialer pool-member 1
 
The difference is you are currently pointing the encapsulation to a dialer that does not exist.
0
 

Accepted Solution

by:
nabeel92 earned 0 total points
ID: 24193704
Ok, issue sorted...
Basically ISP blocked well known ports 0-1024 .. so i had to define a port forwarding rule on the router and use that random port to telnet ...
0
 

Author Comment

by:nabeel92
ID: 24193922
doesnt give u an option of 1 after u type in dialer ... only takes encapsulation aal5mux ppp Dialer and not encapsulation aal5mux ppp Dialer1

router2.ggqueenstown(config-if-atm-vc)#encapsulation aal5mux ppp dialer 1
                                                                        ^
% Invalid input detected at '^' marker.

router2.ggqueenstown(config-if-atm-vc)#encapsulation aal5mux ppp dialer?
dialer

router2.ggqueenstown(config-if-atm-vc)#encapsulation aal5mux ppp dialer ?
  <cr>
0
 
LVL 8

Expert Comment

by:API_NOC
ID: 24193949
I thought you mentioned that the issue was resolved?  But wasn't  your atm interface down/down?  So I do not see how it is working.  Anyway, there is no space after the dialer - try Dialer1 (no space)
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question