Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 508
  • Last Modified:

Cisco 3750 ip address-helper with IP phones

Hi, we currently have a network running two windows DHCP server (80/20).
We have two switch stacks in two physical parts of the building.  Is there a way to get the one half of the building to only get DHCP addresses from a specific server.  I need to get the phones on one side of the building to jump onto vlan 123 and the ones on the otherside to jump to vlan 100.  I configured the option 147 to tell the phones what to do but they all go straight to DHCP server 1 and jump to vlan 100.  I need some phones to get a DHCP address from server two so they will jump to vlan 123.  I have tried using the ip address-helper and pointing to server two but it seems to get ignored.  Any ideas
0
scobner
Asked:
scobner
  • 2
1 Solution
 
API_NOCCommented:
What type of phones are you using?
0
 
scobnerAuthor Commented:
Avaya IP phones
0
 
buckethead34Commented:
You need to set the vlan on the switch port. Then put a helper address on the interface vlan. What kind of switch do you have?
0
 
buckethead34Commented:
I saw that it is a 3750. Here are the commands that you need to put in.
config t
vlan 100
name voice1
exit
vlan 123
name voice2
exit
interface vlan 100
ip address x.x.x.x y.y.y.y
no shutdown
ip helper-address dhcp1_ip_address
interface vlan 123
ip address x.x.x.x y.y.y.y
no shutdown
ip helper-address dhcp2_ip_address

int gig 1/0/1
switchport voice vlan 123

int gig 1/0/2
switchport voice vlan 100

Just put which ever ports in the different vlans. With this config all phones in vlan 100 will go to DHCP server 1 and in vlan 123 will go to DHCP2.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now