[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1411
  • Last Modified:

Exchange Email problem - Message awaiting directory lookup queue

Hi

We have 3 exchange servers. Two of them are on exchange 2000 and one of them is exchagne 2003 which i recently built and migrated few users on that new exchange servers (not all users yet). All was running fine since last night when i replicated public folders using PFDAVadmin to the new exchange and we are now getting following problem:

we have long delay sending emails internally to each other. We noticed that we have more than 1000 messages sitting in the "message awaiting directory lookup" queue. By forcing the queue it goes down but then again start building.

By looking these messages from the queue found that lots of messages are same sender information and refering from sender CN=MICROSOFT PUBLIC MDB are sitting and going in/out from the awaiting directory queue. This seems all related to public folder wrong routing/replication issue.

Also noticed that public folder database (pub1.mdb) size is increasing in every second on the new exchange 2003 server.

How can i stop this replication or etc..

Can you please help, its urgent.

Thanks
0
tech2010
Asked:
tech2010
  • 6
  • 4
1 Solution
 
tech2010Author Commented:
Furthermore, the subject of these messaeges are "backfill request"
0
 
zelron22Commented:
0
 
tech2010Author Commented:
thats fine what you just sent, but i want my problem to get it fixed asap. how can i stop this replcatin process. I just dismouted my public folder store on new exchange 2003 box. we don't activily use public folder. so please tell me shoud i also dismoust public folder store on other servers as well or is there is option or service where i can stop this whole thing? URGENT
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
FearNoMoreCommented:
There is an option in Exchange Syustem Manager on the ORG level to Stop Public Folder Content Replication
http://msexchangeteam.com/archive/2006/06/05/427875.aspx
 
0
 
tech2010Author Commented:
thanks for this option. Actually i had mismout my public folder store on the exchange 2003 which then resolved the problem. But i will also stop public folder replication as well as you suggested.

But now i have noticed that status of my local dilivery queue is retry and there are still lots of message sitting in there. Senders of those message is from:
 "/O=mydomain.com/OU=London/cn=Configuration/cn=Servers/cn=MAIL3/cn=Microsoft Public MDB" <MAIL3-IS@mydomain.com>

Subject is hidden and status is retry. What should i do now. why still messages are in queue. Should i try that option for stoping public folder content replciatino on the organisation level?
0
 
FearNoMoreCommented:
Those messages are in the queue becasue you have dismounted the pf store,
Mount the pf store back up then stop public folder content replication and the check what happens....
Else could could manually delete the mails in the local delivery queue
0
 
tech2010Author Commented:
i will mount the public folder store out of hours and will let you know. However can you please tell me what is the correct way to make public folders available on the new server which i had installed. Basically when i installed new exchange 2003 in my existing two exchang server 2000 envoinrment. The users which are on new exchange could not open public folder in their outlook So thats why last night i used PFDAVadmin tool to replication each folder at the parent level to the new server. And then i end up this email problem which i had orginally describe in this case. So can you please tell me what i did was correct or if not what the proper way to achive this? Thanks
0
 
tech2010Author Commented:
Hi FearNoMore

I mounted pf store and noticed it again started doing the same thing, it again start building the queue and the message in the queue was from microsoft public folder and the subject of those message was hidden, some of them was 'backfill request". Also i noticed that while it is building queue, my pub1.mdb database size is keep increasing after every second. So i have again then dismounted the store. Let me also tell you that when i kept public folder replicatino disabled in this whole process while i was mounting the store. So i don't know what to do now. please advise? thanks
0
 
FearNoMoreCommented:
Make sure that under the properties of the pf store....Replcaiton tab for both the public folder stores on either server.....only a SELF replica of the server should be present and no replica of the other server
Remove all the other replicas and keep only self replicas and you should be fine
0
 
tech2010Author Commented:
What do you mean exactly, i can't see any option where it shows replica listed in the replicaton tab on public folder store. I can see the list of servers under replication tab on each public folder not on public store. please clearify.
0
 
FearNoMoreCommented:
Yes the list of servers that you see for each public folder.....
It should have only ONE server and not BOTH the servers listed.
So if A is the Source server and B is the Target server...for each public folder you see both A and B servers listed correct?
Keep only A and remove B
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now