Null Session Shares not working in Windows Server 2008

I'm using null session shares to write data back from an application launched onto an end user cpu with WMI

On windows 2003 and XP etc it works fine, but on Windows 2008 we get "Access Denied" even though "everyone" and "anonymous logon" have full control over the null session share and its folders.

Is there something special I need to do to allow null session shares to work on Windows 2008 ?

thanks
LVL 8
plqAsked:
Who is Participating?
 
Paolo SantiangeliConnect With a Mentor Consulente InformaticoCommented:
This is security info on windows 2008 server in which you can find some security policy concerning null session shares and anonymous users:

es: Network access: Restrict anonymous access to Named Pipes and Shares

http://technet.microsoft.com/en-us/library/cc264462.aspx?SA_CE=VIR-MAP-WEBS-TNETWEBST-2008-02-08
0
 
Paolo SantiangeliConsulente InformaticoCommented:
0
 
plqAuthor Commented:
OK thanks for the suggestion, but none of the ideas on there worked.

We've always been able to get to c$, just not a null session share running from a process under SYSTEM.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
Paolo SantiangeliConsulente InformaticoCommented:
i have found this:
http://technet.microsoft.com/en-us/library/cc753731.aspx

in which:

You cannot modify the access permissions of folders or volumes that are shared for administrative purposes, such as C$ and ADMIN$.
0
 
plqAuthor Commented:
This is a null session share of a share we created, not an administrative ($) share.

Anyone ??
0
 
plqAuthor Commented:
thanks we're looking into this today and tomorrow..
0
 
reskinCommented:
We have tried all of the above suggestions.  We are using a domain controller and are affecting these changes in the GPO for the default controller.  A networked media streamer is trying to access files but can not enumerate the shares that have been opened to anonymous (null) sessions - it worked fine under Windows Server 2003 R2 so there is something that Microsoft definitely changed here.  I attached the export list from the security options and user rights below.  My understanding is that these override whatever is set as a "local computer" setting.
user-rights.txt
security-options.txt
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.