[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 747
  • Last Modified:

ASA Site To Site VPN Issue

Hello All,

So I have a site to site vpn going between an ASA and an 800 series router. After the a connection is made and I try to ping/browse something from a workstation behind the 800 to a server behind the ASA and I get the following on the ASA logs&

Deny inbound icmp src inside:10.10.20.20 dst inside:10.10.220.42 (type 0, code 0)

I get this for just not icmp&.so in looking at the config I am not sure what I have overlooked.

Traffic from the 800 is 10.10.220.40/255.255.255.248

Thanks All!
: Saved
:
ASA Version 8.0(4) 
!
hostname <blah>
domain-name <blah>
enable password <blah>
passwd <blah> encrypted
names
dns-guard
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.20.247 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.64 255.255.255.128 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 10.10.20.20
 domain-name <blah>
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object icmp
 protocol-object udp
 protocol-object tcp
object-group network Inside_Networks
 network-object 10.10.0.0 255.255.0.0
access-list outside_cryptomap extended permit object-group DM_INLINE_PROTOCOL_1 object-group Inside_Networks 10.10.220.40 255.255.255.248 
access-list inside_nat0_outbound extended permit ip 10.10.0.0 255.255.0.0 10.10.220.40 255.255.255.248 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
asdm image disk0:/asdm-61551.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 101 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.1 1
route inside 10.10.0.0 255.255.0.0 x.x.x.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL 
aaa authentication http console LOCAL 
aaa authentication serial console LOCAL 
aaa authentication ssh console LOCAL 
aaa authentication telnet console LOCAL 
http server enable
http 10.10.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map soho1 1 match address outside_cryptomap
crypto dynamic-map soho1 1 set transform-set ESP-3DES-SHA
crypto dynamic-map soho1 1 set security-association lifetime seconds 28800
crypto dynamic-map soho1 1 set security-association lifetime kilobytes 4608000
crypto map outside_map0 1 ipsec-isakmp dynamic soho1
crypto map outside_map0 interface outside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 10.10.0.0 255.255.0.0 inside
ssh timeout 5
console timeout 0
 
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username <blah> password <blah> encrypted privilege 15
tunnel-group DefaultL2LGroup ipsec-attributes
 pre-shared-key *
tunnel-group soho1 type ipsec-l2l
tunnel-group soho1 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:32b14ee9226393dc762d1f8bf1467bb7
: end
asdm image disk0:/asdm-61551.bin
no asdm history enable

Open in new window

0
dehmerl
Asked:
dehmerl
  • 2
1 Solution
 
bkepfordCommented:
I think you may have a problem with the below although logically it still works and in the NAT exempt statement I have seen it work just fine but not sure if that translates to it working in the crypto map

object-group network Inside_Networks
 network-object 10.10.0.0 255.255.0.0

access-list outside_cryptomap extended permit object-group DM_INLINE_PROTOCOL_1 object-group Inside_Networks 10.10.220.40 255.255.255.248

As the Inside_Networks address actually overlaps the destination address of 10.10.220.40/29

Also this route actually changes the direction of all internal network traffic including what may need to go over the VPN? Is this intended?

route inside 10.10.0.0 255.255.0.0 x.x.x.254 1





0
 
dehmerlAuthor Commented:
we have taken the and sliced the 10.10.220.x/255.255.255.248 so we can setup several of these routers at homes, etc...

so we have several internal nets that follow the pattern of 10.10.x.0/255.255.255.0 this is why i have the route inside 10.10.0.0 255.255.0.0 x.x.x.254 1 - i could break this down to the diffrent networks...

I will give this a quick change and see...
0
 
dehmerlAuthor Commented:
I think route inside 10.10.0.0 255.255.0.0 x.x.x.254 1 was the issue -- I just changed the route on the ASA side to a single /24 network to do a test and bam it worked!

Thanks!
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now