Windows fails to start after installation via WDS

Posted on 2009-04-17
Last Modified: 2012-05-06
Hi all,
 My RIS server recently started having problems so I'm trying to move away from RIS towards WDS (I'm a procrastinator).  I setup WDS in mixed mode on a Win2k SP2 server and moved my riprep images over to it.  The old images work fine from RIS on the new server but I want to get away from the old format and over to .wim files.
So far so good.
  Next I started fiddling with  WDS.  I setup a capture image, syspreped a base windows XP installation,  pxe booted to the capture image and went through the capture process. Uploaded the image to a new image group.  Next I setup a deployment image, PXE booted another PC (identical hardware as the reference PC) into the deployment image, chose my install image from the list and it goes through the process of installing windows.
  My problem is after the reboot. Minisetup never starts. I've gone through the entire process several times now and I either get 1 of two error messages at bootup. At first I was getting

Windows Failed to Start
status: 0xc000000f
selected entry could not be loaded because the application is missing or corrupt

I tried formatting the disk by choosing  and now I'm getting this gem

Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware.

My images are XP but the boot.wim I used to create the boot images (capture and deploy) came from a Vista dvd. I also tried using boot.wim from the waik.  

Anyone have any ideas what I'm missing here?
Question by:mackmann
    LVL 4

    Expert Comment


    I'm having the same problem at the moment. I created a master image and then copied up to up RIS/WDS server. We are still running Mixed mode currently.

    When I pull the image back down off the server some PC's (not all) fail to reach the minisetup and exhibit the same error you have (Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware).

    What I did manage to find was a temp workaround. Once the image has been downloaded and the PC shows the above error restart the PC again, boot off an XP install CD and enter the recovery Console. You will have to enter the Local Administrators password to access the install.

    Select your Windows install and type bootcfg /rebuild. This will rebuild the boot.ini file which is corrupt. When prompted enter a Load Identifier and Operating System Load Options if you like, it's up to you. I'd recommend making the Load Identifier as test. After these steps are all done, restart the PC and the Minisetup will complete and the image will finish deploying.
    See for more info on boot.ini

    The downsides of making the changes above is the boot.ini file now has two entries in it so it needs cleaning up. One will be from the WDS image and one you entered. The entry that you named (Test) is the correct entry and needs to be kept. The other entry can be deleted. The default entry can also be changed. If you prefer you can rename the Load Identifier of the 'Test' entry to something more meaningful Windows XP Professional for example.

    I've not found a full solution yet but I'm working on it today so will report back.

    LVL 4

    Expert Comment

    I forgot to ask, what hardware are you using?

    We are having problems with Dell Optiplex units.
    LVL 4

    Expert Comment

    I found out why some of our PC's are displaying the error above.

    Dell add a tiny hidden diagnostic FAT partition (about 70MB) onto the harddisk when it leaves the factory. 95% of our PC's still have this in place, this is why the deployment on those still works. The odd PC here and there has either had this partition removed or the harddisk replaced. When Dell send out a replacement harddisk it does not come with this hidden diagnostic partition.

    What I suggest to confirm this is the case:
    Boot from an XP CD and go into the Recovery Console, run 'diskpart' from one of the PC's that fails? Is there a hidden partition? Then run 'diskpart' on the PC that created the image and see if there are any hidden partitions.

    I'm just trying to find a permanent solution as the one above is a bit of a hack to perform on a large amount of workstations.


    Author Comment

    We're using Dell Optiplex 755 desktops, and Latitude 630 laptops but my testing has been strictly with the desktops. I also think the problem has something to do with partitions but I'm thinking it's the formatting. I started getting the 2nd error above after I formatted the disk using the winPE tool Since I used boot.wim from a vista DVD to make my boot images, maybe it's not compatible w XP?  I don't know, I guess I'm just reaching.
      I'm out of the office for the rest of the week but will check for the diagnostic partition first thing Monday.  
    LVL 17

    Expert Comment

    by:James Haywood
    We have the same issue. I network boot from my winPE image and do the following:

    attrib -s -h -r c:\boot.ini

    edit c:\boot.ini

    Manually change the partition from (1) to (2) (or vice versa) within boot.ini then save the file and close

    attrib +s +h +r c:\boot.ini

    Then XP should boot as normal and boot.ini is correct and will not need further editing. This takes 3min start to finish.


    Author Comment

    First of all, thanks guys for your time and sorry it took me so long to respond.
       my machines  do have a utility partition. I would like to set this up zero-touch though, so using the recovery console does not work for me. If that's the only way to go, I'll stick with WDS in mixed mode and keep my riprep images. I know it's slower, but I don't want to complicate things for the rest of the folks here who prepare machines.

    hhaywood, the steps you mention above did work for me but like I mentioned to Darren, I'd like to get this working as a zero touch installation.

    I believe one of the problems I'm running into here is related to the UBER bug documented here:  That article suggests to add some reg values prior to capturing the image.
      Another thing someone suggested to me offline was to somehow have winPE do a "bootsect /nt52 /force" prior to the OS install.  I'm looking at the deployment toolkit to try and figure out how to insert a task to try that.   I'll post results as soon as I have them.


    Accepted Solution

    Installed the MDT 2008 and was then able to get my XP wim images to work.

    Expert Comment

    Mackman, can you explain how you got it work? I'm currently trying to fix the same issue. What I've done and am testing now, is I used the workbench tool in MDT2008 to add bootsect /nt52 /force from the command line right before the computer will reboot in the task sequence. Is this what you did too? Not sure mind will work as I'm waiting on the image to finish its install.

    Expert Comment

    My 2 cents. This article from Microsoft worked for me. I was doing W2K3, but similiar to XP install. Apparently the server I created my image from had the Dell partition, which would be partition 1, so my boot.ini reflected windows being on partition 2. I had to use the Windows AIK and WindowsPE to edit my image file's boot.ini to reflect Windows being on partion 1, unmount commit, then replace my image with the changed one. Pretty easy and quick. I did have to look elsewhere for the syntax as the MS article was confusing to me and I needed an example.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
    It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
    This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now