• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1647
  • Last Modified:

DCOM Errors/WMI-WSUS Fails on SBS 2008

Hello,
 
We recently migrated from SBS 2003 (no WSUS) to SBS 2008 Premium (includes WSUS).  I'm getting down to the last of the troubleshooting issues.  WSUS is not able to communicate with the majority of our PCs.
 
I ran WMIDiag on my PC (one of the ones unable to communicate) to see if that would shed any light on the problem.  What I found is:  DCOM was unable to communicate with the computer SBS2003.company.local.
 
In otherwords, my PC is still trying to reach the old server.  I'm guessing that's why WSUS on the new server is unable to communicate with my PC.
 
Can anyone shed some light on this and offer some steps to resolve it?
 
I offer sincere thanks.
 
Gpresult on my PC - XP SP3:    
 
The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
        WXP Windows Firewall
            Filtering:  Denied (WMI Filter)
Error: Not Found
 
On the SBS 2008 server, in event viewer:
 
Log Name:      System
Source:        Microsoft-Windows-GroupPolicy
Date:          4/16/2009 9:52:45 AM
Event ID:      1104
Task Category: None
Level:         Warning
Keywords:    
User:          xxxxx
Computer:      SBS2008.company.local
Description:
Windows was unable to read the Windows Management Instrumentation (WMI) filter information associated with the Group Policy object CN={xxxxx}, CN=POLICIES,CN=SYSTEM,DC=company, DC=LOCAL.This may be caused by a deleted WMI Filter defined in the domain that is still in use by Group Policy objects. Group Policy settings for this Group Policy object will not be enforced. Other Group Policy objects may still apply. Windows will attempt to retrieve this information at the next policy cycle. This specific problem may be resolved by identifying all GPOs that reference the WMI filter and removing the references.
0
normajm400
Asked:
normajm400
  • 2
  • 2
1 Solution
 
DonNetwork AdministratorCommented:
0
 
DonNetwork AdministratorCommented:
0
 
normajm400Author Commented:
Sorry it's taken so long to respond.  

I had run SBS BPA and there were only two errors - neither applicable to resolving my problem.  

The Technet article says to check for existance of the WMI Filter and if it doesn't exist, remove it from the Group Policy object.  How do I narrow down which GPO to remove it from?!  I'm guessing that this all has to do with the missing WXP Windows Firewall which comes up as"not found"  Thus the server is unable to communicate with the PCs through the XP Firewall.  

I ran WMIDiag and there are some errors, don't know how to fix them...yet.

I've been very busy with some other projects.  As the PCs do update automatically via the MS site, we're still protected.  Soon as time allows, I'll turn off the XP Firewall on one of the PCs and see if the server can communicate with it.  Doesn't make sense though as Spiceworks has no problem accessing the PCs and that software uses WMI.  
0
 
normajm400Author Commented:
http://msmvps.com/blogs/levy/archive/2009/01/02/deleted-update-services-gpos-on-sbs-2008.aspx

This explains in part why WSUS isn't working on our new SBS 2008.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now