?
Solved

AS400 SNDNETSPLF

Posted on 2009-04-17
7
Medium Priority
?
2,232 Views
Last Modified: 2013-12-06
Dear support team,

I am using SNDNETSPLF option since long time and very well i am able to send the spool file from 1 uesr profile to another and vice versa.
but today i am facing one problem that i am not able to send the spool file by SNDNETSPLF to only 1 user profile. i had tried with various other user profile and various spool files . i  had checked DSPUSRPMN also, everything is ok with WRKDIRE.

can you please guide

bsidteam
0
Comment
Question by:Bsidmis
  • 4
  • 3
7 Comments
 
LVL 27

Expert Comment

by:tliotta
ID: 24189402
bsidteam (team?):

> ...i am facing one problem that i am not able to send the spool file by SNDNETSPLF to only 1 user profile.

How can you tell? Does an error appear? Or does the spooled file simply disappear? If an error appears, where do you see it? When do you see it? What error is it?

For an error message, view the message in an interactive session. Move the cursor to the message and press <F1> to see additional information. Copy/paste the message detail into a reply here.

Tom
0
 

Author Comment

by:Bsidmis
ID: 24190888
DEAR TOM,
I AM ENCLOSING A DOCUMENT CONTAINING COMPLETE COMMAND AND THIS COMMAND IS NOT WORKING WITH SPECIFIC 1 USER PROFILE I.E. MARCAM rest with all the user id i am able to sent the spool file with this command.
thanks
 

PROBLEM-WITH-SNDNETSPLF.doc
0
 
LVL 27

Accepted Solution

by:
tliotta earned 150 total points
ID: 24198024
Bsidmis:

Again, how do you know that the command is not working?

That means...:

Does the spooled file disappear? Is no message sent to the user profile for MARCAM saying that a file was received? What user profile is associated with user ID MARCAM? What output queue is assigned to that user profile?

Tom
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:Bsidmis
ID: 24200876
dear tom,
you are absolutely correct, the spool file doesn't get appear in MARCAM spool file. therefore i understood the command is not working. and in MARCAM user profile, no message sent to MARCAM user id. the outputq is *WRKSTN and it is the same as in other user profile also. user profile is same as MARCAM and this id is provided by our ERP vendor.
bsidteam
 
 
0
 
LVL 27

Expert Comment

by:tliotta
ID: 24201040
bsidteam:

Okay, so the command completes and issues a message saying that the spooled file was sent. The user ID in the system directory is MARCAM at that system. The user profile is MARCAM for user ID MARCAM.

I cannot tell the user profile who sent the message, but the user profile is SHAILESHM on the spooled file. Also, I can see a [MW=Message waiting] indicator at the bottom of the screen prints.

When a spooled file is sent and received, message ID CPI8072 should be sent to the message queue of the sending user profile.

When you send to MARCAM, does CPI8072 arrive in your user message queue? Is your message queue in *BREAK mode at a different workstation when you send to MARCAM?

Tom
0
 

Author Comment

by:Bsidmis
ID: 24201086
Dear Tom,
Yes, command completes and issues a message but doesnt appear in spool file list.
I understand that MW is the standard indication of AS400 which indicates that you are in "Main Window" or Main Menu. therefore it is not a message waiting.
the mesg id CPI8072 i am not getting any where either successfully i had sent a spool file or not.
In MARCAM mesg queue was *NOTIFY now i have changed as *BREAK and then tried but still i didn't get the spool file in MARCAM.
if you see the job log which i had sent in word file. there is a mesage indicating that
"The file was not sent to 0 users becuase they had distributions that were not correct."
please let me know the further steps.
regards
bsidteam.
 
0
 
LVL 27

Assisted Solution

by:tliotta
tliotta earned 150 total points
ID: 24208738

> I understand that MW is the standard indication of AS400 which indicates that you are in "Main Window" or Main Menu. therefore it is not a message waiting.

No.

The session screen-prints that you supplied look like iSeries access sessions. The [MW] indicates that there is a "message waiting" either for the display message queue or your user message queue or another message queue that has been allocated to the session. It indicates that a message has arrived on a message queue that is associated with the the session, but the message has not yet been looked at in that session. If you execute the DSPMSG command, the [MW] indicator should turn off.

When SNDNETSPLF runs, a *COMPLETION message CPC8053 is sent to the job that ran the command. You generally see this on the message-line at the bottom of your screen as "File XXXXXX sent to N users. Not sent to M users."

But SNDNETSPLF also sends an *INFORMATION message CPI8072 to the message queue of the user who ran the command.

There is some indication that it may be sent as a *NOTIFY message under some unclear circumstances. When it is a *NOTIFY message, the spooled file does not actually get delivered until the *NOTIFY message is responded to. I have caused this to happen in the past, but cannot yet recall exactly how it happens. A message queue in *BREAK mode can display the CPI8072, and until that message is acknowledged, usually simply by pressing [Enter] to exit the messages screen, the spooled file will not appear on the target output queue.

Unfortunately, this is an obscure area (for me). It might take some experimentation.

It doesn't matter what MARCAM's message queues are set for. Questions about message queues are about the user who runs the SNDNETSPLF command. Those questions will help eliminate some possibilities and help narrow the problem down.

Tom
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello I read in a discussion about a person who configured a very simple mirror RAID with two hard drives; the system and data were on the same partition. He asked how to repair the system as it was not booting up anymore. In his case running …
In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question