Setting up Autodiscovery Exchange 2007

Posted on 2009-04-18
Last Modified: 2012-05-06
Hello All
I have set up exchange in my company on a server 2k8 box.
I have outlook 2007 clients and i am having huge problems with auto discovery as i have never seen this before.

I have spend many hours watching my Train Signal info on how to set it up but it does get a little confusing.
Can anyone help with setting up Autodiscover so i can progress onto the next step of my setup,

Send and Receive takes a long time for clients using outlook 2007 and the OAB does not update for the users unless i delete the OAB files from the client computers.

I understand i will need a cert to.

Is there a guide for setting up autodiscovery, i do not need any public dns entrys as my current pop3 solution wis forwarding mail to exchange during my migration.

I understand that autodiscovery works via HTTPS but is this needed as all my clients access the server internally or over a cisco VPN there is no need for secure transport at present.

Can anyone help me Please
Question by:Seanie_
    LVL 65

    Expert Comment

    You cannot run Exchange 2007 without SSL, it doesn't matter what other solutions you have in place for email access, Exchange 2007 is built around SSL.
    When I do the deployments, I don't care what the transport mechanism is, the same things are done on all systems.

    1. The built in SSL certificate is switched to a SAN/UC certificate with the required names.
    2. I setup so that resolves internally and externally to the correct IP addresses (where is the name used on the email addresses).
    3. That all of the URLs set in the product are correct and resolve correctly internally and externally.

    Autodiscover doesn't need any setting up, but the main problems come with certificate prompts and simple failure of the product to connect successfully.

    You can do some diagnosis internally using Outlook. Hold down the CTRL key while right clicking on the Outlook icon and choose to test email auto configuration. Then check the URLs that are being handed out are correct.

    LVL 1

    Expert Comment

    I would suggest that you might have a dns problem in your network. As far as I know there is no way / no need to set up the autodiscover feature. It's all automatically managed by outlook, exchange and AD. Check your dns (forward and reverse lookup) entries for the exchange server, global catalog server(s), etc.

    Author Comment

    Hi there
    thanks for your prompt responses.

    I tested ping and it does not resolve.

    I also used the Test E-Mail auto config tool and the results were:

    autoconfiguration has started, this may take a minute
    autoconfiguration found the following settings

    Display Name: My Name

    Protocol: Exchange RPC
    Server: servername.domain.local
    login name: My userid
    availability service URL: http://servername.domain.local/ews/exchange.asmx
    OOF URL: http://servername.domain.local/ews/exchange.asmx
    OAB URL: http://servername.domain.local/OAB/http://ctdiuk-ex1.ctdiuk.local/oab/6dceb980-aec1-4cd0-a8cd-b5ae9f6e05b5/
    Unified Message Service URL: http://ctdiuk-ex1.ctdiuk.local/unifiedmessaging/service.asmx
    auth packadge: Unspecified.

    The above settings are when i only check autodiscover.
    Using Guessmart most items fail in there apart from as that is hosted on the web currently.

    All of the URL's first ask me to confirm the cert is out but then ask for a login to which i use my domain username and password and it allow me to log in.

    I have not setup any DNS settings as yet.
    Do i need to setup ? if so which record type do i want to add on my internal dns servers????

    LVL 65

    Accepted Solution

    Your OAB URL looks wrong. Have you tried to hide it and have made an error? If not, and that is actually what you received then would cause a problem. doesn't have to resolve internally. Ideally it should, particularly if you are going to have non-domain clients inside the firewall using Outlook, but if everything is a member of the domain then you can get away without it.

    If you have a zone for internally, then configure an A record of autodiscover and point it to your Exchange server's internal IP address.

    The certificate ideally needs to be changed for a commercial certificate, which will avoid the certificate prompt.
    I have outlined the steps required here:


    Author Closing Comment

    Thanks for your help! Used for exchange consultancy and worked through my problems

    Thanks Once again

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Hire Top Freelancers to Complete Exchange Projects

    Source the talented Expert Exchange community
    for top quality work on your Exchange projects.

    Hire the best. Collaborate easily. Get quality work.

    Get an idea of what you should include in an email disclaimer with these Top 5 email disclaimer tips.
    Set OWA language and time zone in Exchange for individuals, all users or per database.
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    This video discusses moving either the default database or any database to a new volume.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now