Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1223
  • Last Modified:

Unable to set "clock rate" on Frame relay switch

my config for two serial int is:

interface Serial0/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102

but the last thing missing is the clock rate 64000 command

I try to do

FR#(config-if) clock rate 64000

but it doesn't save into running config

any idea what I'm doing wrong?


thank you
0
piotrmikula108
Asked:
piotrmikula108
  • 6
  • 4
  • 2
1 Solution
 
Sniper98GCommented:
are you typing "clock rate" or 'clockrate"?

I was pretty sure it was supposed to be the latter.
0
 
piotrmikula108Author Commented:
I tried both actually, neither is saved to the config
0
 
Sniper98GCommented:
What if you show the interface (sh int s0/0) what clock rate is shown their? I'm not entirely sure what the default clock rate is on those ports but if the command is considered default it will not be displayed in the config.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
piotrmikula108Author Commented:
no clockrate.

show int serial 0/0
Serial0/0 is up, line protocol is down
  Hardware is PowerQUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  0, LMI stat recvd 0, LMI upd recvd 0
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0, DCE LMI down
  LMI DLCI 1023  LMI type is CISCO  frame relay DCE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 01:02:56
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 124 interface resets
     0 output buffer failures, 0 output buffers swapped out
     250 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


Here is the entire sh run, it's a 2610XM ROUTER:

Current configuration : 994 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FR-SWITCH
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
!        
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
frame-relay switching
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!        
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

0
 
Don JohnstonInstructorCommented:
The clockrate can only be set on a DCE interface. Issue a "show controller s1//0" (or whatever interface you're trying to set the clockrate on). You should see "cable is v.35 DCE" on about the second or third line. If you see that you have a DTE cable, that's why you can't set it.

0
 
piotrmikula108Author Commented:
I'm new to frame relay but from what I read is that even though frame relay switch may have DTE ends plugged in, the "frame-relay intf-type dce" command will force them to act as dce. My other two router's DCE ports are set to no clockrate
0
 
Don JohnstonInstructorCommented:
Cable type and clockrate is a layer 1 function. All the frame-relay stuff is layer 2. Before you can do any frame-relay tasks, you have to get layer on working.

First, find out which end of the cable is the DCE end. Most cables have a label that will indicate this. Or you can use the "show controller" method. On the DCE end of the cable, set the clockrate.

Then you can worry about all the frame-relay commands.
0
 
piotrmikula108Author Commented:
unfortunately the frame relay switch is the only one I have here with two smart serial ports and the cables are DTE on this end, the other two routers have single serial ports with the DCE ends. Can the clock rate be set on the two other routers in frame-relay scenario on it needs to be set on the frame-relay switch for some reason?
0
 
Don JohnstonInstructorCommented:
The clock rate can (and must) be set on whatever serial port that has the DCE end.

I usually connect the DCE end to the serial port on the frame-relay switch. But there's no reason it won't work on the other end.
0
 
piotrmikula108Author Commented:
it's working now after putting the clock rate on the "edge" routers,

I can ping from one router to another now. Is that the sign frame-relay is working?

when I do show frame-relay map on the FRswitch I get nothing but show frame-relay pvc shows

PVC Statistics for interface Serial0/0 (Frame Relay DCE)

              Active     Inactive      Deleted       Static
  Local          0            0            0            0
  Switched       1            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial0/0

  input pkts 26            output pkts 26           in bytes 1984      
  out bytes 1984           dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
  switched pkts 26        
  Detailed packet drop counters:
  no out intf 0            out intf down 0          no out PVC 0        
  in PVC down 0            out PVC down 0           pkt too big 0        
  shaping Q full 0         pkt above DE 0           policing drop 0        
  pvc create time 01:34:19, last time pvc status changed 00:10:33

PVC Statistics for interface Serial0/1 (Frame Relay DCE)
         
              Active     Inactive      Deleted       Static
  Local          0            0            0            0
  Switched       1            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1

  input pkts 27            output pkts 27           in bytes 2018      
  out bytes 2048           dropped pkts 2           in pkts dropped 2        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
  switched pkts 26        
  Detailed packet drop counters:
  no out intf 0            out intf down 0          no out PVC 0        
  in PVC down 0            out PVC down 2           pkt too big 0        
  shaping Q full 0         pkt above DE 0           policing drop 0        
  pvc create time 01:34:33, last time pvc status changed 00:10:58

and

FR-SWITCH#show frame-relay lmi

LMI Statistics for interface Serial0/0 (Frame Relay DCE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Rcvd 135              Num Status msgs Sent 135
  Num Update Status Sent 0              Num St Enq. Timeouts 285
         
LMI Statistics for interface Serial0/1 (Frame Relay DCE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Rcvd 73               Num Status msgs Sent 73
  Num Update Status Sent 0              Num St Enq. Timeouts 326

why show frame-relay map doesn't show anything? should this command be only used on the other routers? I get results there as you can see below

R1#show frame-relay map
Serial0/0 (up): ip 10.1.2.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

R2#show frame-relay map
Serial0/0 (up): ip 10.1.2.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
0
 
Don JohnstonInstructorCommented:
Frame-relay maps are a function of the customer equipment. It maps an IP to a DLCI. The provider (Frame-Relay Switch) doesn't have (or need) a mapping.
0
 
piotrmikula108Author Commented:
cool! you rock! thanks a lot for helping out on Saturday
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 6
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now