[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 822
  • Last Modified:

Unable to receive email but can send...

I am in the process of upgrading a 2003 Domain with Exchnage 2003 to a 2008 Domain with Exchange 2007.  Here is why I am having my problem...
My external domain name is:  abc.com
My internal domain name is:    def.ghi.jkl.net
I inherited this company when it was already set up this way.  they had on 2003 domain controller with Exchange 2003 installed on the DC.
I installed two new servers with Server 2008 each and made one a DC in the domain and installed Exchange 2007 and DNS on the 2008 DC.
Everything went fine and all servers can see each other and all shares are working properly.

I moved a mailbox from the Exchange 2003 server to the Exchange 2007 server.  I am able to receive email but can not send.

I ran the Microsoft Exchange Troubleshooting Assistant on the Exchange 2007 server and I receive an error message under root causes:
Server server2003.abc.com is a remote server to which server Server2007 is trying to send messages but no 'Host' records of server server.abc.com can be obtained from any DNS servers server Server2007 uses. This may be causing message backups in the queue.

Server2008 is resolving Server2003 with the external domaian name of server2003.abc.com, goes outside the network then tries to come back in.  We use Postini so we only allow email to come in from outside from Postini so server2003 rejectes the email from server2008

Now I know this leads to the obvious of a DNS issue so I checked DNS.

All DNS records internally are listed under the domain def.ghi.jkl.net and abc.com is not entered anywhere.

There is a mail Connector setup between the two email servers.

Do I need to add the domain abc.com to my internal DNS?  If so, how do I do it without messing up the def.ghi.jkl.net internal domain???
0
drwebber11
Asked:
drwebber11
  • 12
  • 3
  • 2
  • +1
1 Solution
 
kdagliCommented:
Check the "Connection Tab" on Default SMTP Virtual Server of Exchange 2003. Make sure you have added the IP address of exchange 2007 server as a allowed connection.
0
 
drwebber11Author Commented:
Yes, it is an allowed connection on the Exchange 2003 server
0
 
drwebber11Author Commented:
The title is wrong, but the body of the message is correct...

I can receive email but I can not sent....

Sorry about that.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
kdagliCommented:
Run get-routinggroupconnector | fl on the 2007 box and paste the output
Also,wat is d last error in d queue?
0
 
drwebber11Author Commented:
when I run that command I get a command not recognized...
0
 
kdagliCommented:
I am suspecting you are typing something wrong.

get-routinggroupconnector | fl is the valid command on exchange 2007 box.

http://technet.microsoft.com/en-us/library/aa996924.aspx
0
 
drwebber11Author Commented:
Got it...

[PS] C:\Windows\System32>Get-RoutingGroupConnector

Name                      SourceRoutingGroup         TargetRoutingGroup
----                      ------------------         ------------------
EXCHANGE2-SERVER2800      Exchange Routing Group ... first routing group
SERVER2800-EXCHANGE2      first routing group        Exchange Routing Group ...
0
 
drwebber11Author Commented:

[PS] C:\Windows\System32>Get-RoutingGroupConnector | fl


TargetRoutingGroup           : first routing group
Cost                         : 1
TargetTransportServers       : {SERVER2800}
ExchangeLegacyDN             : /o=BEVERLY/ou=Exchange Administrative Group (FYD
                               IBOHF23SPDLT)/cn=Configuration/cn=Connections/cn
                               =EXCHANGE2-SERVER2800
PublicFolderReferralsEnabled : True
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {EXCHANGE2}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : EXCHANGE2
MaxMessageSize               : unlimited
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : EXCHANGE2-SERVER2800
DistinguishedName            : CN=EXCHANGE2-SERVER2800,CN=Connections,CN=Exchan
                               ge Routing Group (DWBGZMFD01QNBJR),CN=Routing Gr
                               oups,CN=Exchange Administrative Group (FYDIBOHF2
                               3SPDLT),CN=Administrative Groups,CN=BEVERLY,CN=M
                               icrosoft Exchange,CN=Services,CN=Configuration,D
                               C=beverly,DC=intranet,DC=mbec,DC=net
Identity                     : EXCHANGE2-SERVER2800
Guid                         : dbd780de-34a0-440f-a957-5fc36b1f969f
ObjectCategory               : beverly.intranet.mbec.net/Configuration/Schema/m
                               s-Exch-Routing-Group-Connector
ObjectClass                  : {top, msExchConnector, msExchRoutingGroupConnect
                               or}
WhenChanged                  : 11/16/2008 12:32:07 PM
WhenCreated                  : 11/16/2008 12:31:54 PM
OriginatingServer            : Exchange2.beverly.intranet.mbec.net
IsValid                      : True

TargetRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
Cost                         : 1
TargetTransportServers       : {EXCHANGE2}
ExchangeLegacyDN             : /o=BEVERLY/ou=first administrative group/cn=Conf
                               iguration/cn=Connections/cn=SERVER2800-EXCHANGE2
PublicFolderReferralsEnabled : True
SourceRoutingGroup           : first routing group
SourceTransportServers       : {SERVER2800}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SERVER2800
MaxMessageSize               : unlimited
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : SERVER2800-EXCHANGE2
DistinguishedName            : CN=SERVER2800-EXCHANGE2,CN=Connections,CN=first
                               routing group,CN=Routing Groups,CN=first adminis
                               trative group,CN=Administrative Groups,CN=BEVERL
                               Y,CN=Microsoft Exchange,CN=Services,CN=Configura
                               tion,DC=beverly,DC=intranet,DC=mbec,DC=net
Identity                     : SERVER2800-EXCHANGE2
Guid                         : 4f2800b7-49f9-483d-b12b-90ddf8c6cec5
ObjectCategory               : beverly.intranet.mbec.net/Configuration/Schema/m
                               s-Exch-Routing-Group-Connector
ObjectClass                  : {top, msExchConnector, msExchRoutingGroupConnect
                               or}
WhenChanged                  : 11/16/2008 12:32:07 PM
WhenCreated                  : 11/16/2008 12:31:55 PM
OriginatingServer            : Exchange2.beverly.intranet.mbec.net
IsValid                      : True

0
 
MesthaCommented:
How do you route email to Postini? Where is the smart host set? On the SMTP virtual server or on the SMTP connector? If it is on an SMTP virtual server then it needs to be moved to an SMTP connector.

What I cannot work out is why the server is resolving to an external host name. Are you using AD servers only for DNS? Are you using public IP addresses that could be confusing things?

Simon.
0
 
drwebber11Author Commented:
The smart host is set on the virtual SMTP server on the Exchange 2003 box.

The external domain name is different than the internal domain name.  After receiving the errors I was getting, I added an entry to the local lmhost file and now I do not receive that error anymore.

But now the outgoing email from the Exchange 2007 box sits in queue on the Exchange 2007 box.

I should have noted that outgoing email from the Exchange 2003 server is working

Exchange 2003 incoming and outgoing email works.
Exchange 2007 incoming email works but outgoing queues on that server

Yes, I am only using AD servers for DNS, primary is Server2003, secondary is Server2007
0
 
MesthaCommented:
"The smart host is set on the virtual SMTP server on the Exchange 2003 box."

That MUST change. It will cause problems with mail flow. Remove it and place it on an SMTP connector. Then wait, that may well resolve the issues with outbound email as well.

The smart host on the SMTP virtual server forces all email to go through the smart host, whether internal or external and causes havoc with replication traffic.

Simon.
0
 
drwebber11Author Commented:
Mestha, You were correct, the smart host is enabled on the connector and not the virtual SMTP
0
 
drwebber11Author Commented:
On the Exchange Server 2003 I see my connector for my two Exchange servers under Connectors but I do not see it on my Exchange 2007 server under Hub Transport.  Do I need to manually add one to my 2007 server?
0
 
Randy81Commented:
On the Exchange 2007 server in the management console > Organization configuration > Hub transport > Send connectors
Add new send connector, select internal as intended use,
Add your local and external domains under address space,
Add the IP of your Exchange 2003 server to the smart hosts
Use None for authentication,
Your Source server should be the Exchange 2007 server

That should be all you need in 2007, on the 2003 server make you have under the SMTP protocol > Access > Relay > add the IP of the Exchange 2007 computer,
The DNS error might be looking for an MX record but this should bypass that

Hope this helps
0
 
drwebber11Author Commented:
I added the send connector and verified the relay but the outgoing email still sits in the queue on the 2007 server
0
 
drwebber11Author Commented:
wait, one email did go through while changing things...i need to retrcae my steps and see what it is
0
 
drwebber11Author Commented:
Randy 81:
I did as you said but used * under name space to make it work.
0
 
Randy81Commented:
Glad its working, I misunderstood and thought you were have troubles sending to your local domains only.

A side note, you are now delivering all emails through the 2003 server, if it is your plan to remove that server one day, you will need to create a send connector using Internet instead of internal, I would recommend coping the information from your 2003 server, because you might be doing direct delivery by DNS record or forwarding everything to your ISP for final delivery but its already working and I like to copy working configs :)

2003 server Exchange System Manager > Routing group > your 2003 routing group name > connectors > SMTP connector (is default name I believe)
Under General it will be ether DNS or Forward just use whatever it says in your 2007 config when the time comes.
If you want to test it now using both connectors (one for your local domains, one for Internet) set cost 1 on local and 2 or higher depending on your connectors for the * connector, you always want your final delivery method * to be the highest cost.
0
 
drwebber11Author Commented:
Yes, that is my intention to eventually take down the Exchange 2003 server.  I have a couple of more kinks to work out first though.

Thank you!!!
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 12
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now