Autodiscover and activesync are not working after migrating from server2003 exchange 2007 to server 2008 exchange 2007 sp1

I have the same problem as this guy in this post: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23509930.html

Did any of you manage to figure it out? I have the multi name certificate, rpc is finally working after many hours of digging the web. Any help would be greatly appreciated.

Error when trying to run the autodiscover test:
 When contacting https://mydomian/Autodiscover/Autodiscover.xml received the error The remote server returned an error: (500) Internal Server Error.


Configuration Error 
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
 
Parser Error Message: Could not load file or assembly 'Microsoft.Exchange.Clients.Owa' or one of its dependencies. The system cannot find the file specified. (D:\program files\Microsoft\Exchange Server\ClientAccess\Owa\web.config line 41)
 
Source Error: 
 
 
Line 39: 		<!-- OWA HTTP Modules -->
Line 40: 		<httpModules>
Line 41: 			<add type="Microsoft.Exchange.Clients.Owa.Core.OwaModule, Microsoft.Exchange.Clients.Owa" name="OwaModule" />
Line 42: 		</httpModules>
Line 43: 
 
 
Source File: D:\program files\Microsoft\Exchange Server\ClientAccess\Owa\web.config    Line: 41 
 
 
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3074; ASP.NET Version:2.0.50727.3074

Open in new window

siltechAsked:
Who is Participating?
 
siltechConnect With a Mentor Author Commented:
Ok, its a little complicated but I solved it finally:

the ASP.NET error was because the classic mode was used and thats the way it SHOULD be although the intergated mode is what the tell you to use with iis7...but we let the exchange decide and it should be classic. For some reason the iis didnt like it and kept throwing that annoying error. So i thought ok lets do it with integrated..I got a new error 500.22 it means if you want to use integrated you need to migrate your web.config with appcmd. Did it, got a new error 500.19 cannont creat duplicate entry, means in a parent .config file the entry excists. You have two choices: delete the duplicate entries at parent level or child level. the message was gone but if you tried to log into your owa account all you got were your folders, no mails in the middle pane.
So I unistalled the iis and the cas and reinstalled them ( for the second time) and everything started working again. Tried to work in integrated mode after migrating the web.config file: error cannot handle the request in owa with the folders showing on the side. So back to classic and no ASP errors. Thank you for your help and I hope it helps others too.
0
 
FearNoMoreCommented:
Go to the below mentioned link and run the tests
https://www.testexchangeconnectivity.com/
Post back with the output
0
 
siltechAuthor Commented:
I did, I m far beyond runnig tests now, I already KNOW I have a problem and the tests dont give my answers.
0
 
RaghuvCommented:
To resolve the "The remote server returned an error: (500) Internal Server Error." issue, try recreating the Autodiscover virtual directory.

# Remove-AutodiscoverVirtualDirectory -Identity ""
# New-AutodiscoverVirtualDirectory
0
 
v-9sousoCommented:
CAUSE

i have configured redirection on the Default Web Site to point to
https://mail.contoso.com/owa.

RESOLUTION

Resolved issue by checking the checkbox for "A directory below URL entered" which
is found on the property page of the Default Web Site where you enable redirection.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.