?
Solved

Cisco 2960 - Basic configuration for Data/Voice on the same switch

Posted on 2009-04-19
7
Medium Priority
?
4,786 Views
Last Modified: 2012-06-27
Please provide the configuration to setup a remote office with only one cisco switch (2960).
I want two valns (2 for data, 3 for voice);
More details can find below / from diagram..

Vlans:      
vlan 2-----data (10.200.1.254)
vlan 3-----voice (192.168.1.254)
      
Swtich Ports:      
Fa 0/1-----Voice Gateway - Server (192.168.1.1)
Fa 0/2-----IP Phone (192.168.1.100) + PC Connected (10.200.1.100) to the phone
Fa 0/3-----Printer (10.200.1.201)


SampleVOIPdiagram.JPG
0
Comment
Question by:Lernst
  • 5
  • 2
7 Comments
 
LVL 6

Accepted Solution

by:
ged125 earned 600 total points
ID: 24180215
This should get you started.  I am assuming you want to use the switch for DHCP.
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2960
!
!
username cisco privilege 15
username cisco secret cisco
no aaa new-model
clock timezone Pacific -8
clock summer-time PDT recurring
vtp mode transparent
ip subnet-zero
ip routing
ip telnet source-interface Vlan1
ip domain-name mydomain.com
ip name-server 4.2.2.1
ip name-server 4.2.2.2
!
ip dhcp pool VLAN2
   network 10.200.1.0 255.255.255.0
   default-router 10.200.1.254 
   domain-name mydomain.com
   option 150 ip 192.168.1.1 
   dns-server 4.2.2.1 4.2.2.2
!
ip dhcp pool VLAN3
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254 
   domain-name mydomain.com
   option 150 ip 192.168.1.1 
   dns-server 4.2.2.1 4.2.2.2 
!
ip multicast-routing distributed
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint TP-self-signed-3329456256
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3329456256
 revocation-check none
 rsakeypair TP-self-signed-3329456256
!
!
crypto ca certificate chain TP-self-signed-3329456256
 certificate self-signed 01
  30820284 308201ED A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  50312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33333239 34353632 3536311D 301B0609 2A864886 F70D0109 
  02160E33 3536302E 6E776973 732E6E65 74301E17 0D393330 33303130 30303131 
  375A170D 32303031 30313030 30303030 5A305031 2F302D06 03550403 1326494F 
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3333 32393435 
  36323536 311D301B 06092A86 4886F70D 01090216 0E333536 302E6E77 6973732E 
  6E657430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 
  A811B32A 37A4AACC 78C48017 171DA1C0 6C6BBE2E 25B4879B 78770AF2 13FB85E9 
  D97B798C 805C3888 13D510DF EFFCE98D E425AECD BB1DA78C D764F85E 45084CB6 
  F9D74EB2 3E120B73 9399828E 0470DB5E E95FF70B 26D2ADDC 960DE83F 18547DFE 
  14A574F3 5496E5FB 162A4C5C 0D82D4B7 3AD3CA7B CAB9B557 456B0FEC 15B428D7 
  02030100 01A36E30 6C300F06 03551D13 0101FF04 05300301 01FF3019 0603551D 
  11041230 10820E33 3536302E 6E776973 732E6E65 74301F06 03551D23 04183016 
  8014FD71 BE02F990 19E623AB 701BB72B D93D49D0 8890301D 0603551D 0E041604 
  14FD71BE 02F99019 E623AB70 1BB72BD9 3D49D088 90300D06 092A8648 86F70D01 
  01040500 03818100 49DC50E0 4EA0C4B5 3E1267E9 21690B19 3E4F518C 1FD73E82 
  130491DF FF98B744 A3D916C5 1CF29859 CD291615 68C3D322 17A98156 FD000CE3 
  194C1428 068761D8 B2C23988 79823B18 44E891D3 5502C6ED 7A124386 5322B6A8 
  67B5E40B BE60610A C13F3671 A6D1280C 4E532C72 C3CA3EC4 2F84997C DB3EA68A 
  F7038097 DAD96084
  quit
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
 name Data 
!
vlan 3
 name Voice
!
!
interface FastEthernet0/1
 description Sample Data Voice
 switchport access vlan 2
 switchport mode access
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
!
interface FastEthernet0/2
 description Sample Voice Port
 switchport access vlan 3
 switchport mode access
 switchport voice vlan 250
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
!
interface Vlan2
 ip address 10.200.1.254 255.255.255.0
!
interface Vlan3
 ip address 192.168.1.254 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
 login local
line vty 5 15
 no login
!
ntp clock-period 36029228
ntp server 140.142.16.34
!
end

Open in new window

0
 
LVL 6

Expert Comment

by:ged125
ID: 24180218
Line 18 should actually read :"ip telnet source-interface Vlan2"
0
 
LVL 6

Expert Comment

by:ged125
ID: 24180231
After looking at your diagram again I realize there are a couple changes.   Use this config for the interfaces.
interface FastEthernet0/1
 description Avaya Phone Switch
 switchport access vlan 3
 switchport mode access
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
!
interface FastEthernet0/2
 description Sample Voice Port
 switchport access vlan 2
 switchport mode access
 switchport voice vlan 3
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast
!
interface FastEthernet0/3
 description Sample Printer Port
 switchport access vlan 2
 switchport mode access
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
 spanning-tree portfast

Open in new window

0
[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

 

Author Comment

by:Lernst
ID: 24180311
Thanks a lot for immediate respose.
I do not require DHCP on the switch as I got a DHCP server already there.
We were doing the configuration on HP switch by tagging/untagging traffic.
Is that possible in Cisco switchs..If possible hope dont mind in providing that tooo.

Is this crypto ca certificate (line 91) and below are mandatory? I need very basic commands to make the setup in the working with traffic prioritised for Voice.
Thanks Again...
0
 
LVL 6

Expert Comment

by:ged125
ID: 24180339
Line 91 is not required for what you need.

If the IP phones support 802.1Q tagging, can you specify on the phone what the data VLAN is?  If that this the case, I phone port would look like this:

Interface FastEthernet0/2
 description Connected to Phone and PC
 switchport trunk encaps dot1q
 switchport mode trunk
 switchport trunk native vlan 2 (make sure this matches the phone's configuration)
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast

The QoS configuration on this interface should be the same for a Avaya phone, although Cisco is specified.
0
 

Author Closing Comment

by:Lernst
ID: 31572012
Thanks a lot for your support.
But the line 17: IP Routing did not accepted by the switch. I would like to know whether this switch does not support this or do we have enable some other feature to accept this command.
0
 
LVL 6

Expert Comment

by:ged125
ID: 24311256
The fact that "IP ROUTING"  is not available is usually an indication that the switch does not support Layer 3 switching or the current image is not enhanced.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question