Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2785
  • Last Modified:

Please insert disk into drive E:

I have a Memorex 1GB Travel Drive and a new laptop with Vista Home Premium 64.  When I inserted the drive for the first time it went through the motions of installing the drivers and said new hardware ready to use.  When I go to My Computer and try to open it, it gives me the following error.
"Please insert disk into drive E:"

Thanks, James
0
JAMES125
Asked:
JAMES125
  • 7
  • 4
  • 3
  • +3
6 Solutions
 
johnb6767Commented:
Start>run>diskmgmt.msc

Right click the disk, and sel;ect Change Drive Letter>and Assign it a higher Drive Letter, for testing....
0
 
JAMES125Author Commented:
Disk E: isn't listed in the disk manager but the system files for my device are?
0
 
JAMES125Author Commented:
The system files are listed as F:
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
asmodeusnzCommented:
When was the last time you used this drive?
That error indicates the operating system cannot "See" that drive.
It can't see the format or files you have on that disk.
This generally means the USB drive is stuffed, however.......

Assuming you have files on that disk, which I guess is why you are asking, dont format it, but try putting the drive into a different computer or even the same one you used to write the files to it in the first place
You MIGHT be able to recover the data if you do this.
Otherwise that USB Stick is stuffed, they do just die without warning.
0
 
JAMES125Author Commented:
It's been a couple years since I've used it last and the computer I used it with has died.  I actually tried Format it but it said there is no disk in drive E:.
0
 
johnb6767Commented:
So in My Computer, is your Drive listed as F, or E:?
0
 
JAMES125Author Commented:
Both, the actual drive you would click on to open it is listed as E: but when you insert the drive into the usb port Drive f also appears listed as U3 system files.
0
 
johnb6767Commented:
Can you give us a screenshot? Just attach it to this thread....
0
 
asmodeusnzCommented:
If it was still working it would assign a letter not used by the system.
If its been 2 years since you used it last and its not being detected by the system its definitely pointing to be stuffed.
I suppose you cant try what I suggested because you no longer have the old pc correct?
If not, then I would definitely try another computer, any computer and if the result is the same the USB drive has died
0
 
segurahCommented:
Happens that you have a drive with U3 Techology, they have two partition 1 with u3 and another with fat.

See at : http://en.wikipedia.org/wiki/U3
0
 
johnb6767Commented:
Good catch......
0
 
asmodeusnzCommented:
Doesnt explain why its not detected though.
U3 only launches its gimmick stuff, like Imations Easydrive and Seagates FreeAgent.
Should still be assigned a drive letter if it works.
I didnt think anyone kept the stuff thats on the original drives lol.
0
 
segurahCommented:
0
 
JAMES125Author Commented:
Just a reminder I am currently running Vista Home Premium 64-bit.  The software for the U3 unistalation is made for XP and 2000.
Doc3.docx
0
 
segurahCommented:
Try launchpad 1.6, works with vista ... donĀ“t specify if works wih 64-bits.  (http://lpinstalleru3.s3.amazonaws.com/LPInstaller.exe)


Any case, you can deinstall (wih removal tool) and format flash again. Read at u3 site: http://u3.com/support/default.aspx#CQ3
0
 
EvathiosCommented:
Go To Control Panel  > Administrative tools >> Computer Management
Then Go Down To Storage Disk Management And Look There If your USB Flash Disk Appear there or not .. may be its damaged or has file system error
so you can lunch it from there ..
0
 
John GriffithConsultantCommented:
I would suggest that you update U3 or remove it & format it.
For info, I have dumped file listing of a modern U3 - "Cruzer" 4 GB USB stick.  It does work on Vista x64.  Contents are in code boxes.
Drive g: = 96 MB u3 system drive; drive e: = 3.74 GB "removable disk" FAT32 partition -
 

Volume in drive G is U3 System
 Volume Serial Number is 977A-2C8C
 
 Directory of G:\
 
05/06/2008  08:26 AM               309 autorun.inf
10/23/2007  03:45 AM         1,336,632 LaunchU3.exe
05/06/2008  08:11 AM         5,600,229 LaunchPad.zip
               3 File(s)      6,937,170 bytes
 
     Total Files Listed:
               3 File(s)      6,937,170 bytes
               0 Dir(s)               0 bytes free
 
==========================================
 
Contents of the zip file -- LaunchPad.zip
 
05/06/2008  03:10 PM                 9 version.dat
05/04/2008  04:02 PM         4,603,904 LaunchPad.exe
05/02/2008  10:41 AM         3,493,888 Launchpad Removal.exe
12/09/2007  04:03 PM             1,901 PelicanExtension.dll.sig
12/09/2007  04:00 PM           593,920 PelicanExtension.dll
10/23/2007  10:35 AM           718,336 U3LauncherSetup.msi
10/23/2007  10:33 AM             1,901 LPSecurityExtension.dll.sig
10/23/2007  10:33 AM         2,129,920 LPSecurityExtension.dll
10/23/2007  10:32 AM             1,901 SanDiskFormatExtension.dll.sig
10/23/2007  10:32 AM           544,768 SanDiskFormatExtension.dll
10/23/2007  09:44 AM            54,584 U3AccessGrant.exe
10/23/2007  09:27 AM           110,592 cleanup.exe
10/23/2007  09:23 AM         2,600,960 u3dapi10.dll
10/23/2007  09:23 AM            88,034 LPHelp-tw.chm
10/23/2007  09:23 AM            90,017 LPHelp-jp.chm
10/23/2007  09:23 AM            94,331 LPHelp-it.chm
10/23/2007  09:23 AM            95,968 LPHelp-fr.chm
10/23/2007  09:23 AM            94,194 LPHelp-es.chm
10/23/2007  09:23 AM           109,621 LPHelp-en.chm
10/23/2007  09:23 AM            98,339 LPHelp-de.chm
10/23/2007  09:23 AM            78,576 LPHelp-ch.chm
10/23/2007  09:22 AM               328 Loading.htm
10/23/2007  09:22 AM            58,842 Loading.gif
10/23/2007  09:22 AM                82 PelicanBusyPage.htm
10/23/2007  09:22 AM            35,070 PelicanBusy.gif
              25 File(s)     15,699,986 bytes
 
=========================================================
 
Contents of the autorun.inf file - 
 
[AutoRun] 
open=LaunchU3.exe -a
icon=LaunchU3.exe,0
action=Run U3 Launchpad
 
[Definitions]
Launchpad=LaunchPad.exe
Vtype=2
 
[CopyFiles]
FileNumber=1
File1=LaunchPad.zip
 
[Update]
URL=http://u3.sandisk.com/download/lp_installer.asp?custom=1.6.1.2&brand=PelicanBFG
 
[Comment]
brand=PelicanBFG
 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=

Open in new window

0
 
JAMES125Author Commented:
I've tried all these things including trying the flash drive on additional computers and come to the conclusion that the drive is dead.  Thanks to all for the patience and advice.
0
 
JAMES125Author Commented:
Once again thanks for the help but I think the drive is dead.  Either way I have already bought another drive and tossed the old one.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 7
  • 4
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now