Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Extremelly slow LAN speed on Server 2008 and SBS 2008

Posted on 2009-04-19
13
Medium Priority
?
9,641 Views
Last Modified: 2012-05-06
Hi,

I have already escalated this case for few times, but without sucess.

My problem are 2 Windows 2008 servers, 1 Server 2008 STANDARD and 1 SBS 2008.
All except the following is OK:

1st server is 2008 Standard, and is on physical machine, QuadCore XEON, 8 GB RAM, RAID 10 SAS disks, ALL Gigabit NIC's and Gigabit Switches.
100 Mbps optical fibre internet, which runs almost full 100 Mbps in BOTH DIRECTIONS.
PROBLEM:
MY clients on Gigabit LAN have all interconnection transfer speed between themselves up to 500 or 600 Mbps, except with this SERVER 2008 - only 0.5 - 1 Mbps download speed (from SERVER to CLIENT) max!!!

2nd server is SBS 2008, running on VMware ESXi on same HW as above.
There are 2 virtual machines, one Windows 2003 and one Windows 2008.
Again, problematic is UPLOAD speed from ANY CLIENT to this SBS 2008 - only 2-3 Mbps on Gigabit network.
All other speeds in ANY direction are Gigabit-like.
Also, transfer speeds TO and FROM other virtual machine (win 2003) on same HW are also Gigabit-like

I have tried almost anything on both machines:
- reinstalled NIC drivers
- patched to latest updates
- changed cables
- TEAMED 2 NIC's into team
- played with "autotuninglevel" parameters

But nothing helped!
The common pitfail is: ONLY Win 2008 technology is problematic. And only transfer speed in one direction and one destination is problrmatic (for example - on 1st machine, internet speed is 100 Mbps, but LAN speed is below 1 Mbps).

Here is my paralel post, but there is no usefull advice: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_24273725.html

It is NOT that I want to fine-tune. My current LAN speeds are practically useless, so I need to solve those problems asap.

Suggestions welcome.
Thanx.
0
Comment
Question by:Andrej Pirman
  • 5
  • 3
  • 2
  • +2
13 Comments
 
LVL 47

Assisted Solution

by:Donald Stewart
Donald Stewart earned 300 total points
ID: 24181260
0
 
LVL 7

Accepted Solution

by:
kumarnirmal earned 480 total points
ID: 24181452
I suggest that you check your speed and duplex level in the ESXi Server. Set the speed and duplex to manual instead of Auto-Negotiate and update the thread.
Also when the SBS 2008 VM was created what did you choose for the vNIC Option. Did you choose the enhanced-vmxnet option or the flexible option ?
0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24181458
Please update whether you have installed VMware Tools inside the SBS 2008 VM.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 59

Assisted Solution

by:Darius Ghassem
Darius Ghassem earned 480 total points
ID: 24181505
Disable TCP Checksum, IP Checksum, TCP Offload or IP Offload. These will cause network slowness. What AV are you running in the VMs. Some AVs like Symantec Endpoint causes network issues in 2008.
0
 
LVL 11

Assisted Solution

by:Chris Gralike
Chris Gralike earned 240 total points
ID: 24182910
If you have managed switches, see if there are exessive broadcasts, duplex mismatch, or other problems on the ports connected to the machine. If switch supports it, enable debugging on the specific ports.
0
 
LVL 18

Author Comment

by:Andrej Pirman
ID: 24183445
Wow, guyz, thank you for bunch of advices.
All those are production servers, so I'll try suggested changes only today during the night. I'll report back with results.

Regarding VMware:
- NO, unfortunatelly VMware Tools do not want to get installed on this specific virtual machine 2008
- YES, speed of both NIC on ESX is set to 1 Gbps full-duplex manually
- VM's NIC is Intel PRO 1000 NT and if I look at driver's properties, there is nothing related to virtual*, enhanced-vmxnet option or the flexible option
hmmm....might it be that machine was converted from PHYSICAL to VIRTUAL, and that's where troubles came from?
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 24183903
What AV are you running?
0
 
LVL 18

Author Comment

by:Andrej Pirman
ID: 24191893
AV is NOD32, version 3.x on both systems.
But I think it should not interfere, since it is just simple AV for occasionall file scanning, without Firewall and with disabled real-time scan.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 24193530
There have been problems with NOD, SEP, and a couple more AV softwares that have been causing this issue on Server 2008. What I have found is that McAfee and AVG works well on this edition of server without slowing the network down and hanging network services. I would remove NOD for testing.
0
 
LVL 18

Author Comment

by:Andrej Pirman
ID: 24197402
Here...
I uninstalled NOD 32 from SERVER 2008 machine, but there is no change. Still extremelly slow!
I also uninstalled Network adapter from server, and reinstalled it, disabled it and enabled again...but again, no change.

Here are latest results in pictures, showing transfer of 150 MB file from XP CLIENT --> SERVER:
- on 1st picture SERVER is 2008
- on 2nd picture SERVER is 2003
Both servers are virtual machines on same ESX host, connected with Gigabit Full-Duplex (manually set) same NIC to same network, and in same AD Domain. And at time of testing, none of servers had NOD32 installed.
So everything is the same, except OS.

I'm becoming slightly mad...
bandwidth-problem-win2008-1.gif
bandwidth-problem-win2008-2.gif
0
 
LVL 18

Author Comment

by:Andrej Pirman
ID: 24200897
Digging into problem this night, I found some specific and interesting things:

- in problematic SERVER 2008 (inside ESX host) the default NIC adapter was Intel 1000E, and virtual machine was using  E1000 driver. I tried to install VMware Tools, but all I've got was a series of BSOD with "tcpip.sys" as faulty driver.

- so I simply added new NIC to this VM, of type "flexible" and installed it with AMD drivers. Then I disabled existing Intel E1000 adapter and moved all services to the new AMD Network Adapter.
Many things got broken in this step, beginning from Networking, and then seizing down many things way down to Group Policy, since SYSVOL share was not available anymore. So I spent few hours repairing domain controller, but finally I get it to work. After doing repairs, server was hooked at logon screen "Applying computer settings..." for more than an hour, but he was busy and did his job perfectly.

And not to mention main HEUREKA - Network speed is faster than light in both directions :))

- VMware Tools still refuse to install with "General system error occured: internal error". I tried to install it manually, but I simply cannot find WINDOWS.ISO VMware Tools installer package, actually...cannot find it on ANY of my ESXi host installations, neither on guest VMs.
So I quit from installing VMware Tools for now.

...30 minutes later: AGAIN THE SAME NETWORK SLOWLINESS!!!
I was really sure problem was gone, but NO - approx. half an hour later, I tested file transfer speed in both directions and again exact the same symptoms as before!
0
 
LVL 18

Author Comment

by:Andrej Pirman
ID: 24204808
SOLLUTION FOUND:

Being determined to dig into problem and solve it, I spent whole night at the facility and finally I found the problem cause and solved it. It was something unbeleiveably strange - domain replication hit tombstone limit!

This SERVER 2008 is the only DC in domain, but it was initially setup by doing live migration from existing DC from Windows 2000 OS. The catch was that after migration was done, old DC was not demoted from AD structure, but it simply died of HW failure.
Domain replication hit the problems, tombstone limit was due, and FSMO roles were not properly distributed. So NTFRS was failing, GPO became corrupt, and after reboot server was not able to became DC.
I won't describe the whole chain of problems here, which all arrised after I started digging. The main point is that after I did Authoritative Restore and after I rebuilt GPO, all netwroking problems dissapeared!

Thank you all for help.
I actually found sollution myself, but will split points for good intentions :)
0
 
LVL 11

Expert Comment

by:Chris Gralike
ID: 24204926
Those are some serious problems. Do check/Monitor all the FSMO roles over the comming period just to make sure.

If running 2008 the command is buildin, have a look at this arti
http://technet.microsoft.com/en-us/library/cc731968.aspx

Good luck!
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An article on effective troubleshooting
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question