outlook web access - failed login

Posted on 2009-04-19
Last Modified: 2013-12-14

For some reason today when I went to logon to outlook web access it came up with a HTTP 400 Bad request error. Now web access was working fine 3 days ago, but I was amending changes to exchweb(properties) before, so basicaly could I have changed something in the properties of exchweb that give the 400 error after i log in my credentials? for SSL or basic authentication etc?

I can view the interface for outlook web access on server/exchange but as soon as I put in my details and hit log on the web page fails and gives the 400 error. Im certain its in the exchweb properties but not sure what exactly what it is.....

Many thanks in advance,

Question by:J3D1-KN1G1-1t
    LVL 2

    Expert Comment

    hi jedi,
    your OWA might be corrupt.
    The link below might be able to help you.

    let me know how you go.


    Author Comment


    I dont think its corrupt as the interface is fine and it was working just two days ago......Im pretty sure its a setting that i need to look for...

    Thanks anyways

    LVL 4

    Expert Comment

    Try and use the settings on the microsoft article:

    Error message when an Outlook Web Access user tries to access a mailbox in Exchange Server 2003: HTTP 400 Bad Request (Request header too long)

    Author Comment

    Error message I get is 400 bad request https://server/exchweb/bin/auth/owauth.dll
    so i think the setting is related to authentication exchweb in the IIS.

    does anyoen know the default setting exchweb for authentication in the IIS? this might help..

    Thanks anyways numero_uno
    LVL 3

    Expert Comment

    If you are using OWA 2003 , please reset the virtual directories if you are not sure which setting you changed.Make sure you backup IIS before following commands in this article.

    How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003

    LVL 2

    Accepted Solution

    Hi Jedi,

    the easiest way will be resetting the whole OWA; the link is as per above in my comment.

    however; you can try this

    Open the IIS Manager and navigate to your server -> Web Sites -> Default Web Site -> ExchWeb.

    Right click on the ExchWeb directory, click Properties and select the Directory Security tab.

    Click the Edit button found in the Authentication and Access Control section to view the Authentication Methods dialog box.

    Make sure the Enable Anonymous Access checkbox is selected; also mark off the Integrated Windows Authentication checkbox.

    Click OK. You may see a dialog box asking you if you want to override inheritances. If this happens, click Select All, followed by OK.

    Click OK a couple more times and quit IIS Manager.


    Author Comment

    Thank you DAHIT and Girish

    It has come to resetting the virtual dirsctories....I will do this after hours when there are no clients logged on. As my I might have to restart the server if the v/directories arent created.

    Also I noticed that in the IIS console under deafult websites that Exchange said "the device is not connected" and Exadmin said ""The system cannot find the path specified"". which might be the root of this initall error 400...... hopefully this reset would fix it.

    Thanks for your great help I will update soon on this situation  

    Author Comment


    I re-creted teh virtual directories to the "tee" and I still got the same error..........

    so from this could it be the configuration setting in the directory exchange-oma ? because this directory didnt get recreated.

    does anyone know the settings for exchange-oma? which might help crack this.

    Many Thanks in Advance,


    Author Comment

    Problem Solved.....

    checked DNS setting is pointing to the local server, and re-added the DNS entry for Outlook Web Access
    set firewall settings again.

    The reason why I did this was when I went home I could log on OWA but internally I then I though it might be the DNS settings or firewall...... strange thing is though before I couldnt connect at all from home or office.

    Oh well main things is that it is up and runnig thank you for all your brilliant support.



    Featured Post

    Are your corporate email signatures appalling?

    Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

    Join & Write a Comment

    We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
    PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now