outlook web access - failed login

Hi,

For some reason today when I went to logon to outlook web access it came up with a HTTP 400 Bad request error. Now web access was working fine 3 days ago, but I was amending changes to exchweb(properties) before, so basicaly could I have changed something in the properties of exchweb that give the 400 error after i log in my credentials? for SSL or basic authentication etc?


I can view the interface for outlook web access on server/exchange but as soon as I put in my details and hit log on the web page fails and gives the 400 error. Im certain its in the exchweb properties but not sure what exactly what it is.....

Many thanks in advance,

Kesh
J3D1-KN1G1-1tAsked:
Who is Participating?
 
DAHITSydneyConnect With a Mentor Commented:
Hi Jedi,

the easiest way will be resetting the whole OWA; the link is as per above in my comment.

however; you can try this

Open the IIS Manager and navigate to your server -> Web Sites -> Default Web Site -> ExchWeb.

Right click on the ExchWeb directory, click Properties and select the Directory Security tab.

Click the Edit button found in the Authentication and Access Control section to view the Authentication Methods dialog box.

Make sure the Enable Anonymous Access checkbox is selected; also mark off the Integrated Windows Authentication checkbox.

Click OK. You may see a dialog box asking you if you want to override inheritances. If this happens, click Select All, followed by OK.

Click OK a couple more times and quit IIS Manager.

cheers.
0
 
DAHITSydneyCommented:
hi jedi,
your OWA might be corrupt.
The link below might be able to help you.

http://www.msexchange.org/tutorials/Fixing-Damaged-Incorrectly-Configured-OWA-2003-Installation.html

let me know how you go.

Cheers.
0
 
J3D1-KN1G1-1tAuthor Commented:
Hi

I dont think its corrupt as the interface is fine and it was working just two days ago......Im pretty sure its a setting that i need to look for...

Thanks anyways

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
numero_unoCommented:
Try and use the settings on the microsoft article:

Error message when an Outlook Web Access user tries to access a mailbox in Exchange Server 2003: HTTP 400 Bad Request (Request header too long)
http://support.microsoft.com/kb/920862
0
 
J3D1-KN1G1-1tAuthor Commented:
Error message I get is 400 bad request https://server/exchweb/bin/auth/owauth.dll
so i think the setting is related to authentication exchweb in the IIS.


does anyoen know the default setting exchweb for authentication in the IIS? this might help..

Thanks anyways numero_uno
0
 
Girish_2500Commented:
If you are using OWA 2003 , please reset the virtual directories if you are not sure which setting you changed.Make sure you backup IIS before following commands in this article.

How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003

http://support.microsoft.com/kb/883380


0
 
J3D1-KN1G1-1tAuthor Commented:
Thank you DAHIT and Girish

It has come to resetting the virtual dirsctories....I will do this after hours when there are no clients logged on. As my I might have to restart the server if the v/directories arent created.

Also I noticed that in the IIS console under deafult websites that Exchange said "the device is not connected" and Exadmin said ""The system cannot find the path specified"". which might be the root of this initall error 400...... hopefully this reset would fix it.

Thanks for your great help I will update soon on this situation  
0
 
J3D1-KN1G1-1tAuthor Commented:
Hi,


I re-creted teh virtual directories to the "tee" and I still got the same error..........

so from this could it be the configuration setting in the directory exchange-oma ? because this directory didnt get recreated.

does anyone know the settings for exchange-oma? which might help crack this.

Many Thanks in Advance,

0
 
J3D1-KN1G1-1tAuthor Commented:
Problem Solved.....

checked DNS setting is pointing to the local server, and re-added the DNS entry for Outlook Web Access
set firewall settings again.

The reason why I did this was when I went home I could log on OWA but internally I couldnt.....so then I though it might be the DNS settings or firewall...... strange thing is though before I couldnt connect at all from home or office.

Oh well main things is that it is up and runnig thank you for all your brilliant support.

Regards

J3d1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.