?
Solved

USB drives won't automount in XP, will show up if device plugged in while booting

Posted on 2009-04-19
13
Medium Priority
?
589 Views
Last Modified: 2012-06-27
Hi,

I have an XP Precision 380 that if I plug any usb drive into any of the usb slots, Windows won't mount it. However, if I uninstall all USB from the Device Manager, plug in the drives, and then scan for hardware changes, the drives will mount. Also, if you boot with the usb drives plugged in, they will mount. Any idea what I can do to make automount work again?

Thanks!
0
Comment
Question by:jennx
  • 6
  • 3
  • 2
  • +1
13 Comments
 

Expert Comment

by:w3bdesign
ID: 24181356
Try this:

STEP 1

Back up any important data on the pen drive.


STEP 2

Use a low-level formatting tool to low-level format the pen drive (GParted cannot do it, GParted can only perform a normal format). I used a freeware utility for Windows called HDDGURU Low Level Format Tool (http://hddguru.com/) as I do not know of one for Linux.


STEP 3

Use GParted to format the pen drive to FAT32 and then set the boot bit.


The pen drive should then be able to automount. Some pen drives work fine without having to perform this procedure, others need to be low level formatted.
0
 

Author Comment

by:jennx
ID: 24181380
Thanks for your response. This happens with ALL usb drives. And they're usb drives that I can plug into other computers and they work. So it's not the device. It's something in XP that's preventing the automount.
0
 

Expert Comment

by:w3bdesign
ID: 24181418
In that case, it sounds like a driver issue. I would do this:

Right click My Computer->Properties->Device Management, delete the USB Controllers, reboot and let Windows
reinstall everything.

That way, you are uninstalling the USB drivers, and reinstalling them again, which should fix the problem. Also, what motherboard do you currently have? You may need to visit your motherboard's manufacturer's website and download the drivers again, if you don't have a driver CD/DVD.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:jennx
ID: 24181471
I did delete the USB Controllers. When I do that, plug in the usb drives, and "check for hardware changes," the usb drives appear. If I unplug them at that point and try to plug them in again, they don't show up. Also, I reinstalled the latest Chipset driver for my system from the Dell site. I feel like there has to be a setting in Windows that's preventing the automount.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24182048
Removable Storage Service starting with Windows, and not just set to Manual?

Plug and Play Service also set to Automatic?

Check to see if these are both running PRIOR to plugging in the drives....
0
 

Author Comment

by:jennx
ID: 24182124
They were both set to manual and neither one was running. I set both to automatic and restarted the machine. I confirmed that both were started. I plugged in a drive. It didn't automount. Bummer.
0
 
LVL 66

Assisted Solution

by:johnb6767
johnb6767 earned 400 total points
ID: 24182159
Odd.....

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

Delete the entries at the bottom that look like the following..... Dont delete the one that holds your Boot Drive (EG. The C Drive)

\DosDevices\C: (DONT DELETE THIS ONE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!)

And please backup the MountedDevices registry key prior to doing this....

0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24182160
I think I stressed the importance of that value enough??

Then reboot.... And keep your fingers crossed....
0
 
LVL 93

Accepted Solution

by:
nobus earned 1600 total points
ID: 24182431
try these : (one at the time...)
Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

http://support.microsoft.com/kb/925196

OR :
Remove all USB drivers with:     https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usb.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbport.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbprint.inf
0
 

Author Comment

by:jennx
ID: 24186104
I did all of the suggestions listed by nobus and johnb. None of them worked. One bright spot is that that renewusb batch file that nobus provided does provide an enduser friendly workaround. The enduser could insert their usb drive, click on that file and the drive will show up. Lame, but workable on this machine. I'm still open to suggestions though. It's just the weirdest thing.













0
 
LVL 93

Expert Comment

by:nobus
ID: 24186132
maybe this can help :  start>run>diskmgmt.msc         If they show up in disk management, do :
start>run>services.msc

In the listing look for removable storage service.
Is is set to Auto, and if not started, click the Start link in the top left...

Download the latest drivers for the chipset, and reinstall it to update the USB root hubs
0
 

Author Comment

by:jennx
ID: 24186397
They don't show up  disk management unless you restart the computer or reinstall the usb devices. Removable storage service is set to automatic and installed. I did install the latest chipset that Dell provides. I think a rebuild is in order, but I'll have to schedule that with the end user. I'll try any additional suggestions though. I hate rebuilding.
0
 

Author Comment

by:jennx
ID: 24191031
Ok, so the last thing I did worked? I went into HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class, went through the keys and deleted all UpperFilters and LowerFilters that had anything to do with storage. Not the smartest thing perhaps, but then when I inserted a usb stick it worked. It also, made my Dell recovery store mount which I'm not thrilled about, but, hey, usb sticks mount which was the goal. Thanks everyone.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Like many organizations, your foray into cloud computing may have started with an ancillary or security service, like email spam and virus protection. For some, the first or second step into the cloud was moving email off-premise. For others, a clou…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question